If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Problem with autocompletion on entering an email address

RESOLVED DUPLICATE of bug 970456

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 970456
3 years ago
3 years ago

People

(Reporter: Daniel B, Unassigned)

Tracking

31 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E; rv:11.0) like Gecko

Steps to reproduce:

Then I compose a new email, I type the letters "ol" in the "To:" field.


Actual results:

I get a match for the email address "name@mollehem.com".


Expected results:

The letters I type should ONLY match at the beginning of a word. The letters "ol" should never match the word "mollehem".

This worked fine in the previous version of Thunderbird but is broken in Thunderbird 31.1.0.

In earlier versions of Thunderbird I could type "ol" and press <Tab> and I got the correct email address. In the new version of Thunderbird I need to type "olle" and still has to select the correct recipient. This is very irritating.
Yes Daniel, we're addressing these issues in Bug 1012397 and Bug 970456 respectively.
"Contains"-matches are very powerful for a lot of usecases, but we'll sort them further down into your autocomplete results so that your most likely matches should return to the top.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 970456
You need to log in before you can comment on or make changes to this bug.