Closed Bug 10643 Opened 21 years ago Closed 21 years ago

Necko --> Get New Mail for Pop sometimes doesn't show correctly

Categories

(MailNews Core :: Networking, defect, P3)

All
Windows NT
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 10905

People

(Reporter: mscott, Assigned: mscott)

Details

I haven't been able to narrow this down yet, but sometimes when I get new mail
for pop, we download the messages. The headers show up in the thread pane
correctly. However, when you goto display a message the new messages that were
donwloaded don't display or they don't display correctly.

It appears that we are reading the wrong byte ranges out of the berkley mail
folder. If I look at the tempMessage.eml that I write out when we goto display a
message, you can clearly see that we are reading in the end of the previous
message and only the first part of the message we're trying to show.

I'm still trying to track this one down.
Status: NEW → ASSIGNED
Target Milestone: M9
Scott- I think that all bugs which occur in Necko, but not in non-Necko builds
should have component set to "Necko".  Correct, Jan?
Since necko is landing within an hour, there really won't be such a thing as a
regular non-necko build. I think this is a mailnews networking bug and would
like to keep the component there. I guess I've already made the transition that
everyone else will be making today that there is only necko =).

I don't think mailnews networking bugs should be filed as necko bugs. We should
probably just be using Networking-Mail from here on out. I've been trying to
only assign necko bugs to bugs that are actually in necko and not mailnews
(i.e. bugs on warren's team). Does that make sense?
Ok!
I believe this bug may turn out to be a duplicate of Bug #10905 where necko
can't open files > meg or so.

The inbox I'm having this problem with is about 7MBytes. After visual
inspection, it appears that new messages are correctly being written into my
Inbox (this act doesn't use necko). But the display of the messages is messed up
(and this does use necko).

I'll try it out on a QA account where the inbox is small and much less than a
megabyte. If we can display new messages in this case then this bug is probably
a duplicate.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Marking as a duplicate of bug #10905.

*** This bug has been marked as a duplicate of 10905 ***
Status: RESOLVED → VERIFIED
marking verified as duplicate.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.