[BLOCKER] Necko: Whole mailbox doesn't get parsed

VERIFIED FIXED in M9

Status

()

P1
blocker
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: scottputterman, Assigned: warrensomebody)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Looks like a necko problem with large files...waiting for necko to confirm.)

(Reporter)

Description

19 years ago
Right now it looks like only one call to OnDataAvailable is being made to
nsParseMailbox and there's no Stop call.  Because it's happening in 1MB chunks,
the 1st 1MB worth of headers get parsed, but in my folder of 1000 messages which
takes up 7MB, most of the headers don't show up.

Updated

19 years ago
Status: NEW → ASSIGNED
Whiteboard: Looks like a necko problem with large files...waiting for necko to confirm.

Comment 1

19 years ago
I believe this is a necko bug the more I think about it. They had some problems
with reading in large files and I remember a temporary work around being to set
the following buffer size:

NS_FILE_TRANSPORT_BUFFER_SIZE  (1024*1024)

My guess is, Scott's berkley mail folder is larger than this size and that's why
we can't read it out.

I've emailed rick potts and warren to get their open. I'll post it here. I'll
also try to find the necko bug for this problem and will mark this a dup of it
if that turns out to be the case.

Updated

19 years ago
Severity: normal → blocker
Component: Necko → Networking-Mail
Priority: P3 → P1
Summary: [BLOCKER] Whole mailbox doesn't get parsed → [BLOCKER] Necko: Whole mailbox doesn't get parsed

Comment 2

19 years ago
We are going to get rid of the "necko" component for mail/news soon per mscott.

Updated

19 years ago
Target Milestone: M9

Comment 3

19 years ago
setting tfv to m9..still haven't heard back from rick and warren yet.

Updated

19 years ago
Assignee: mscott → warren
Status: ASSIGNED → NEW
Component: Networking-Mail → Necko

Comment 4

19 years ago
Re-assignng to warren. This bug is a manifestation of necko's problem
with really large files. Setting component to necko because this really is a
necko bug and not a mailnews networking problem.

Warren, this should be pretty easy to test without using messenger. The file
tests in netwerk should trigger the problem too if the file is big enough.

Comment 5

19 years ago
(mscott - do you want the product to be Browser rather than MailNews?  I thought
you wanted to get rid of the Necko component in the MailNews product.)

Updated

19 years ago
Product: MailNews → Browser

Comment 6

19 years ago
Yeah your right...the product should be browser..I'm setting that now.
(Reporter)

Updated

19 years ago
Blocks: 11091
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 7

19 years ago
*** Bug 10643 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Blocks: 11349
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

19 years ago
Scott, I think I've got this fixed now. At least things are much happier when I
crank the file buffer size way down -- I assume the large mailbox size is the
converse problem. Let me know if it doesn't work.
(Reporter)

Comment 9

19 years ago
Yes, this is working for me now.  Thanks for fixing this.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
this is now working.

Comment 11

19 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
You need to log in before you can comment on or make changes to this bug.