GET/SET CLIR (calling line identity restriction) calls on boot up causing GCF failures

RESOLVED FIXED in 2.1 S6 (10oct)

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: anshulj, Assigned: arthurcc)

Tracking

unspecified
2.1 S6 (10oct)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 affected, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [caf priority: p2][cr 718645])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
On Firefox OS the get/set CLIR APIs are called every time on bootup. This is interfering with GCF conformance testing, which is not very sympathetic toward any unexpected NW related requests. Because of this, any SS/USSD/SMS related tests are being given a fail verdict.

[Blocking Requested - why for this release]: This issue is blocking couple of GCF certification test cases.
(Reporter)

Comment 1

4 years ago
The GCF tests pass on Android and on further analysis I found that Android doesn't set/get the CLIR setting after loading a new build as the default setting is -1. Once a user goes to the settings UI the call to get CLIR is made as expected. Once the CLIR setting is updated in the database, Android as well get/set CLIR on reboots there after.

So the only difference is the very first time after a fresh build load, which is when the GCF tests are run.
Whiteboard: [cr 718645]
Assignee: nobody → arthur.chen

Comment 2

4 years ago
Triage: blocking as certification test case
blocking-b2g: 2.1? → 2.1+

Updated

4 years ago
Target Milestone: --- → 2.1 S5 (26sep)
Status: NEW → ASSIGNED
Created attachment 8495074 [details]
link to https://github.com/mozilla-b2g/gaia/pull/24417

Alive, could you help review this simple patch? The intention is to avoid setting caller id when there is no user preference (that is also the same time when the GCF certification test is performed). Once users set their preference in settings, the behavior is as usual.

Anshul, please help check if the patch works, thanks!
Attachment #8495074 - Flags: review?(alive)
Attachment #8495074 - Flags: feedback?(anshulj)
Attachment #8495074 - Flags: review?(alive) → review+
(Reporter)

Comment 4

4 years ago
Arthur, I see different behavior between 2.0 and 2.1 w.r.t. CLIR setting with and without your change. Please find the details below.

FFOS 2.0
- After a new build load, Set and Get CLIR are called on boot up with the default value of 0
- If I change the setting to say 2, then Set and Get CLIR are called on bootup with the new value of 2.

FFOS 2.1 (without your change)
- After a new build load, only Get CLIR is being called
- Once the phone is up, when I go to the settings app, I see Get CLIR being called twice instead of one time.
- I change the CLIR to say 2(show number) and reboot. I only see Get CLIR being called.

FFOS 2.1 (with your change)
- I see the exact same behavior on 2.1 as without your change.

So it seems like there is a regression in 2.1 in that set CLIR is not being called on bootup anymore and so I am unable to verify if your change is fixing the issue.
(Reporter)

Comment 5

4 years ago
Filed bug 1074499 for the issue with set CLIR not working.
(Reporter)

Comment 6

4 years ago
Comment on attachment 8495074 [details]
link to https://github.com/mozilla-b2g/gaia/pull/24417

With the bug 1028544 reverted, I am able to test this patch and find it working as expected.
Attachment #8495074 - Flags: feedback?(anshulj) → feedback+
master: b945f8885b189f0dcea8ef510bc58337b68f72c2

I'll check if the patch for bug 1028544 is valid.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
Resolution: --- → FIXED
Comment on attachment 8495074 [details]
link to https://github.com/mozilla-b2g/gaia/pull/24417

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: This is a certification blocker
[Testing completed]: Manual tests were completed. Unit tests were added.
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: N/A
Attachment #8495074 - Flags: approval-gaia-v2.1?
Attachment #8495074 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/9d588ec5f09096c113913f2db2c216e2caf89ff1
status-b2g-v2.1: affected → fixed
Target Milestone: 2.1 S5 (26sep) → 2.1 S6 (10oct)
Whiteboard: [cr 718645] → [caf priority: p2][cr 718645]
Hi,Anshul 
Could you provid the step details for me?
thanks.
Flags: needinfo?(anshulj)
(Reporter)

Comment 11

4 years ago
Alissa, the steps are pretty basic. Reboot the phone and make sure no CLIR calls are sent to RIL.
Flags: needinfo?(anshulj)
Hi Arthur, could you help to describe how to make sure if CLIR calls are sent to RIL? If any log or information Alissa can follow to verify this issue?
Flags: needinfo?(arthur.chen)
Hsinyi, is there any log from gecko providing such information?
Flags: needinfo?(arthur.chen) → needinfo?(htsai)
Hi,
You could grep the string "setCLIR" or "getCLIR". If you see them, that means gecko receives the commands.
Flags: needinfo?(htsai)
This issue has been verified successfully on  2.1, 2.2.
Reproducing rate: 0/5
Flame 2.1 build:
Gaia-Rev        77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/4c28bb3be0c6
Build-ID        20150121001510
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150121.034530
FW-Date         Wed Jan 21 03:45:41 EST 2015
Bootloader      L1TC000118D0
Flame 2.2 
Gaia-Rev        e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/75a462a58d7a
Build-ID        20150121002607
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150121.040751
FW-Date         Wed Jan 21 04:08:02 EST 2015
Bootloader      L1TC000118D0
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.