Get Started for Android - content development

RESOLVED FIXED

Status

Marketing
Design
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: Yuan, Assigned: Troy Palmer)

Tracking

(Blocks: 1 bug)

Details

Attachments

(2 attachments)

>>Project/Request Title:
Get Started for Android - content development

>>Project Overview:
Create a "Get Started" tour  for new Firefox Android users.  With this new tour, we are hoping to communicate with users about what makes Firefox special and valuable to you.

This is currently targeting Firefox 35, I believe



>> Creative Help Needed:
Copy:    Yes 
Design:  Yes 
Video:   No 
Other:  No

>>Creative Specs:
We are planning to use illustrations to communicate each theme, so it'd be great to have creative team work together with Product UX on this! Also be consistent about the messages we are communicating through the copies. 

I think Arcadio has confirmed that these three themes: Customization, Privacy, Sync, will fit nicely with the marking campaign and the new website. 


>>CTA and Design:
We currently have a splash screen for Firefox 34: https://bug1042809.bugzilla.mozilla.org/attachment.cgi?id=8464395 

The format for the "Get started" tour will likely be 3-4 screens that the user can swipe through to navigate. The user can keep swipe one more to get to the Firefox Home Page.

>>Creative Due Date:
2014-10-14

>>Launch Date:
2015-01-06

>>Mozilla Goal:
Firefox Browser

>>Points of Contact:
mark.finkle@gmail.com, krudnitski@mozilla.com, alam@mozilla.com, madhava@mozilla.com

Comment 1

4 years ago
Adding Troy as well since he's working on the product page for Android. Just FYI for now.

Comment 2

4 years ago
Hi Yuan. Thanks for filing this...we're always glad for the chance to integrate our work with the product team (and vice versa). So I'm clear, is there a design request here? Who is working on those illustrations?

Regardless of those answers, I think it would be good for my team to be plugged into this so we can make sure the illustration styles in this tour match our illustration styles elsewhere.
(In reply to John Slater from comment #2)
> Hi Yuan. Thanks for filing this...we're always glad for the chance to
> integrate our work with the product team (and vice versa). So I'm clear, is
> there a design request here? Who is working on those illustrations?
> 
> Regardless of those answers, I think it would be good for my team to be
> plugged into this so we can make sure the illustration styles in this tour
> match our illustration styles elsewhere.

Hi John,
Great to hear! The product UX team will be taking the lead on design. Anthony Lam, Designer on Android team, has expressed interests working on the illustrations for this tour.

I did put "Design" request there because I would expect both team to sync up on the visual style of the illustrations and the overall look and feel.
Blocks: 1059441

Comment 4

4 years ago
Hi Yuan, 

I'm assigning this over to Troy since he's been working on copy for the product page. I've also added Lee Tom who's been doing the design work for that.
Assignee: jbalaco → troy
Status: NEW → ASSIGNED

Comment 5

4 years ago
Thanks, Jennifer.

Troy, nothing for you to do immediately, but stay tuned for more details.
(Assignee)

Comment 6

4 years ago
Sounds good. Thanks.
Hey guys, 

Trying to pick this up again from Yuan's departure. 

It sounds like the outline provided by Yuan is still valid and would make for a great starting point. Since we will need to do some extra sync up around the "illustrations" part, let's focus on the content first? We could pick this back up by starting on getting the copy for each of the 3 screens/themes and then coming together to discuss imagery (whether that's screen shots or illustrations or what not).

I don't want to prescribe any solutions here but something that simply follows the structure of what we currently have would be extremely helpful (headline and body copy).

Also, CC'ing Gemma our UR specialist since we've been tag teaming the thinking behind this.
Flags: needinfo?(troy)
Flags: needinfo?(Mnovak)
Also ensuring that this is on Arcadio's radar to help coordinate the wording.
Flags: needinfo?(alainez)

Comment 9

3 years ago
What's the current status of this? Are there mock-ups?

A meeting outside of Bugzilla is in order to put the ask on the table. 

I'm available Wednesday afternoon.
Flags: needinfo?(alainez)
Agree with Arcadio. There's a lot going on right now, so let's make sure this has a clear plan and timeline, one that works with all the other pieces we're currently working on. Thanks.
Flags: needinfo?(troy)
Flags: needinfo?(Mnovak)
Ping on the status here?
Flags: needinfo?(alainez)
Met with Arcadio and Chenxia in SFO...

some notes:
 - Arcadio will need to have content done by first week of January
 - "Content" at this point will be multiple 'slides' (3/4)
 - Backup plan will be to inherit current content and keep it to 1 'slide'
 - Chenxia will continue to implement the new UX/UI before she leaves for PTO
 - Anthony will take content and update the new "slides" with imagery to match
QA Contact: cristina.madaras
Adding a note to get the final copy (once we get it from Arcadio) tested and in sync with UR as per Karen's request :) before we uplift.

Comment 14

3 years ago
Have recently asked Matej to review tour flow and sample copy. 

Copy doc here: https://docs.google.com/a/mozilla.com/document/d/10TT7sCl3hEGcX97RfmU1UdMNln1Wbx6zoT2fic8evFk/edit?usp=sharing
Flags: needinfo?(alainez)
(In reply to alainez from comment #14)
> Have recently asked Matej to review tour flow and sample copy. 
> 
> Copy doc here:
> https://docs.google.com/a/mozilla.com/document/d/
> 10TT7sCl3hEGcX97RfmU1UdMNln1Wbx6zoT2fic8evFk/edit?usp=sharing

I've added a few notes and revisions. Would be good to get the new stuff into layout so we can see if it all fits.
Thanks Matej and Arcadio! This copy looks great :)

A few things I want to mention - I think we'd like to break this into two pieces, one with more screens, and one with more interactive content (installing addons, making changes to Firefox, etc). Let's talk to Anthony as well about how that experience will work.

I made some comments in the document. Some of them might be easier to resolve through discussion.

I can put add these into the first run experience pretty easily - I'll ask Anthony for some icons/visuals, and put a build together probably in the next few days for you to look at.
Flags: needinfo?(alam)
(In reply to Chenxia Liu [:liuche] from comment #16)
> Thanks Matej and Arcadio! This copy looks great :)
> 
> A few things I want to mention - I think we'd like to break this into two
> pieces, one with more screens, and one with more interactive content
> (installing addons, making changes to Firefox, etc). Let's talk to Anthony
> as well about how that experience will work.
> 
> I made some comments in the document. Some of them might be easier to
> resolve through discussion.
> 
> I can put add these into the first run experience pretty easily - I'll ask
> Anthony for some icons/visuals, and put a build together probably in the
> next few days for you to look at.

Thanks guys. I've also left some comments in the google doc.

As Chenxia pointed out, we'll have to break this up into two parts. 

We also have UI/UX updates to the current "welcome screen" well on its way and we can try to make copy changes to that. That work is separate to the multiple slide stuff we're talking about here (just wanted to mention that :)

For the "welcome screen" I will just lift the copy of the first "slide" in the copy docs here if that's alright, otherwise we can just keep what we have. That way, we can try to at least get updated copy for the "welcome screen".
Flags: needinfo?(matej)
Flags: needinfo?(alam)
Flags: needinfo?(alainez)
I shared a shorter copy option in the gdoc, but here are some others as well:

Welcome to Firefox
The features you love. The privacy you trust. 

Welcome to Firefox
Our most customizable browser yet.

Welcome to Firefox
The best in features, privacy and customization.

Welcome to Firefox
More privacy features and ways to customize than ever.
Flags: needinfo?(matej)
Created attachment 8562304 [details]
prev_welcomescr_mock1.png

Thanks Matej! We'll go ahead and use the first one in this list.

Chenxia, could we update the welcome screen with these copy changes?

Matej, we'll need to figure out the other slides too for the next part :)
Flags: needinfo?(liuche)
^ "Tell me more" can be updated later when we start doing the multiple screens, for the time being we could stick to the "Sign in to Firefox" copy I think.
(In reply to Anthony Lam (:antlam) from comment #19)
> Created attachment 8562304 [details]
> prev_welcomescr_mock1.png
> 
> Thanks Matej! We'll go ahead and use the first one in this list.

Let's just make sure that Arcadio sees and approves this as well. Thanks.
Created bug 1131806 and updated with screenshots.
Flags: needinfo?(liuche)
The text wrap looks to be not ideal.

Chenxia, could we go with "More privacy features and ways to customize than ever." instead?

I know it's not ideal to just change this copy for the visuals but alas, we need to adjust since we didn't design with the copy :\
Flags: needinfo?(liuche)
Updated in bug 1131806.
Flags: needinfo?(liuche)

Comment 25

3 years ago
Can this bug be resolved? It looks like you have the copy that was needed.
(In reply to Jennifer Balaco from comment #25)
> Can this bug be resolved? It looks like you have the copy that was needed.

This project is ongoing, but I'm not sure of the current status. Maybe it would be better to file a new bug as needs arise?
Yep! Closing this bug, and we'll file another when needed. This copy was used (and landed) with bug 1131806.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(alainez)
Resolution: --- → FIXED
Can I assume this bug is for the content only at this point and we're not landing the copy in anything that can be uplifted past Aurora?

Just double checking :)
See: https://bug1131806.bugzilla.mozilla.org/attachment.cgi?id=8564368

The copy for the Welcome Screen above is currently on Aurora, and is on track to ride the trains through release on 38. It replaces the old first run screen (which I think we all agree was rushed in for partner reasons and was not as good is it could have been) which has been on release since 34, so this is a strict improvement.

From our discussions for improved first run experience (multi-page) my understanding is that those are on hold until we can do some extensive user studies based on multi-screen flow + copy.
(In reply to Karen Rudnitski [:kar] from comment #28)
> Can I assume this bug is for the content only at this point and we're not
> landing the copy in anything that can be uplifted past Aurora?
> 
> Just double checking :)

This bug has developed to be just about the copy on our "welcome screen". That is, the single "slide" that users currently see. Reason being, we wanted to update what Yuan already had riding the trains as we spent more time on a more though-out, multi-slide, experience (First Run).

All in all, yes - this bug is just for content at this point. But it will pass Aurora.

But - this is not "First Run", simply "Welcome Screen". We're only changing the body copy, not the Call to Action or anything. Chenxia will attach screenshots.
Created attachment 8576257 [details]
Screenshot: First run 34 and 38

Reporting for screenshot duty!

These are the two welcome screens that are currently in the tree. The first one has already been released with Firefox 34, and the second one (full screen, blue/white) is riding the trains with 38.
Sorry for the fire drill - and thank you! Yes, this makes sense, is clear and what was discussed and expected. Teaches me to read the bugs fully for a refresh instead of jumping in :/

Thanks :)
You need to log in before you can comment on or make changes to this bug.