[RTL] Short day names in Calendar should reflect language setting.

VERIFIED FIXED

Status

P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: swilkes, Unassigned)

Tracking

unspecified
x86
Mac OS X
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, ux-b2g:2.2, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Select Arabic language in Settings.
Open Calendar app.
Choose Week view, at bottom.
Observe that the short day names in the calendar are shown in English and not Arabic.

Expected: Short day names in the calendar reflect appropriate Arabic abbreviations, not English ones. This is available in the International Component for Unicode.
RTL triage: P2 -- will make a best effort to get this into the 2.2 release.
Priority: -- → P2
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
feature-b2g: --- → 2.2+
This is a l10n issue, should be fixed on gaia-l10n side.

Comment 4

4 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15239/
Flags: in-moztrap+
Delphine, can you mark this bug so that it gets visibility in the l10n queue?
Flags: needinfo?(lebedel.delphine)
Sure!
Adding Rami, Ahmed, Manel and Youghourta so they can get to this asap :)
Doing so since this is more of an urgent case. But please do note that string freeze isn't before April 4th (same as FC) so there might be instances where there is untranslated UI until 1 or 2 weeks after that date (historically, that's how long it takes for l10n teams to catch up with any pending l10n work after string freeze)
thanks all!
Flags: needinfo?(youghourta)
Flags: needinfo?(rami223)
Flags: needinfo?(nefzaoui)
Flags: needinfo?(manel.rhaiem92)
Flags: needinfo?(lebedel.delphine)
(Reporter)

Comment 7

4 years ago
Adding Kaze since he is going to help with reviews on this, as Ahmed's queue is quite full.
Flags: needinfo?(fabien)
Created attachment 8565077 [details]
cal_rtl_month_names_1.png

I just updated using a OTA (because they pull locale files straight from the gaia-l10n hg repository) and confirmed it is working as expected.

Adding one more screenshot.
Flags: needinfo?(nefzaoui)
Created attachment 8565079 [details]
Week View::cal_rtl_month_names_2.png
Plus, knowing that gaia-l10n on HG is still 2.2 this means it is working for both 3.0 and 2.2 \o/
And based on that, closing. :)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Awesome! Marking as verified fixed as per the screenshots, and clearing all the unecessary ni's
thanks!
status-b2g-v2.2: --- → verified
status-b2g-master: --- → verified
Flags: needinfo?(youghourta)
Flags: needinfo?(rami223)
Flags: needinfo?(manel.rhaiem92)
Flags: needinfo?(fabien)

Comment 12

4 years ago
According to Comment 11, switch the status.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.