[Calendar] Short week day names on month view are wrong when weekStartsOnMonday = 1

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: tchevalier, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 unaffected, b2g-master unaffected)

Details

Attachments

(2 attachments)

For locales where weekStartsOnMonday = 1 (French for instance [1]), the short week day names displayed at the top of month view are wrong.

See attached screenshot comparing 2.0 with current master, it's probably easier to understand what I mean.



[1] https://hg.mozilla.org/gaia-l10n/fr/file/c0718864b286/shared/date/date.properties#l206
+ qawanted to check 2.1 and 2.2.
Keywords: qawanted
I can confirm it happens on 2.2
BTW, we are deprecating the `weekStartsOnMonday` in favor of `firstDayOfTheWeek` (because in some locales the week starts on Saturday)
See Also: → 1059017, 1064607
Posted image Flame 2.1 screenshot
Flame 2.1 is unaffected. See screenshot.

Device: Flame 2.1
BuildID: 20150130061138
Gaia: 63f291df9b9ad8498fb8fc7fb8bf070524406a5c
Gecko: cd88c8b3cb43
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Duplicate of this bug: 1129067
?ni me to check why this happened; not sure if it was introduced during month view refactor, a11y work, RTL, or if it's just something that changed on the french locale.
Flags: needinfo?(mmedeiros)
triage: blocking for regression
blocking-b2g: --- → 2.2+
this should be fixed after we update the french locale and add the `firstDayOfTheWeek = 1` to "date.fr.properties".

we already have the proper `weekday-${i}-single-char` for fr (http://transvision.mozfr.org/?recherche=apps%2Fcalendar%2Fcalendar.properties&repo=gaia&sourcelocale=en-US&locale=fr&search_type=entities).

one thing that is weird to me is that transvision still doesn't know about `firstDayOfTheWeek` even for the en-US locale.

this string was added because on some locales the first day of the week is actually Saturday.
Flags: needinfo?(mmedeiros)
Gaia Master on Transvision maps to gaia-l10n (there's no Gaia 2.2 until l10n actually branches)
https://hg.mozilla.org/gaia-l10n/

gaia-l10n is not currently mapping master but 2.2, the problem is that 2.2 string extraction was stuck because of bug 1105304. Next week it should start updating again.
The weird part is that I can't reproduce anymore on master...

Until now I hadn't changed anything to the French l10n, but I just pushed tonight firstDayOfTheWeek = 1 to master and 2.2 French l10n repo : https://hg.mozilla.org/gaia-l10n/fr/rev/ba490d6af1e4#l4.15

Let's see in next build if it's still working.
Actualy Flame OTA has been made available a few minutes ago. With firstDayOfTheWeek = 1 now on French locale, weeks are starting on monday (as expected) and the short name is now right (L for Lundi, D for Dimanche, etc.)

I guess a check on 2.2 wouldn't hurt.
ni? to Théo as a reminder to check this one on 2.2 and comment here.
Flags: needinfo?(theo.chevalier11)
Alright, looks good on 2.2 as well.
As said in c#8, this will be fully fixed once the string firstDayOfTheWeek will be translated for each locale.
No branch affected, I guess we can close this one ;)

Checked on Flame with French on the following build

Gaia-Rev        ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d04b78eeb536
Build-ID        20150213002503
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141214.073044
FW-Date         Sun Dec 14 07:30:57 EST 2014
Bootloader      L1TC000118D0
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(theo.chevalier11)
Resolution: --- → WORKSFORME
Duplicate of this bug: 1134203
See Also: → 1054987
You need to log in before you can comment on or make changes to this bug.