B2G RIL: treat 0x90, 0x91, 0x9E and 0x9F as a success results for sw1 regarding ICC_IO.

RESOLVED FIXED in Firefox 34

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sku, Assigned: sku)

Tracking

unspecified
2.1 S4 (12sep)
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0M+, firefox33 wontfix, firefox34 fixed, firefox35 fixed, b2g-v2.0 wontfix, b2g-v2.0M fixed, b2g-v2.1 fixed, b2g-v2.2 fixed)

Details

Attachments

(2 attachments, 2 obsolete attachments)

Assignee

Description

5 years ago
Per 3GPP TS 11.11 clause 9.4.1 Responses to commands which are correctly executed, 0x90, 0x91, 0x9E and 0x9F should all be treated as a success result for sw1 regarding ICC_IO. However, B2G only treats 0x90 (ICC_STATUS_NORMAL_ENDING) as a success result currently.


[1] - http://dxr.mozilla.org/mozilla-central/source/dom/system/gonk/ril_worker.js?from=ril_worker.js&case=true#5857
Assignee

Updated

5 years ago
Assignee: nobody → sku
Assignee

Updated

5 years ago
Blocks: 1058409
Assignee

Updated

5 years ago
Attachment #8486148 - Flags: review?(echen)
Assignee

Updated

5 years ago
blocking-b2g: --- → 2.0M?
Comment on attachment 8486148 [details] [diff] [review]
Bug 1064647 - B2G RIL: treat 0x90, 0x91, 0x9E and 0x9F as a success results for sw1 regarding ICC_IO.

Review of attachment 8486148 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you.
Attachment #8486148 - Flags: review?(echen) → review+
Francis, would you like to triage this?
Flags: needinfo?(frlee)
per comment 7, 2.0m+
blocking-b2g: 2.0M? → 2.0M+
Flags: needinfo?(frlee)
Do we need this on v2.1 as well?
Flags: needinfo?(sku)
Assignee

Comment 12

5 years ago
Hi Ryan:
 Once we need it on v2.1, will request check-in then.

Thanks!!
Shawn
Flags: needinfo?(sku)
https://hg.mozilla.org/mozilla-central/rev/5a69f9fca5ab
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S4 (12sep)
Duplicate of this bug: 926053
Comment on attachment 8486437 [details] [diff] [review]
Bug 1064647 - B2G RIL: treat 0x90, 0x91, 0x9E and 0x9F as a success results for sw1 regarding ICC_IO. r=Edgar.

Approval Request Comment
[Feature/regressing bug #]: NA
[User impact if declined]: Unable to access some EF on particular SIM card. (i.e. fail to import sim contact, see bug 926053)
[Describe test coverage new/current, TBPL]: The changes follows spec and we have tested with real devices, it works good.
[Risks and why]: low
[String/UUID change made/needed]: NA
Attachment #8486437 - Flags: approval-mozilla-aurora?
Comment on attachment 8486437 [details] [diff] [review]
Bug 1064647 - B2G RIL: treat 0x90, 0x91, 0x9E and 0x9F as a success results for sw1 regarding ICC_IO. r=Edgar.

Approving due to same reason as https://bugzilla.mozilla.org/show_bug.cgi?id=1061380#c19 and NI anshul so he's aware of these RIL changes and can raise any major concerns.
Attachment #8486437 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: needinfo?(anshulj)

Comment 18

5 years ago
Thanks Bhavana.
Flags: needinfo?(anshulj)
You need to log in before you can comment on or make changes to this bug.