[B2G][RIL] Unable to import contacts from sim card (JavaScript Error: "contacts is undefined")

RESOLVED FIXED in Firefox 34, Firefox OS v2.0M

Status

Firefox OS
RIL
P1
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: edgar, Assigned: edgar)

Tracking

(Blocks: 2 bugs)

unspecified
2.1 S5 (26sep)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-testsuite +
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.0M+, firefox33 wontfix, firefox34 fixed, firefox35 fixed, b2g-v2.0 wontfix, b2g-v2.0M verified, b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(5 attachments, 2 obsolete attachments)

(Assignee)

Description

3 years ago
STR:
1. Open Contacts app.
2. Go to "Import Contacts" page.
3. Import Contacts from SIM 1.

Expected:
Success to import contacts from sim card.

Actual:
Get stuck on "Reading from SIM card..."

Build information:
device: dolphin
Gecko: 202767:c2d4182eb406 (hg, m-c)
Gaia: 6475adb2aabaf84510047c74d381ad5fce9f42b8 (git, master)
(Assignee)

Comment 1

3 years ago
Created attachment 8482469 [details]
[LOG] dolphin

09-02 10:43:32.464   107   519 I Gecko   : RIL Worker: Received 28 bytes.
09-02 10:43:32.464   107   519 I Gecko   : RIL Worker: Already read 0
09-02 10:43:32.464   107   519 I Gecko   : RIL Worker: New incoming parcel of size 24
09-02 10:43:32.464   107   519 I Gecko   : RIL Worker: Parcel (size 24): 0,0,0,0,85,1,0,0,0,0,0,0,106,0,0,0,130,0,0,0,255,255,255,255
09-02 10:43:32.464   107   519 I Gecko   : RIL Worker: We have at least one complete parcel.
09-02 10:43:32.464   107   519 I Gecko   : RIL Worker: [1] Solicited response for request type 28, token 341, error 0
09-02 10:43:32.464   107   519 I Gecko   : RIL Worker: [1] Handling parcel as REQUEST_SIM_IO
09-02 10:43:32.464   107   519 I Gecko   : RIL Worker: [1] ICC I/O Error code null EF id = 6f49 command = c0(6a/82)
09-02 10:43:32.464   107   519 I Gecko   : RIL Worker: Parcel handler didn't consume whole parcel, 4 bytes left over
09-02 10:43:32.464   107   519 I Gecko   : RIL Worker: Next parcel size unknown, going to sleep.
09-02 10:43:32.464   107   107 I Gecko   : -*- RadioInterface[1]: Received message from worker: {"requestId":"id{f632cff9-4ceb-4cea-9eaa-618901530a61}","contactType":"sdn","rilMessageClientId":1,"rilMessageToken":27,"rilMessageType":"readICCContacts","errorMsg":null}
09-02 10:43:32.474   107   531 E         : GetPrevFBAcquireFd: FB acquire fence is invalid!
09-02 10:43:32.474   107   531 E         : GetPrevFBAcquireFd: FB acquire fence is invalid!
09-02 10:43:32.474   107   531 E         : GetPrevFBAcquireFd: FB acquire fence is invalid!
09-02 10:43:32.474   107   531 E         : GetPrevFBAcquireFd: FB acquire fence is invalid!
09-02 10:43:32.484   704   704 I Gecko   : -*- RILContentHelper: Received message 'RIL:ReadIccContacts': {"clientId":1,"data":{"requestId":"id{f632cff9-4ceb-4cea-9eaa-618901530a61}","contactType":"sdn","rilMessageClientId":1,"rilMessageToken":27,"rilMessageType":"readICCContacts","errorMsg":null}}
09-02 10:43:32.484   704   704 E GeckoConsole: [JavaScript Error: "contacts is undefined" {file: "jar:file:///system/b2g/omni.ja!/components/RILContentHelper.js" line: 1949}]
(Assignee)

Updated

3 years ago
Summary: [B2G][RIL][Dolphin] Unable to import contacts from sim card → [B2G][RIL][Dolphin] Unable to import contacts from sim card (JavaScript Error: "contacts is undefined")
(Assignee)

Comment 2

3 years ago
Created attachment 8482475 [details]
[LOG] dolphin + radio log
(Assignee)

Updated

3 years ago
Attachment #8482469 - Attachment description: dolphin.log → [LOG] dolphin
(Assignee)

Comment 3

3 years ago
If the error comes from sw1 regarding IccIo [1], we don't config the |errorMsg| well now [2]. And RILContentHelper will treat this request is success.

Besides, according to 31.102 session 4.2.29. EF_SDN is presented only if service n° 4 and/or service n° 89 is available. We should correct this behavior as well. 

[1] http://dxr.mozilla.org/mozilla-central/source/dom/system/gonk/ril_worker.js#5857-5860
[2] http://dxr.mozilla.org/mozilla-central/source/dom/system/gonk/ril_worker.js#12860-12880
Flags: needinfo?(sam.hua)
(Assignee)

Updated

3 years ago
Flags: needinfo?(sam.hua)
(Assignee)

Updated

3 years ago
Summary: [B2G][RIL][Dolphin] Unable to import contacts from sim card (JavaScript Error: "contacts is undefined") → [B2G][RIL] Unable to import contacts from sim card (JavaScript Error: "contacts is undefined")

Updated

3 years ago
Duplicate of this bug: 1067855
(Assignee)

Comment 5

3 years ago
Created attachment 8495050 [details] [diff] [review]
Part 1: Only access EF_SDN when SDN service is available, v1
(Assignee)

Comment 6

3 years ago
Created attachment 8495192 [details] [diff] [review]
Part 2: Refactor ICC I/O error, v1

Updated

3 years ago
Whiteboard: [partner-blocker]
(Assignee)

Comment 7

3 years ago
Created attachment 8495735 [details] [diff] [review]
Part 1: Only access EF_SDN when SDN service is available, v2

Fix the failure in test_ril_worker_icc_ICCContactHelper.js
Attachment #8495050 - Attachment is obsolete: true
(Assignee)

Comment 8

3 years ago
Created attachment 8495740 [details] [diff] [review]
Part 2: Refactor ICC I/O error, v2
(Assignee)

Updated

3 years ago
Attachment #8495735 - Flags: review?(vyang)
(Assignee)

Updated

3 years ago
Attachment #8495740 - Flags: review?(vyang)
Attachment #8495735 - Flags: review?(vyang) → review+
(Assignee)

Updated

3 years ago
Attachment #8495192 - Attachment is obsolete: true
Comment on attachment 8495740 [details] [diff] [review]
Part 2: Refactor ICC I/O error, v2

Review of attachment 8495740 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you!
Attachment #8495740 - Flags: review?(vyang) → review+
(Assignee)

Comment 10

3 years ago
Try result: https://tbpl.mozilla.org/?tree=Try&rev=53a3af8a1bc0
(Assignee)

Comment 11

3 years ago
https://hg.mozilla.org/integration/b2g-inbound/rev/af0a7a4281d2
https://hg.mozilla.org/integration/b2g-inbound/rev/4c6ebcc0a38d

Updated

3 years ago
blocking-b2g: --- → 2.0M+
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1061487
https://hg.mozilla.org/mozilla-central/rev/af0a7a4281d2
https://hg.mozilla.org/mozilla-central/rev/4c6ebcc0a38d
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S5 (26sep)
http://hg.mozilla.org/releases/mozilla-b2g32_v2_0m/rev/3271eaca4d19
http://hg.mozilla.org/releases/mozilla-b2g32_v2_0m/rev/b119abbbfe0e
status-b2g-v2.0M: --- → fixed
Should this be considered for 2.1 as well? If so, please nominate :)
status-b2g-v2.0: --- → wontfix
status-b2g-v2.1: --- → ?
status-b2g-v2.2: --- → fixed
status-firefox33: --- → wontfix
status-firefox34: --- → affected
status-firefox35: --- → fixed
Flags: needinfo?(echen)
(Assignee)

Comment 16

3 years ago
Comment on attachment 8495735 [details] [diff] [review]
Part 1: Only access EF_SDN when SDN service is available, v2

Approval Request Comment
[Feature/regressing bug #]: NA
[User impact if declined]: Fail to import sim contact on particular device.
[Describe test coverage new/current, TBPL]: Xpcshell + Marionette + tests with read device, all of them works good.
[Risks and why]: low
[String/UUID change made/needed]: NA
Attachment #8495735 - Flags: approval-mozilla-aurora?
Flags: needinfo?(echen)
(Assignee)

Comment 17

3 years ago
Comment on attachment 8495740 [details] [diff] [review]
Part 2: Refactor ICC I/O error, v2

Approval Request Comment
Please see comment #16
Attachment #8495740 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 18

3 years ago
Note that the patches here depends on bug 1064647.
Comment on attachment 8495735 [details] [diff] [review]
Part 1: Only access EF_SDN when SDN service is available, v2

Approving given these are really low risk and applicable to all platform and have come-in before FC.

Also NI :anshul from CAF so he is aware of these changes as these are RIL related and is able to raise any major concerns if it breaks their flow etc...
Attachment #8495735 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

3 years ago
Flags: needinfo?(anshulj)

Updated

3 years ago
Attachment #8495740 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

3 years ago
Flags: needinfo?(anshulj)
https://hg.mozilla.org/releases/mozilla-aurora/rev/f774ac472641
https://hg.mozilla.org/releases/mozilla-aurora/rev/d5fcddc6091b
status-b2g-v2.1: ? → fixed
status-firefox34: affected → fixed

Updated

3 years ago
Blocks: 1080337
Whiteboard: [partner-blocker]

Updated

3 years ago
Blocks: 1054172

Updated

3 years ago
Blocks: 1080481
Created attachment 8522744 [details]
video

This issue can't repro on Flame 2.1/2.2 and woodduck 2.0.
See attachment: Verify_video.MP4
Reproducing rate: 0/3

Woodduck 2.0 buid:
Gaia-Rev        ee5cf148b4c546beea9bfb799d2a3ee62074957d
Gecko-Rev       73601b71861cbc2f180c4d2653cec3e9fbb39db5
Build-ID        20141114050313
Version         32.0
Flame2.1 build:
Gaia-Rev        569a299ca446f714cd98d5881cc058fd6f6e257b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/d188e92aa5a6
Build-ID        20141113001200
Version         34.0
Flame2.2 build:
Gaia-Rev        be8b0151d2f9a4c41fc63952128e0b723cd1161d
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/ab137ddd3746
Build-ID        20141113040205
Version         36.0a1
status-b2g-v2.0M: fixed → verified
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified

Updated

3 years ago
Blocks: 1107999

Updated

3 years ago
Priority: -- → P1

Updated

3 years ago
No longer blocks: 1107999
(Assignee)

Updated

3 years ago
Blocks: 1157082
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/10748/
QA Whiteboard: [MGSEI-Triage+]
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.