Closed Bug 1065147 Opened 8 years ago Closed 8 years ago

[Dialer] DTMF volume is reduced significantly and cannot be increased after a call

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S5 (26sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: smiko, Assigned: rik)

References

()

Details

(Keywords: regression, Whiteboard: [caf priority: p2][2.1-flame-test-run-2][CR 726380])

Attachments

(2 files)

Attached file logcat
Description: The user is unable to increase the DTMF volume after a call. 

Repro Steps:
1: Update a Flame to 20140908000204
2: Open Dialer and make a call
4: End the call and return to Dialer.
6: Open the keypad and enter a phone number.

Actual:
Key presses are very quiet

Expected:
Key presses are the same volume as before the call

Flame 2.1(319mb)

Environmental Variables:
Device: Flame 2.1 (319mb)
Build ID: 20140908000204
Gaia: a8e4d26555e5713ec6c72270cfd0cfabc096a0d3
Gecko: 746f24f9d21d
Version: 34.0a2 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Notes:
1: The only way to get the DTMF volume back is to reboot the phone

Repro frequency: 100%

See attached: logcat

Video clip: http://youtu.be/XvJKo1l4ZQw
This issue DOES occur on Flame 2.2(319mb), Open C 2.2, Flame 2.1(512mb), Open C 2.1, 

Actual result: 
Key presses are very quiet

Flame 2.2 (319mb)

Environmental Variables:
Device: Flame Master (319mb)
Build ID: 20140908040204
Gaia: c71fd5d8c9c7cb021c97e5e9fbb29f92b50a084d
Gecko: 892768985915
Version: 35.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Open C 2.2

Environmental Variables:
Device: Open_C Master 
Build ID: 20140908040204
Gaia: c71fd5d8c9c7cb021c97e5e9fbb29f92b50a084d
Gecko: 892768985915
Version: 35.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1 (512mb)

Environmental Variables:
Device: Flame 2.1(512mb)
Build ID: 20140908000204
Gaia: a8e4d26555e5713ec6c72270cfd0cfabc096a0d3
Gecko: 746f24f9d21d
Version: 34.0a2 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Open C 2.1

Environmental Variables:
Device: Open_C 2.1 
Build ID: 20140908000204
Gaia: a8e4d26555e5713ec6c72270cfd0cfabc096a0d3
Gecko: 746f24f9d21d
Version: 34.0a2 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


This issue does NOT occur on Flame 2.0(319mb), or Open C 2.0 

Actual result:
Key presses are at normal volume

Flame 2.0 (319mb)

Environmental Variables:
Device: Flame 2.0 (319mb)
Build ID: 20140908000202
Gaia: f02a8e4ef0fabeb28593fa660a0a4ca8a5fe67e5
Gecko: 8e46e547f4ad
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open_C 2.0

Environmental Variables:
Device: Open_C 2.0 
Build ID: 20140908000202
Gaia: f02a8e4ef0fabeb28593fa660a0a4ca8a5fe67e5
Gecko: 8e46e547f4ad
Version: 32.0 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Keywords: regression
Whiteboard: [2.1-flame-test-run-2]
This issue also causes alarms to ring at a much lower volume level
[Blocking Requested - why for this release]:

This will make dialing a phone number extremely difficult for users who rely on dial tones. Also, per comment 2, this make cause users to miss alarms that go off after making a call.
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
triage: it's a accessibility problem. it should block also because it's an identifiable regression.
blocking-b2g: 2.1? → 2.1+
Gabriele, do you know anything about this?
Flags: needinfo?(gsvelto)
(In reply to Doug Sherk (:drs) from comment #5)
> Gabriele, do you know anything about this?

Not really, is this happening only on Flame or can we reproduce it on other devices? I'll try to have a look tomorrow.
QA Contact: pcheng
Comment 1 says it reproduces on Open C.
Taking this, I'll investigate it today.
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Flags: needinfo?(gsvelto)
OK, I've had a look and it seems there's a step missing from the STR to reproduce this which I've picked up in the video: during the call turn the volume all the way down; afterwards turn it up again. It seems that for some reason the volume associated with the call affects the dialtones too. This is bizarre because because they should be entirely separate.

The last two relevant changes to this code in gaia are bug 1061012 and bug 980854 with the latter being more likely to be the culprit looking at the dates. If that's the case however then it probably triggered a gecko bug because bug 980854 only removed workarounds that had nothing to do with volume or channel adjustments.
I've just tested this using the latest build on the Hamachi and it doesn't reproduce there... I'll try on my Flame tomorrow as I have to wait until midnight before touching it in order to ensure that bug 1051083 is fixed (/me rolls eyes).
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20140902113703
Gaia: 7e469783859785a8bd4bf02a802f32561c84be7b
Gecko: 1d3b0ec6e32d
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20140902122901
Gaia: 271c527d57c845e0c38b42deed91e8a89a137f1a
Gecko: a73392bff404
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First broken gaia & Last working gecko - issue DOES repro
Gaia: 271c527d57c845e0c38b42deed91e8a89a137f1a
Gecko: 1d3b0ec6e32d

First broken gecko & Last working gaia - issue does NOT repro
Gaia: 7e469783859785a8bd4bf02a802f32561c84be7b
Gecko: a73392bff404

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/7e469783859785a8bd4bf02a802f32561c84be7b...271c527d57c845e0c38b42deed91e8a89a137f1a

Possibly caused by Bug 1061012 ?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Push-log agrees with comment 9 - the culprit is Bug 1061012
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Thanks for your help here Pi Wei, Joshua. CC'ing Etienne who authored the fix for that bug.
Setting needinfo so that this doesn't slip through Etienne's probably massive bugmail backlog.
Flags: needinfo?(etienne)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
The fix for this is as easy as fixing a typo: https://github.com/mozilla-b2g/gaia/blob/2dee9fd3adae936ca5eda6c6816b0488ad94e364/shared/js/dialer/tone_player.js#L22

cannel -> channel.

I'm gonna try to write tests to check this.
The existing test is catching this error if you only run it. But because of a test ran before, we need to reset the state of the object.
Assignee: gsvelto → anthony
Attachment #8491561 - Flags: review?(etienne)
Attachment #8491561 - Flags: review?(drs+bugzilla)
Attachment #8491561 - Flags: review?(drs+bugzilla) → review+
https://github.com/mozilla-b2g/gaia/commit/ea5b934ef52990275d1f145febd906427240f308
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 8491561 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/24185

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1061012
[User impact] if declined: Key presses don't respect user setting
[Testing completed]: On device and new unit tests.
[Risk to taking this patch] (and alternatives if risky): Low, it was a typo
[String changes made]: None
Attachment #8491561 - Flags: approval-gaia-v2.1?
Attachment #8491561 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Duplicate of this bug: 1069148
Whiteboard: [2.1-flame-test-run-2] → [2.1-flame-test-run-2][CR 726380]
Whiteboard: [2.1-flame-test-run-2][CR 726380] → [caf priority: p2][2.1-flame-test-run-2][CR 726380]
This issue is verified fixed on the Flame 2.1 and the Flame 2.2

The dial tone volume stays the same after the phone call and can be increased. 

Flame 2.1 

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141012001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.2 

Device: Flame 2.2 Master  KK (319mb) (Full Flash)
BuildID: 20141012040203
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(dharris)
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(dharris)
You need to log in before you can comment on or make changes to this bug.