Closed Bug 1065219 Opened 6 years ago Closed 6 years ago

Simplify MSR::SelectReader and reject incompatible tracks at initialization time

Categories

(Core :: Audio/Video, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla35

People

(Reporter: kinetik, Assigned: kinetik)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 2 obsolete files)

No description provided.
Blocks: MSE
Attachment #8486917 - Attachment is obsolete: true
It makes more sense to reject incompatible tracks early, so move rejection to TrackBuffer::RegisterDecoder (so that incompatible tracks are never added to the set of active decoders), and remove the similar check from SelectReader.  This also drops the work-around EOS queue check from SelectReader, since it doesn't work as intended and only serves to confuse.
Attachment #8486920 - Flags: review?(cajbir.bugzilla)
What does this patch apply on top of? I can't get it to apply.
Flags: needinfo?(kinetik)
Not sure now, here's a rebase from my current queue.  This applies on top of:

Bug 1064705
Bug 1062666
Bug 1062657
Bug 1065218
Attachment #8486920 - Attachment is obsolete: true
Attachment #8486920 - Flags: review?(cajbir.bugzilla)
Attachment #8486970 - Flags: review?(cajbir.bugzilla)
Flags: needinfo?(kinetik)
Bug 1065218 appears to rely on changes in this patch and vice versa. I can't apply 1065218 to apply this one on top.
I thought I uploaded rebased versions of them all, but it looks like it only did this one.  Fixed now, please try again.
(In reply to Matthew Gregan [:kinetik] from comment #7)
> I thought I uploaded rebased versions of them all, but it looks like it only
> did this one.  Fixed now, please try again.

Thanks, that worked.
Attachment #8486970 - Flags: review?(cajbir.bugzilla) → review+
https://hg.mozilla.org/mozilla-central/rev/ed5f95178615
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
You need to log in before you can comment on or make changes to this bug.