Closed Bug 1065520 Opened 5 years ago Closed 5 years ago

[Calendar][Week View] Events still display in Week view after they are deleted from another View

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S6 (10oct)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: Marty, Assigned: mmedeiros)

References

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

Description:
If an event is deleted from Month or Day view, the event will still be displayed in Week view.  Selecting the event will lead to a blank event page.

Note: This issue does not occur if the user has not previously navigated to Week view before deleting the event.  If the event is deleted from within Week view, the event is removed properly.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140910000202
2) Open the Calendar app
3) Create an Event
4) Navigate to Week view and observe the event
5) Navigate to Month view and delete the event
6) Navigate to Week view and observe the event
  
Actual:
The event is still present in Week view after deletion
  
Expected: 
The event is removed from Week view
  
Environmental Variables:
Device: Flame 2.1
BuildID: 20140910000202
Gaia: 79dc972d637ff5ef7667b231e93118b4ed83ba9c
Gecko: 0890010015a2
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

  
Repro frequency: 100%
See attached: logcat
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
This issue DOES occur on Flame 2.2.
Deleted events persist in Week View.

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140910040203
Gaia: 8e02f689b0fc39cb6ccdc22d02ed7e219c58faa7
Gecko: 152ef25e89ae
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
we DON'T need a regression window. regression introduced by the new 5-day week view (Bug 1023662).

happens because SingleDay view is disabled (stops listening to DayObserver) and our current logic only triggers the callback if we have busytimes on the DayObserver "cache"..
Assignee: nobody → mmedeiros
QAWanted for branch checks to confirm this is a regression.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawanted
The bug repros on Flame 2.2, Flame 2.1 and Open C 2.2
Actual result:  After deleting an event in the month or day view, the event is still visible in the week view.

Flame 2.2
BuildID: 20140911063332
Gaia: e3b9d0d6516177636965d97c63c60981a24a0662
Gecko: 98ea98c8191a
Platform Version: 35.0a1
Firmware Version: v165
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1
BuildID: 20140910165554
Gaia: d61264cd0c1f797b6be11e33524d8d52983c87e4
Gecko: 1d44dfce2e5b
Platform Version: 34.0a2
Firmware Version: v165
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Open C 2.2
BuildID: 20140911063332
Gaia: e3b9d0d6516177636965d97c63c60981a24a0662
Gecko: 98ea98c8191a
Platform Version: 35.0a1
Firmware Version: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

--------------------------------------------------------------------------------------------------------

The bug does not repro on Flame 2.0
Actual result: After deleting an event in the month or day view, the event is not visible in the week view.

BuildID: 20140910161756
Gaia: ddec117b2d6ac8ea50d7fd833a9cf0605d5b358b
Gecko: 271294ee1e5a
Platform Version: 32.0
Firmware Version: v165
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: ckreinbring
Just to make it clear, this bug only happens if you have a single event on that day, if you have 2+ events the view will update..

We DON'T need a regression window, I'm 100% sure it was introduced by the 5-day week view patch (https://github.com/mozilla-b2g/gaia/commit/9e5cdf38347c00ae96e91e4e28d406cc5cb73f8c) and I already have a fix for it - only had to delete one if statement and update tests to avoid regressions, will submit it soon for review.
Attachment #8488162 - Flags: review?(gaye)
Flags: needinfo?(jmitchell)
[Blocking Requested - why for this release]: regression from 2.0 and confusing for the user (week view displays an event that doesn't exist anymore). It's a simple fix (only deleted one if statement) and should not cause side effects or merge conflicts.
blocking-b2g: --- → 2.1?
Blocks: 1023662
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+][lead-review+]
Keywords: regression
Comment on attachment 8488162 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23971

Good catch! Can we land directly on 2.1 or (at the very least) wait until next week (for the amd conversion)?
Attachment #8488162 - Flags: review?(gaye) → review+
triage: blocking, significant regression caused by new feature in 2.1
blocking-b2g: 2.1? → 2.1+
Target Milestone: --- → 2.1 S5 (26sep)
Target Milestone: 2.1 S5 (26sep) → 2.1 S6 (10oct)
landed on master: https://github.com/mozilla-b2g/gaia/commit/a516552a788cddc97bf72041826df44b17aa1408
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8488162 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23971

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1023662
[User impact] if declined: user will think event was not deleted and also would allow user to open event details for an event that doesn't exist (app looks broken)
[Testing completed]: manual, unit and marionette
[Risk to taking this patch] (and alternatives if risky): low, changes only affect week view and we did enough testing
[String changes made]: none
Attachment #8488162 - Flags: approval-gaia-v2.1?
Backed out for causing Gu failures like: 

19:13:02     INFO -  TEST-UNEXPECTED-FAIL | calendar/test/unit/views/single_day_test.js |  "after each" hook - TypeError: this.connection is null (app://calendar.gaiamobile.org/js/db.js?time=1412734380951:155)
19:13:02     INFO -      Error: TypeError: this.connection is null (app://calendar.gaiamobile.org/js/db.js?time=1412734380951:155)
19:13:02     INFO -          at onerror (app://calendar.gaiamobile.org/common/vendor/mocha/mocha.js:4959:10)

This failure was also in the gaia-try run: https://tbpl.mozilla.org/?rev=68176dabcf5cb1d6b33d09f42d96834195f0b64d&tree=Gaia-Try

https://tbpl.mozilla.org/php/getParsedLog.php?id=49760241&tree=B2g-Inbound

https://github.com/mozilla-b2g/gaia/commit/4c5730799ed0aa1c992325401ce063ecd2d81e5b
Status: RESOLVED → REOPENED
Flags: needinfo?(mmedeiros)
Resolution: FIXED → ---
Comment on attachment 8488162 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23971

Clearing uplift approval due to backout.
Attachment #8488162 - Flags: approval-gaia-v2.1?
basically same thing as before, only added a single line of code + 2 lines of comment... now it should not cause unit test failures (avoid triggering a db transaction if no views are listening to it).

sorry for the all the trouble, I thought the TBPL failures was from when the tree got closed, did not notice that one of the errors was on the calendar app itself.
Attachment #8488162 - Attachment is obsolete: true
Attachment #8501782 - Flags: review?(gaye)
Flags: needinfo?(mmedeiros)
Comment on attachment 8501782 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24950

Feel free to merge when green.
Attachment #8501782 - Flags: review?(gaye) → review+
landed on master: https://github.com/mozilla-b2g/gaia/commit/420c5456dccb53a9c0950cac71494cec1e7afd31
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Comment on attachment 8501782 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24950

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1023662
[User impact] if declined: user will think event was not deleted and also would allow user to open event details for an event that doesn't exist (app looks broken)
[Testing completed]: manual, unit and marionette
[Risk to taking this patch] (and alternatives if risky): low, changes only affect week view and we did enough testing
[String changes made]: none
Attachment #8501782 - Flags: approval-gaia-v2.1?
Attachment #8501782 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Depends on: 1081050
[Environment]
Gaia-Rev        d18e130216cd3960cd327179364d9f71e42debda
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/610ee0e6a776
Build-ID        20141012161201
Version         34.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20140925.192608
FW-Date         Thu Sep 25 19:26:18 EDT 2014
Bootloader      L1TC10011800

[Result]
PASS
Status: RESOLVED → VERIFIED
This issue is verified fixed on Flame 2.1 and Flame 2.2.

Created events do not appear in any section of the calendar once they have been deleted.

Flame 2.2 

Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141017040208
Gaia: abef62c0623e5504a97b4fd411e879a67b285b52
Gecko: ae1dfa192faf
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 36.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.1 

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141017001201
Gaia: 1ea74943cfe525c76a074ca1d7de8e51a70f6b98
Gecko: 2befa902ff5c
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.