Regression: Specifying a port for SMTP server no longer works

VERIFIED DUPLICATE of bug 106631

Status

VERIFIED DUPLICATE of bug 106631
17 years ago
10 years ago

People

(Reporter: kaie, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
In the past, even with the 0.9.4 branch, it was possible to enter the hostname
for the smtp server in host:port notation. As Mailnews does not provide a
separate GUI for specifying the port name of the server, this was the only way
of using a nonstandard port.

With the current trunk of Mozilla this does no longer work.

To reproduce this, you need a smtp server running on a port different from 25.

Set smtp hostname to hostname:port. Send a mail. Mozilla complains with the
error message "cannot connect to server".

This is caused by NS_MsgBuildSmtpUrl, which always appends ":25" to the smtp
hostname.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 106631 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Verify dupe - reported 4X.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.