Closed Bug 1066307 Opened 6 years ago Closed 6 years ago

[TaskManager] Initial sizing of landscape rendering is incorrect

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified

People

(Reporter: kgrandon, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

46 bytes, text/x-github-pull-request
vingtetun
: review+
Details | Review
No description provided.
STR:
1 - Open a few apps.
2 - Open an app which supports landscape mode and rotate the device. The `Browser` app works well for this.
3 - Long tap on the home button to enter the task manager.

Exptected STR:
Everything works fine.

Actual STR:
Cards are bunched together and not rendered correctly.
Attached file Github pull request
WIP pull request - thinking about tests...
Wrong blocking bug.
Blocks: 1061324
No longer blocks: 1047143
Comment on attachment 8488231 [details] [review]
Github pull request

Etienne or Vivien - could one of you guys review this? Thanks!
Attachment #8488231 - Flags: review?(etienne)
Attachment #8488231 - Flags: review?(21)
Duplicate of this bug: 963378
Comment on attachment 8488231 [details] [review]
Github pull request

Makes sense! Thanks for the patch.
Attachment #8488231 - Flags: review?(etienne)
Attachment #8488231 - Flags: review?(21)
Attachment #8488231 - Flags: review+
In master: https://github.com/mozilla-b2g/gaia/commit/890e59dee53ea9f794cb3a43a250e5fcb3df4bd1
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Verified Fixed.  Issue no longer occurs in Flame 2.2
Task manager renders appropriately in Landscape screen orientation.

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140916040203
Gaia: e2d70bee03b5380ac327a145e5d694fb2443f018
Gecko: 3b7921328fc1
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.