If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Purchasing in-app product fails with TRANS_NOT_FOUND

RESOLVED DUPLICATE of bug 1066858

Status

Marketplace
Payments/Refunds
--
major
RESOLVED DUPLICATE of bug 1066858
3 years ago
3 years ago

People

(Reporter: krupa, Unassigned)

Tracking

x86
Gonk (Firefox OS)
Points:
---

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8488317 [details]
in-app product.txt

steps to reproduce:
1. Install the FxPay app on your FirefoxOS phone
4. Change the API to marketplace.allizom.org
5. Start the purchase of one of the in-app product
6. Sign in using persona
7. Enter PIN

expected behavior:
Bango screen loads


actual behavior:
Error page loads

09-11 16:14:12.291 E/GeckoConsole(  135): Content JS LOG at https://marketplace-cdn.allizom.org/mozpay/spa/js/main.min.js?bust=fb8ced5616b84e23abf69348a9e1fa03bccc50a5:63 in r: [cancel] Running paymentFailed with errorCode: TRANS_NOT_FOUND
09-11 16:14:12.301 E/GeckoConsole(  842): Content JS ERROR at app://fxpay.allizom.org/fxpay.js:540 in startPurchase/</payReq.onerror: mozPay: received onerror(): TRANS_NOT_FOUND
09-11 16:14:12.311 E/GeckoConsole(  842): Content JS ERROR at app://fxpay.allizom.org/js/index.js:97 in anonymous: error purchasing product 6535f835-924c-48b9-8975-0658e175bb7a message: TRANS_NOT_FOUND
09-11 16:14:12.321 E/GeckoConsole(  842): Content JS ERROR at app://fxpay.allizom.org/js/index.js:82 in showError: TRANS_NOT_FOUND
(Reporter)

Updated

3 years ago
Severity: normal → major
I'm pretty sure this was caused by bug 1066858. What was the name of the product you were trying to purchase?
(Reporter)

Comment 2

3 years ago
(In reply to Kumar McMillan [:kumar] (needinfo for quickness) from comment #1)
> I'm pretty sure this was caused by bug 1066858. What was the name of the
> product you were trying to purchase?

Now, I can buy most of the products except for the in-app product named <script>alert(‘Problem1')</script> @ https://marketplace.allizom.org/developers/app/fxpay/in-app-payments/in-app-products/

Earlier it was failing for most products.
ok, that sounds like bug 1066858 because of the smart quote in your product name
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1066858
You need to log in before you can comment on or make changes to this bug.