[tracking] Server-less in-app payments

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: andy+bugzilla, Unassigned)

Tracking

x86
Mac OS X
Points:
---
Dependency tree / graph

Details

(Reporter)

Description

5 years ago
A revision of in-app payments to see if we can remove the requirement of users to maintain a server.

Based on: https://wiki.mozilla.org/Marketplace/InAppPayments#Proposed_solution
(Reporter)

Updated

5 years ago
Depends on: 944482
(Reporter)

Updated

5 years ago
Depends on: 944487
(Reporter)

Updated

5 years ago
Depends on: 944489
(Reporter)

Updated

5 years ago
Depends on: 944490
(Reporter)

Updated

5 years ago
Depends on: 944518
(Reporter)

Updated

5 years ago
Depends on: 757226
(Reporter)

Updated

5 years ago
Depends on: 944519
(Reporter)

Updated

5 years ago
Depends on: 944522
(Reporter)

Updated

5 years ago
Depends on: 944523
(Reporter)

Updated

5 years ago
Depends on: 944525
Summary: [tracking] Server less in-app payments → [tracking] Server-less in-app payments
(Reporter)

Updated

5 years ago
Depends on: 769793
(Reporter)

Updated

5 years ago
No longer depends on: 769793
(Reporter)

Updated

5 years ago
Depends on: 769793
(Reporter)

Updated

5 years ago
Depends on: 977764
(Reporter)

Updated

5 years ago
Depends on: 977765
(Reporter)

Updated

5 years ago
Depends on: 977767
(Reporter)

Updated

5 years ago
Depends on: 978880
Depends on: 982670
(Reporter)

Updated

5 years ago
Depends on: 984526

Updated

4 years ago
Depends on: 1019096

Updated

4 years ago
Depends on: 1019890
(Reporter)

Updated

4 years ago
Depends on: 1022936
Depends on: 1023403
(Reporter)

Updated

4 years ago
Depends on: 1023630
(Reporter)

Updated

4 years ago
Depends on: 1023632
(Reporter)

Updated

4 years ago
Depends on: 1023634

Updated

4 years ago
Depends on: 986614
(Reporter)

Updated

4 years ago
Depends on: 1027908
(Reporter)

Updated

4 years ago
Depends on: 1028361
Depends on: 1028389
Depends on: 1028976

Updated

4 years ago
Depends on: 1035448
Duplicate of this bug: 910270

Comment 3

4 years ago
would we not need to update the Developer Hub as well as when a developer submits a free app we wouldn't ask for payment details. However, if they use in app payments, they would need to register as paid app though, it is free.
Flags: needinfo?(kumar.mcmillan)
The DevHub submission flow already does what we want, I think. If you submit a free app that accepts in-app payments you do need to register payment details.
Flags: needinfo?(kumar.mcmillan)

Updated

4 years ago
Depends on: 1052143
(Reporter)

Updated

4 years ago
No longer depends on: 1045228
(Reporter)

Updated

4 years ago
No longer depends on: 769793
(Reporter)

Updated

4 years ago
Depends on: 1037605
(Reporter)

Updated

4 years ago
No longer depends on: 972886
(Reporter)

Updated

4 years ago
No longer depends on: 981093
(Reporter)

Updated

4 years ago
Depends on: 1058279
(Reporter)

Updated

4 years ago
No longer depends on: 982670
(Reporter)

Updated

4 years ago
No longer depends on: 1020999
(Reporter)

Updated

4 years ago
No longer depends on: 1023630
No longer depends on: 977765

Updated

4 years ago
Depends on: 1058284

Updated

4 years ago
Depends on: 1059371
(Reporter)

Updated

4 years ago
Depends on: 1059944
(Reporter)

Updated

4 years ago
Depends on: 1059959

Updated

4 years ago
No longer depends on: 1059371

Updated

4 years ago
Depends on: 1064586

Updated

4 years ago
Depends on: 1064687

Updated

4 years ago
Depends on: 1064690

Updated

4 years ago
Depends on: 1065328

Updated

4 years ago
Depends on: 1065352

Updated

4 years ago
Depends on: 1066356

Updated

4 years ago
Depends on: 1066359

Updated

4 years ago
Depends on: 1066374

Updated

4 years ago
Depends on: 1066418

Updated

4 years ago
Depends on: 1066419

Updated

4 years ago
Depends on: 1066575

Updated

4 years ago
Depends on: 1066648

Updated

4 years ago
Depends on: 1066844

Updated

4 years ago
Depends on: 1067390
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Updated

4 years ago
No longer depends on: 1066648
You need to log in before you can comment on or make changes to this bug.