Closed Bug 1066483 Opened 5 years ago Closed 5 years ago

Update SVG camelCase knowledge to omit names dropped from the spec

Categories

(Core :: DOM: HTML Parser, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla36

People

(Reporter: hsivonen, Assigned: hsivonen)

References

Details

Attachments

(3 files)

Some SVG camelCase attributes have been dropped by the SVG WG and then dropped by the HTML spec. I'm not sure how good an idea it is to tweak this stuff, but since Blink has already tweaked their parser (except for filterRes), I guess it's too late to second-guess this direction.
Attached patch Java patchSplinter Review
Attached patch Gecko patchSplinter Review
The test file update comes verbatim from upstream.
Attachment #8488490 - Flags: review?(wchen)
Attachment #8488502 - Flags: review?(wchen)
Comment on attachment 8488502 [details] [diff] [review]
Gecko patch

Review of attachment 8488502 [details] [diff] [review]:
-----------------------------------------------------------------

For contentStyleType and contentScriptType, we should probably remove the comments here too:

http://dxr.mozilla.org/mozilla-central/source/content/base/src/nsTreeSanitizer.cpp#396

It looks like there is already a bug for removing the parsing of filterRes (bug 979472), we should also get rid of these gecko bits since they aren't being used anywhere:

http://dxr.mozilla.org/mozilla-central/source/content/base/src/nsGkAtomList.h#1326
http://dxr.mozilla.org/mozilla-central/source/content/base/src/nsTreeSanitizer.cpp#419

r=me with those changes.
Attachment #8488502 - Flags: review?(wchen) → review+
Attachment #8488490 - Flags: review?(wchen) → review+
Duplicate of this bug: 979472
Thanks. Landed with the review comments addressed:
 https://hg.mozilla.org/integration/mozilla-inbound/rev/230ec8030aa7
It looks like we have another copy of the html5lib tests in web platform tests, and it's failing due to unexpected test passes. We probably just need to delete this file:

http://dxr.mozilla.org/mozilla-central/source/testing/web-platform/meta/html/syntax/parsing/html5lib_tests11.html.ini
Attachment #8505344 - Flags: review?(james)
Attachment #8505344 - Flags: review?(james) → review+
https://hg.mozilla.org/mozilla-central/rev/9ec96af33898
https://hg.mozilla.org/mozilla-central/rev/d435760a28dc
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.