Closed Bug 106691 Opened 19 years ago Closed 15 years ago

Use Carbon Events to optimize PLEvent handling

Categories

(Core :: XUL, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: mikepinkerton, Assigned: ccarlen)

References

Details

summary says it all.
Blocks: 106689
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.6
Target Milestone: mozilla0.9.6 → mozilla0.9.7
Blocks: 106397
-> 098
Target Milestone: mozilla0.9.7 → mozilla0.9.8
Now that 78611 has been checked in, i think that this bug can be marked
WONTFIX/INVALID.
pav, you're probably correct but i still want to make sure that we're not doing
any polling.
with work in 105445, we have covered removing polling from timers and PLEvent
processing. duping this to that. 

*** This bug has been marked as a duplicate of 105445 ***
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
ok, more work is required than i thought. un-duping.

first, under conrad's patch in the other bug, it just calls ::WakeUpProcess()
which delivers a null event to the app and wakes it up. When not calling WNE, my
guess is that this is a no-op since we're not polling and there is no concept of
idle events. So we need to post a carbon event of our own. Hopefully, though,
this doesn't change the event flow (remember dougt's patch which posted events
and starved update events?)

Another option would be to poll the PLEvent Q on a regular carbon timer. While
just as ugly, i think carbon timers are still more efficient CPU-wise than
polling with WNE.

Too much brainpower required before vacation, i'll pick this up in january.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → ASSIGNED
not gonna happen in 098
Target Milestone: mozilla0.9.8 → mozilla0.9.9
over to dagley, i probably won't have time for these by 099 with the embedding
work i'm getting pulled into.
Assignee: pinkerton → sdagley
Status: ASSIGNED → NEW
This isn't about timers any more.
Summary: Rewrite timers to use CarbonEvents → Use Carbon Events to optimize PLEvent handling
-> mozilla1.0
Target Milestone: mozilla0.9.9 → mozilla1.0
Blocks: 124305
Target Milestone: mozilla1.0 → mozilla1.1
Target Milestone: mozilla1.1alpha → ---
Since I don't report into Internet Technologies anymore this bug needs a new
owner -> saari
Assignee: sdagley → saari
Conrad did this already.
Assignee: saari → ccarlen
This was done. But see also bug 282940.
Status: NEW → RESOLVED
Closed: 19 years ago15 years ago
Resolution: --- → FIXED
No longer blocks: 106397
You need to log in before you can comment on or make changes to this bug.