Attachments "Save All" does not create an entry in "Saved Files" list aka Download Manager window

RESOLVED DUPLICATE of bug 914517

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 914517
4 years ago
3 years ago

People

(Reporter: Thomas D. (currently busy elsewhere), Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 2 bugs, {regression})

24 Branch
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

+++ This bug was initially created as a clone of Bug #914517 +++

"Saved Files" dialogue aka Download Manager is now almost totally disfunctional even for the initiated who know how to find and use it in spite of the poor default behaviour and design. Retrieving just saved attachments now requires using OS file manager, no access to target files/folders from within TB. This is a bad loss in terms of ux-efficiency and should be fixed asap, even for the old download manager.

works on TB24.6 -> regression

Steps to reproduce: (TB31.1.1 on WinXP)

1. received message with multiple Attachments (e.g. jpgs)
2. click on "Save All" button in attachment header bar
3. choose folder, OK
4. Press CTRL-J to open Saved Files Dialogue


Actual results:

- Attachments are correctly saved, but
- Saved files are NOT listed in the Saved Files dialogue
Iow, even for advanced users who are able to navigate the broken default behaviour around TB's download manager, they can no longer access the files or target folder directly from TB; need to open their OS file manager and search again for the very files they have just saved and whose location is known - grrrr

Expected results:

Saved files should be listed in Saved Files dialogue to allow easy retrieval of the files and/or target folder
(Reporter)

Comment 1

4 years ago
Wayne, can you confirm this?
Flags: needinfo?(vseerror)
(Reporter)

Updated

4 years ago
No longer depends on: 914517
(Reporter)

Updated

4 years ago
Depends on: 914517

Comment 2

4 years ago
nightly build, vista.
files processed via save as don't appear in Saved Files Dialogue.
However opened files do appear in Saved Files Dialogue.
I have not idea when it changed, I don't normally use this.
Flags: needinfo?(vseerror)
Whiteboard: [regression:TB2?]
(Reporter)

Updated

4 years ago
See Also: → bug 549719
(Reporter)

Comment 3

3 years ago
(In reply to Kent James (:rkent) from comment Bug 914517 #16)
> Since we plan to land bug 1087233 for Thunderbird 38, we should also finish
> this to get the download manager working more reliably.

Kent, thanks for setting tracking-TB38+ on bug 914517; pls do the same here:
This is essentially the same bug, but different code path.
Bug 914517 is for "Save as..." of single file (where user picks folder & file name), whereas
this bug 1067177 is for "Save all" of all files (where user picks just folder).
Users will face this bug 1067177 more often because it's the default button on the attachment toolbar.
tracking-thunderbird38: --- → ?
Whiteboard: [regression:TB2?]

Comment 4

3 years ago
Aceman, any chance you could look at this?

Comment 5

3 years ago
This seems to work for me in current trunk. Save All does list files in the Saved files tab.
Was bug 914517 comment 6 right?
Even Detach All works for me (on Windows).

Comment 6

3 years ago
If someone else could test that these are all working, we could dup this bug to bug 914517

Comment 7

3 years ago
Yes this is working fine on trunk. Duping to bug 914517.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
tracking-thunderbird38: ? → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 914517
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.