Closed Bug 1067331 Opened 5 years ago Closed 5 years ago

WebIDE times out due to toolkit/loader compatibility change

Categories

(DevTools :: WebIDE, defect)

x86_64
All
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: paul, Unassigned)

References

Details

Runtime app, local project, ... anything. I can't connect to the app:

version	2.2.0.0-prerelease
appbuildid	20140914223128
platformbuildid	20140914221844
platformversion	35.0a1
geckobuildid	20140914221844

And after the timeout, I can't push apps anymore.
The operation that times out is "Opening toolbox".
In app-manager.js:

> let target = yield AppActorFront.getTargetForApp(client, actor, manifest);

Stuck here.
Most likely a regression of bug 1037235.
I can see this exception with some more debug logs:
[Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIXULAppInfo.ID]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource://gre/modules/sdk/system/XulApp.js :: <TOP_LEVEL> :: line 19"  data: no]
Jan can't reproduce with a master build.
I reproduce it with a today's morning changeset
  http://hg.mozilla.org/mozilla-central/rev/bf5fcc0c4b27
And the problem disappear if I revert bug 1037235's changeset.
Backed out a6d02cff43d3.
Where is this failing test's log on Tinderbox?
Flags: needinfo?(paul)
(In reply to Erik Vold [:erikvold] [:ztatic] from comment #7)
> Where is this failing test's log on Tinderbox?

There's no tests (we can't test B2G + Firefox Desktop). And it's an issue on B2G, not Firefox Desktop.
Flags: needinfo?(paul)
(In reply to Paul Rouget [:paul] (slow to respond. Ping me on IRC) from comment #8)
> (In reply to Erik Vold [:erikvold] [:ztatic] from comment #7)
> > Where is this failing test's log on Tinderbox?
> 
> There's no tests (we can't test B2G + Firefox Desktop). And it's an issue on
> B2G, not Firefox Desktop.

Ok then can I leave you guys to fix this?  I have no experience using the webide with b2g and it would take me much longer to resolve, a test would make my life much easier if I were to help you here.
Flags: needinfo?(paul)
This does not directly block native jetpacks
No longer blocks: native-jetpack
Summary: WebIDE times out when connecting to any app → WebIDE times out due to toolkit/loader compatibility change
Once bug 1037235 is uplifted as part of bug 1114752, I will retest this.
Depends on: 1114752
Flags: needinfo?(paul)
This appears to be working correctly.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.