Closed Bug 1114752 Opened 5 years ago Closed 5 years ago

Uplift Add-on SDK to Firefox

Categories

(Add-on SDK Graveyard :: General, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED
mozilla38

People

(Reporter: evold, Assigned: evold)

References

()

Details

Attachments

(1 file)

No description provided.
Assignee: nobody → evold
Depends on: 1111107, 1111102, 1113423
Depends on: 1111106
Depends on: 1114769
Depends on: 1111695
Depends on: 1114772
Depends on: 1114775
Depends on: 1114776
Depends on: 1114779
Depends on: 1114789
Depends on: 970062
Depends on: 1009340
Depends on: 1055575
Depends on: 970135
Depends on: 1112772
Depends on: 1075541
Depends on: 1109453
Depends on: 1058997
Depends on: 1102504
Depends on: 1102107
Depends on: 1094005
Depends on: 853085
Depends on: 1091888
Depends on: 1083927
Depends on: 1070952
Depends on: 1100639
Depends on: 1060138
Depends on: 1098690
Depends on: 1092477
Depends on: 1097918
Depends on: 1097874
Depends on: 1095583
Depends on: 1023661
Depends on: 1092882
Depends on: 1095012
Depends on: 1017751
Although bug 1083927 is marked resolved, it was reverted from the sdk repo b/c the tests it adds do not pass, so someone needs to look into this before the uplift.
Depends on: 1114940
Depends on: 1115383
Depends on: 1115601
Depends on: 1115398
Depends on: 1115400
Depends on: 1111691
Depends on: 847840
Depends on: 1037235
Depends on: 1004514
Depends on: 1114712
Depends on: 1118364
No longer depends on: 1118364
No longer depends on: 1114775
No longer depends on: 1114779
No longer depends on: 1114789
No longer depends on: 1111691
No longer depends on: 1114769
No longer depends on: 1114776
These bugs no longer need to be blockers.
No longer depends on: 847840, 970062
Trying again:

remote: You can view your change at the following URL:
remote:   https://hg.mozilla.org/try/rev/85bbfb599971
remote: You can view the progress of your build at the following URL:
remote:   https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=85bbfb599971
remote: Alternatively, view them on TBPL (soon to be deprecated):
remote:   https://tbpl.mozilla.org/?tree=Try&rev=85bbfb599971
Trying on updated fx-team:

remote: You can view the progress of your build at the following URL:
remote:   https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=1c447bf3d640
remote: Alternatively, view them on TBPL (soon to be deprecated):
remote:   https://tbpl.mozilla.org/?tree=Try&rev=1c447bf3d640
ok xpcshell tests end up requiring sdk/system/xul-app.jsm which errors when try to make use nsIXULAppInfo, because this dne in the xpcshell environment.

Trying again with a try around this use of nsIXULAppInfo, catch uses a blank object `{}` will seek review if this passes.

remote: You can view your change at the following URL:
remote:   https://hg.mozilla.org/try/rev/0ee7639d87f5
remote: You can view the progress of your build at the following URL:
remote:   https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=0ee7639d87f5
remote: Alternatively, view them on TBPL (soon to be deprecated):
remote:   https://tbpl.mozilla.org/?tree=Try&rev=0ee7639d87f5
Attachment #8546688 - Flags: review?(jsantell) → review+
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/e854b77d2f2be34f79c113bf617ce1bb6ccc7ed9
Bug 1114752 adding a try/catch around use of nsIXULAppInfo (which fails for xpcshell tests)

https://github.com/mozilla/addon-sdk/commit/4d7d33e3f594d10d0d13c3b97781e20316139b20
Merge pull request #1830 from erikvold/1114752

Bug 1114752 adding a try/catch around use of nsIXULAppInfo (which fails for xpcshell tests) r=jsantell
remote: You can view your change at the following URL:
remote:   https://hg.mozilla.org/try/rev/ed91e76de4a8
remote: You can view the progress of your build at the following URL:
remote:   https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=ed91e76de4a8
remote: Alternatively, view them on TBPL (soon to be deprecated):
remote:   https://tbpl.mozilla.org/?tree=Try&rev=ed91e76de4a8
Trying again on updated fx-team with new range:

https://github.com/mozilla/addon-sdk/compare/1aee56d5ef161f47beb5ee6197cc4598956e6010...4d7d33e3f594d10d0d13c3b97781e20316139b20

remote: You can view your change at the following URL:
remote:   https://hg.mozilla.org/try/rev/ed91e76de4a8
remote: You can view the progress of your build at the following URL:
remote:   https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=ed91e76de4a8
remote: Alternatively, view them on TBPL (soon to be deprecated):
remote:   https://tbpl.mozilla.org/?tree=Try&rev=ed91e76de4a8
There seems to be some issue making the debug builds on windows.

This http://pastebin.mozilla.org/8174387 points to some issue with the lib/index.js file, which is in the moz.build, so that appears fine, the file is blank though, so I added the mpl 2 header to see if that helps..

remote: You can view your change at the following URL:
remote:   https://hg.mozilla.org/try/rev/444a1462f97e
remote: You can view the progress of your build at the following URL:
remote:   https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=444a1462f97e
remote: Alternatively, view them on TBPL (soon to be deprecated):
remote:   https://tbpl.mozilla.org/?tree=Try&rev=444a1462f97e
Commit pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/508215e8f9fa58e76625fcc9141edf9998023b97
Bug 1114752 Adding mpl 2 license header to the lib/index.js file a=me
See Also: → 1120292
I had to back the uplift out in https://hg.mozilla.org/integration/fx-team/rev/a868809113e1 for apparently breaking b2g tests on fx-team:

https://treeherder.mozilla.org/#/jobs?repo=fx-team&revision=2815bfd2ccb5&filter-searchStr=b2g

If these are still broken on the backout push, we can reland this.
(In reply to Wes Kocher (:KWierso) from comment #17)
> I had to back the uplift out in
> https://hg.mozilla.org/integration/fx-team/rev/a868809113e1 for apparently
> breaking b2g tests on fx-team:
> 
> https://treeherder.mozilla.org/#/jobs?repo=fx-
> team&revision=2815bfd2ccb5&filter-searchStr=b2g
> 
> If these are still broken on the backout push, we can reland this.

Early results on the backout are passing. Something from this uplift broke b2g tests. Fun.
Depends on: 1120427
(In reply to Erik Vold [:erikvold] (please needinfo? me) from comment #19)
> I started reverting commits to addon-sdk/source/lib/ in
> https://github.com/erikvold/addon-sdk/compare/mozilla:
> 1aee56d5ef161f47beb5ee6197cc4598956e6010...erikvold:1114752-uplift-debug
> 
> These were the last trys, first to last:
> 
> https://tbpl.mozilla.org/?tree=Try&rev=32b27e30ef12
> https://tbpl.mozilla.org/?tree=Try&rev=850b920fd30e
> https://tbpl.mozilla.org/?tree=Try&rev=ab4b5045658c
> https://tbpl.mozilla.org/?tree=Try&rev=7156ded8e734
> https://tbpl.mozilla.org/?tree=Try&rev=c8aceb4297dc
> 
> The last one seems to resolve the b2g issues, which is bug 1102107.
> 
> I'll try reverting that single commit next.

So with the last green result, I thought that reverting just bug 1102107 would work, but doesn't seem to be the case.

In https://github.com/erikvold/addon-sdk/compare/mozilla:1aee56d5ef161f47beb5ee6197cc4598956e6010...erikvold:1114752-uplift-debug-2 I've reverted only the 4 changes to the toolkit/loader, in a different order, these are the four corresponding tries:

* https://tbpl.mozilla.org/?tree=Try&rev=c204eff741cf&showall=1
* https://tbpl.mozilla.org/?tree=Try&rev=9f82953fd31a&showall=1
* https://tbpl.mozilla.org/?tree=Try&rev=dfa8e5cc5346&showall=1
* https://tbpl.mozilla.org/?tree=Try&rev=bd582b4ec23c&showall=1

not sure if any result in greens yet.
(In reply to Erik Vold [:erikvold] (please needinfo? me) from comment #21)
> In
> https://github.com/erikvold/addon-sdk/compare/mozilla:1a0010e...erikvold:
> 1114752-uplift-debug-3 I tried the same four reverts as in
> https://github.com/erikvold/addon-sdk/compare/mozilla:1a0010e...erikvold:
> 1114752-uplift-debug-2 but reverse order, these are the results:
> 
> * https://tbpl.mozilla.org/?tree=Try&rev=f1fb1a6f8fa4&showall=1
> * https://tbpl.mozilla.org/?tree=Try&rev=1a44c5ee66af&showall=1
> * https://tbpl.mozilla.org/?tree=Try&rev=42f6c2d0d93c&showall=1
> * https://tbpl.mozilla.org/?tree=Try&rev=a3706a71216e&showall=1

Ok in https://github.com/erikvold/addon-sdk/compare/mozilla:27ca6a9...erikvold:1114752-uplift-debug-4 I re-reverted the change from bug Bug 1070952 to toolkit/loader and that had no affect, the b2g tests were still greed, so we can eliminate bug Bug 1070952 as part of the issue.

I think the issue is something about the combination of Bug 1102107 and Bug 1037235 at this point.  I've tried reverting each by themselves and that had no positive effect.

See comment 21 on https://github.com/erikvold/addon-sdk/compare/mozilla:1a0010e...erikvold:1114752-uplift-debug-3 for trying Bug 1037235 alone.

See comment 20 above on https://github.com/erikvold/addon-sdk/compare/mozilla:1a0010e...erikvold:1114752-uplift-debug-2 for trying Bug 1102107 alone.
> Ok in
> https://github.com/erikvold/addon-sdk/compare/mozilla:27ca6a9...erikvold:
> 1114752-uplift-debug-4 I re-reverted the change from bug Bug 1070952 to
> toolkit/loader and that had no affect, the b2g tests were still greed, so we
> can eliminate bug Bug 1070952 as part of the issue.
> 

still green*

those results are here: https://tbpl.mozilla.org/?tree=Try&rev=122bfcaecaf5
Depends on: 1122978
Commit pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/4711314ae16b97ef92c19ddaa4d951c916c54a01
Bug 1114752 converting lib/sdk/system/xul-app.jsm to support b2g for uplift a=me

Also related to:

* Bug 1122978 - Test that our JSM files are written to support b2g (which is meant to test this issue)
* Bug 1037235 - toolkit/loader does not check module compatibility (which introduced the bug)
No longer depends on: 1114772
Update: Bug 1102107 describes the last blocker for uplift.

I'll be on vacation next week, so if bug 1102107 doesn't get resolved by thursday then someone else will have to do the uplift next week, or we'll have to wait until I get back.

The regression that bug 1102107 caused is described in Bug 1122978 comment 9 and Bug 1120427 comment 8, so the bug either needs to be reverted (which will cause other bugs to reverted), or fixed.
Assignee: evold → nobody
Priority: -- → P1
No longer depends on: 1009340
No longer depends on: 1070952
No longer depends on: 1102504
No longer depends on: 1122978
No longer depends on: 1120427
The only bug still blocking this is bug 1102107, waiting for Irakli's response there.
Flags: needinfo?(rFobic)
Note that attachment 8519478 [details] [review] of bug 1023661 introduced a Javascript exception into Thunderbird, so it would be good to take bug 1100644 too (attachment 8554143 [details] [review]).
Depends on: 1100644
Clear needinfo here since activity one mentioned bug is happening there.
Flags: needinfo?(rFobic)
Commit pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/83004de78ffb412bdff571750baee65abdd77a2e
Merge pull request #1849 from erikvold/uplifts

Bug 1114752 M-C to Github Uplifts a=me
Commit pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/985733760862b860d81f9115ff60d2401b26e15f
Bug 1114752 Update test/jetpack-package.ini to include test/querystring|path directory a=me
Assignee: nobody → evold
https://hg.mozilla.org/mozilla-central/rev/4171b3354b53
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
You need to log in before you can comment on or make changes to this bug.