New marketplace package incoming

RESOLVED FIXED in Firefox OS v2.1
(NeedInfo from)

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: clouserw, Assigned: kngo, NeedInfo)

Tracking

unspecified
2.1 S6 (10oct)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 fixed, b2g-v2.2 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
We're going to have a new packaged app fixing some important bugs.  We'd like to get it in 2.1.

I understand your feature complete is Oct 13.  We'll get this PR done well before then.
(In reply to Wil Clouser [:clouserw] from comment #0)
> We're going to have a new packaged app fixing some important bugs.  We'd
> like to get it in 2.1.
> 
> I understand your feature complete is Oct 13.  We'll get this PR done well
> before then.

Note - FC implies that we've hit a quality level that allows us to hand off to partners (i.e. initial stabilization). That's different than when features need to land - features need to land by the feature landing milestone, which has already passed.
(Reporter)

Comment 2

4 years ago
The Marketplace has landed.  We're fixing bugs.
Bhavana, what is Release management call on this ?
Flags: needinfo?(bbajaj)
Wil, can you please give more input on what kind of fixes are going in into this new package ? Also, what's the level of risk involved and how much testing has been done ? do you anticipate any major platform support to help fix new issues seen ? If that's the case I'd be cautious here as we want to avoid any major platform changes too late in the FL-FC period.
Flags: needinfo?(bbajaj) → needinfo?(clouserw)
(Reporter)

Comment 5

4 years ago
The package in the builds right now is from the end of April.  Since then, in Marketplace there have been 1730 bugs closed.  Many of those are server side, but many will be in the client as well.  Some big callouts:

* Added MVNO detection
* Improved analytics
* Enhanced UI (Feed) supporting regional features
* Many paper cut bug fixes
* Additional optimizations (gzip support on selected files)
* Updated legal documents
* Updated localizations

Changes are tested and pushed live each week.  I don't expect any platform support other than pulling in the new package.
Flags: needinfo?(clouserw)

Updated

4 years ago
blocking-b2g: 2.1? → 2.1+
(In reply to Wil Clouser [:clouserw] from comment #5)
> The package in the builds right now is from the end of April.  Since then,
> in Marketplace there have been 1730 bugs closed.  Many of those are server
> side, but many will be in the client as well.  Some big callouts:
> 
> * Added MVNO detection
> * Improved analytics
> * Enhanced UI (Feed) supporting regional features
> * Many paper cut bug fixes
> * Additional optimizations (gzip support on selected files)
> * Updated legal documents
> * Updated localizations
> 
> Changes are tested and pushed live each week.  I don't expect any platform
> support other than pulling in the new package.

Thanks ! Please seek approval as needed to land on 2.1
(Assignee)

Comment 7

4 years ago
We have some tests failing, can we get help resolving these errors? https://tbpl.mozilla.org/?rev=edab97ade70687d7d31ce46af410853173df495b&tree=Gaia-Try

Thanks!
(Assignee)

Comment 9

4 years ago
I see a bug in the etags, fixing.
Hi Wil,

Is the PR associante to this change this one:

https://github.com/mozilla-b2g/gaia/pull/24727

If so, could you add it as an attachment. 

Also what's the status of this work? Please take into consideration that FC for 2.1 is upcoming Friday October 10th.

Thanks!
Flags: needinfo?(clouserw)
(Assignee)

Comment 11

4 years ago
Created attachment 8500361 [details] [review]
Marketplace for v2.1 PR
(Assignee)

Comment 12

4 years ago
The current status is attempting to fix the failing Gaia tests before merging the patch in.
Flags: needinfo?(clouserw)
Thanks a lot for the heads up!
Last question Kevin, who has to review this, the code is living in gaia but don't know how is in charge of doing this.

Saw in the github history that Michael Henretty also contributed, is him the person?

Thanks!
Flags: needinfo?(kngo)
(Reporter)

Comment 15

4 years ago
It varies.  We had trouble with our last PR also with seemingly unrelated tests failing and our team doesn't know enough about Gaia to debug it.  I talked to Fabrice this morning and he said he'd try to find someone to help.
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #14)
> Last question Kevin, who has to review this, the code is living in gaia but
> don't know how is in charge of doing this.

The package lands in gaia, but the app itself is QA'ed by the marketplace team.
 
It look like you have no 2.1 blockers anymore, can you take this one?
Regarding the errors that we have in unit tests, and after follow Julien's guidance, the problem seems to be on our test system for 2.1 branch.

We are launching unit tests agains b2g-35 that includes an implementation of promises that breaks the current failing tests.
John Ford has created bug 1079391, to deal with the problems in testing 2.1 branch.
Depends on: 1079391
Fabrice, John is already working on the bug to try to get good builds (trying against the correct gecko) for 2.1

We don't know when that will be there, in the meantime I will suggest to merge this patch (since has no much to do with the problems of our testing infraestructure).

What do you think?
Flags: needinfo?(fabrice)
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #19)
> Fabrice, John is already working on the bug to try to get good builds
> (trying against the correct gecko) for 2.1
> 
> We don't know when that will be there, in the meantime I will suggest to
> merge this patch (since has no much to do with the problems of our testing
> infraestructure).
> 
> What do you think?

Sure, go ahead.
Flags: needinfo?(fabrice)
(Reporter)

Updated

4 years ago
Attachment #8500361 - Flags: review?(francisco)
Comment on attachment 8500361 [details] [review]
Marketplace for v2.1 PR

r=me thx!
Attachment #8500361 - Flags: review?(francisco) → review+
Ryan can you merge to 2.1 branch?
Flags: needinfo?(ryanvm)
Keywords: checkin-needed
Not without approval.
Flags: needinfo?(ryanvm)
Keywords: checkin-needed
Comment on attachment 8500361 [details] [review]
Marketplace for v2.1 PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
New packaged marketplace app
[User impact] if declined:
No new marketplace app xD
[Testing completed]:
Tested on device 2.1, also marketplace app QA done by marketplace team
[Risk to taking this patch] (and alternatives if risky):
Low
[String changes made]:
None
Attachment #8500361 - Flags: approval-gaia-v2.1?(fabrice)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Usually we link directly to the commit hash:
v2.1: https://github.com/mozilla-b2g/gaia/commit/dc17b7b2fbbc6780fa76fa417c0374a0123b143b
Assignee: nobody → kngo
status-b2g-v2.1: --- → fixed
status-b2g-v2.2: --- → unaffected
Target Milestone: --- → 2.1 S6 (10oct)
Attachment #8500361 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
You need to log in before you can comment on or make changes to this bug.