Closed Bug 1067567 Opened 5 years ago Closed 5 years ago

cd <objdir>; mozmake installer or mach build installer doesn't create an installer

Categories

(SeaMonkey :: Build Config, defect, blocker)

x86
Windows 7
defect
Not set
blocker

Tracking

(seamonkey2.31+ fixed, seamonkey2.32+ fixed, seamonkey2.33+ fixed)

RESOLVED FIXED
seamonkey2.33
Tracking Status
seamonkey2.31 + fixed
seamonkey2.32 + fixed
seamonkey2.33 + fixed

People

(Reporter: philip.chee, Assigned: ewong)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR:
1. mozmake build or mach build
2. cd <objdir>
3. mozmake package (works!)
4. mozmake installer (fails)
This used to work.
4a. mozmake -C suite/installer/windows/ installer
This works.
4c. mozmake installer in the TB objdir works too. So something is buggered up in our build config.
This is affecting the c-a WinNT builds.

In WinNT c-a (normal and debug) build in the find filepath_1 (for
the seamonkey*installer.exe) step:
'bash' '-c' 'find build/objdir/dist/install/sea -maxdepth 1 -type f -name *.installer.exe'
 in dir e:\builds\slave\c-aurora-w32\. (timeout 1200 secs)
 watching logfiles {}
 argv: ['bash', '-c', 'find build/objdir/dist/install/sea -maxdepth 1 -type f -name *.installer.exe']
 environment:
  !::=::\
  !EXITCODE=00000001
  ALLUSERSPROFILE=C:\Documents and Settings\All Users
  APPDATA=C:\Documents and Settings\seabld\Application Data
  APR_ICONV_PATH=d:/mozilla-build/svn-win32-1.6.3/iconv
  BOOTMODE=BKSTD
  CLIENTNAME=Console
  CLUSTERLOG=C:\WINDOWS\Cluster\cluster.log
  COMMONPROGRAMFILES=C:\Program Files\Common Files
  COMPUTERNAME=SEA-WIN32-02
  COMSPEC=C:\WINDOWS\system32\cmd.exe
  CVS_RSH=ssh
  DEVENVDIR=D:\msvs8\Common7\IDE
  EDITOR=emacs.exe --no-window-system
  FP_NO_HOST_CHECK=NO
  FRAMEWORKDIR=C:\WINDOWS\Microsoft.NET\Framework
  FRAMEWORKSDKDIR=D:\msvs8\SDK\v2.0
  FRAMEWORKVERSION=v2.0.50727
  HOME=c:/Documents and Settings/seabld
  HOMEDRIVE=C:
  HOMEPATH=\
  HOSTTYPE=i686
  INCLUDE=D:\sdks\v7.0\\include;D:\sdks\v7.0\\include\atl;D:\msvs8\VC\ATLMFC\INCLUDE;D:\msvs8\VC\INCLUDE;D:\msvs8\VC\PlatformSDK\include;;d:\sdks\dx10\include
  INPUTRC=D:/mozilla-build/msys/etc/inputrc
  JAVA_HOME=d:/jdk-1.5.0_10
  LIB=D:\sdks\v7.0\\lib;D:\msvs8\VC\ATLMFC\LIB;D:\msvs8\VC\LIB;D:\msvs8\VC\PlatformSDK\lib;D:\msvs8\SDK\v2.0\lib;;D:\mozilla-build\\atlthunk_compat;d:\sdks\dx10\lib\x86
  LIBPATH=C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727;D:\msvs8\VC\ATLMFC\LIB
  LOG="c:\tmp\buildbot-startup.log"
  LOGNAME=seabld
  LOGONSERVER=\\SEA-WIN32-02
  MACHTYPE=i686-pc-msys
  MAKE_MODE=unix
  MOZILLABUILD=D:\mozilla-build\
  MOZILLABUILDDRIVE=D:
  MOZILLABUILDPATH=\mozilla-build\
  MOZ_MSVCVERSION=8
  MOZ_NO_RESET_PATH=1
  MOZ_TOOLS=D:\mozilla-build\\moztools
  MSVC6KEY=HKLM\SOFTWARE\Microsoft\VisualStudio\6.0\Setup\Microsoft Visual C++
  MSVC71KEY=HKLM\SOFTWARE\Microsoft\VisualStudio\7.1\Setup\VC
  MSVC8EXPRESSKEY=HKLM\SOFTWARE\Microsoft\VCExpress\8.0\Setup\VC
  MSVC8KEY=HKLM\SOFTWARE\Microsoft\VisualStudio\8.0\Setup\VC
  MSVC9EXPRESSKEY=HKLM\SOFTWARE\Microsoft\VCExpress\9.0\Setup\VC
  MSVC9KEY=HKLM\SOFTWARE\Microsoft\VisualStudio\9.0\Setup\VC
  MSVCEXPROOTKEY=HKLM\SOFTWARE\Microsoft\VCExpress
  MSVCROOTKEY=HKLM\SOFTWARE\Microsoft\VisualStudio
  MSYSTEM=MINGW32
  MSYS_TBOX_CLIENT_CVS_DIR=e:/builds/tinderbox/mozilla/tools/tinderbox
  NUMBER_OF_PROCESSORS=4
  NVAPSDK=D:\sdks\tegra042\
  OLDPWD=d:/mozilla-build
  OS=Windows_NT
  OSTYPE=msys
  PATH=D:\mozilla-build\msys\local\bin;d:\mozilla-build\wget;d:\mozilla-build\7zip;d:\mozilla-build\blat261\full;d:\mozilla-build\python25;d:\mozilla-build\svn-win32-1.6.3\bin;d:\mozilla-build\upx203w;d:\mozilla-build\emacs-22.3\bin;d:\mozilla-build\info-zip;d:\mozilla-build\nsis-2.22;d:\mozilla-build\nsis-2.33u;d:\mozilla-build\hg;d:\mozilla-build\python25\Scripts;d:\mozilla-build\kdiff3;d:\mozilla-build\vim\vim72;d:\mozilla-build\yasm;.;D:\mozilla-build\msys\local\bin;D:\mozilla-build\msys\mingw\bin;D:\mozilla-build\msys\bin;d:\sdks\v7.0\bin;d:\msvs8\Common7\IDE;d:\msvs8\VC\BIN;d:\msvs8\Common7\Tools;d:\msvs8\Common7\Tools\bin;d:\msvs8\VC\PlatformSDK\bin;d:\msvs8\SDK\v2.0\bin;c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727;d:\msvs8\VC\VCPackages;c:\WINDOWS\system32;c:\WINDOWS;c:\WINDOWS\System32\Wbem;c:\Program Files\Intel\DMIX;d:\mozilla-build\python25;d:\mercurial;c:\Program Files\Microsoft SQL Server\90\Tools\binn\;d:\sdks\tegra042\tools;d:\sdks\tegra042\platformlibs\bin\winxp\x86\release;d:\sdks\tegra042\3rdparty\bin\winxp\x86\release;d:\mozilla-build\python25\scripts;d:\mozilla-build\hg\bin;d:\mozilla-build\moztools\bin
  PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
  PROCESSOR_ARCHITECTURE=x86
  PROCESSOR_IDENTIFIER=x86 Family 6 Model 30 Stepping 5, GenuineIntel
  PROCESSOR_LEVEL=6
  PROCESSOR_REVISION=1e05
  PROGRAMFILES=C:\Program Files
  PROMPT=$P$G
  PS1=\[\033]0;$MSYSTEM:\w\007
\033[32m\]\u@\h \[\033[33m\w\033[0m\]
$ 
  PWD=c:/Documents and Settings/seabld
  SDK2003SP1KEY=HKLM\SOFTWARE\Microsoft\MicrosoftSDK\InstalledSDKs\8F9E5EF3-A9A5-491B-A889-C58EFFECE8B3
  SDK2003SP2KEY=HKLM\SOFTWARE\Microsoft\MicrosoftSDK\InstalledSDKs\D2FF9F89-8AA2-4373-8A31-C838BF4DBBE1
  SDK61KEY=HKLM\SOFTWARE\Microsoft\Microsoft SDKs\Windows\v6.1
  SDK6AKEY=HKLM\SOFTWARE\Microsoft\Microsoft SDKs\Windows\v6.0A
  SDK6KEY=HKLM\SOFTWARE\Microsoft\Microsoft SDKs\Windows\v6.0
  SDK7KEY=HKLM\SOFTWARE\Microsoft\Microsoft SDKs\Windows\v7.0
  SDKDIR=D:\sdks\v7.0\
  SDKMINORVER=0
  SDKROOTKEY=HKLM\SOFTWARE\Microsoft\MicrosoftSDK\InstalledSDKs
  SDKVER=7
  SESSIONNAME=Console
  SHELL=D:/mozilla-build/msys/bin/sh
  SHLVL=1
  SSH_AGENT_PID=1696
  SSH_AUTH_SOCK=C:/DOCUME~1/seabld/LOCALS~1/Temp/ssh-fflxGe1644/agent.1644
  SYSTEMDRIVE=C:
  SYSTEMROOT=C:\WINDOWS
  TBOX_CLIENT_CVS_DIR=e:/builds/tinderbox/mozilla/tools/tinderbox
  TEMP=C:/DOCUME~1/seabld/LOCALS~1/Temp
  TEMPVC9DIR=D:\msvs9\VC\
  TERM=cygwin
  TMP=C:/DOCUME~1/seabld/LOCALS~1/Temp
  USERDOMAIN=SEA-WIN32-02
  USERNAME=seabld
  USERPROFILE=C:\Documents and Settings\seabld
  USESDK=1
  VC8DIR=D:\msvs8\VC\
  VC9DIR=D:\msvs9\VC\
  VCINSTALLDIR=D:\msvs8\VC
  VS100COMNTOOLS=D:\msvs10\Common7\Tools\
  VS80COMNTOOLS=D:\msvs8\Common7\Tools\
  VS90COMNTOOLS=D:\msvs9\Common7\Tools\
  VSINSTALLDIR=D:\msvs8
  WIN32_REDIST_DIR=d:/msvs8/VC/redist/x86/Microsoft.VC80.CRT
  WIN64=0
  WINCURVERKEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion
  WINDIR=C:\WINDOWS
  _=d:/mozilla-build/python25/python
 using PTY: False
find: build/objdir/dist/install/sea: No such file or directory
program finished with exit code 1
elapsedTime=0.109000

While the build/objdir/dist/install path exists, there's nothing
in it.
Setting to blocker because the Windows installer is not build
Severity: normal → blocker
Tried this locally and it seems to work.
Assignee: nobody → ewong
Status: NEW → ASSIGNED
Attachment #8503905 - Flags: review?(bugspam.Callek)
(In reply to Edmund Wong (:ewong) from comment #3)
> Created attachment 8503905 [details] [diff] [review]
> proposed patch (v1)
> 
> Tried this locally and it seems to work.

Aha , this is from Bug 957220, part 4 Make the Windows installer work under mozilla-central

https://hg.mozilla.org/comm-central/rev/3b5aff8c2921
Depends on: 957220
Attachment #8503905 - Flags: review?(bugspam.Callek)
Attachment #8503905 - Flags: review+
Attachment #8503905 - Flags: approval-comm-beta+
Attachment #8503905 - Flags: approval-comm-aurora+
Pushed to comm-central
http://hg.mozilla.org/comm-central/rev/ee088ecb23da
Pushed to branches:
http://hg.mozilla.org/releases/comm-aurora/rev/899d3c254de4
http://hg.mozilla.org/releases/comm-beta/rev/e7a91a71df71
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.33
You need to log in before you can comment on or make changes to this bug.