Job details: buildbotJobname persists when switching from a buildbot to non-buildbot job

RESOLVED FIXED

Status

Tree Management
Treeherder
P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: bc, Assigned: camd)

Tracking

({regression})

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
1. https://treeherder.allizom.org/ui/#/jobs?repo=mozilla-inbound&revision=38fe938f82c4
2. click on Android 2.3 opt Sm job
3. Notice https://github.com/mozilla/treeherder-ui/blob/master/webapp/app/plugins/pluginpanel.html#L103 is blank

 <li><a href="{{ buildbotJobnameHref }}" target="_blank" prevent-default-on-left-click th-filter-by-buildername>{{ buildbotJobname }}</a></li>

4. click on a buildbot job, for example Mochitest
5. Notice the value is now filled.
6. Click back on the Sm job and see the value persisted.

Updated

3 years ago
Blocks: 1059400
Priority: -- → P2
Summary: buildbotJobname persists in pluginpanel → Job details: buildbotJobname persists between jobs

Updated

3 years ago
See Also: → bug 1082707

Updated

3 years ago
Keywords: regression
I can reproduce this on stage using Bob's link. With a local instance pointing to stage data, I can also reproduce the bug.

Fwiw, when running a local instance pointing to the same data on production, the revision appears but none of these Autophone(jobs) in question, display.
(Reporter)

Comment 2

3 years ago
jfrench: At the moment Autophone is only reporting to treeherder.allizom.org. Also due to the split apks that started this weekend, Autophone is out of order.
(Assignee)

Comment 3

3 years ago
This was fixed by:

Commit pushed to master at https://github.com/mozilla/treeherder-ui

https://github.com/mozilla/treeherder-ui/commit/58eb4006ff9475bb70c979fae06009e96a111499
Assignee: nobody → cdawson
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

3 years ago
camd, I see an issue on staging where if I click on a job (say bc) then on a different job (say M1), the Job name persists. I don't see this behavior on production though. I don't understand why it is reproducible on stage but not production.

Should I file a new bug?
Flags: needinfo?(cdawson)
So this bug was actually not fixed by https://github.com/mozilla/treeherder-ui/commit/58eb4006ff9475bb70c979fae06009e96a111499
This issue was introduced by https://github.com/mozilla/treeherder-ui/commit/a6b9a2aada3c20662bd1495a93a83bb1beff74c0
and to fix it we need to re-add a 2-way data binding to the job properties here 
https://github.com/mozilla/treeherder-ui/blob/master/webapp/app/plugins/pluginpanel.html#L155
In general I think it's a good idea to restore the 2-way data binding everywhere in the left part of the bottom panel.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I just had a chat with Mauro in channel, his feeling is there isn't a lot of win in one-way binding anything in bottom-left-bottom, for the minor(if any) performance benefits vs. unknown behaviors. Per that request I will two-way bind everything in that pane.
Assignee: cdawson → tojonmz

Comment 7

3 years ago
sgtm
Actually I mis-read the first part of Mauro's comment 5, reassigning back to camd for this original outstanding bug of buildBot job persistence. My two-way binding of bottom-left-bottom will happen in another bug.
Assignee: tojonmz → cdawson
(In reply to Jonathan French (:jfrench) from comment #8)
> My two-way binding of bottom-left-bottom will happen in another bug.

This is now bug 1110845.
This was fixed in bug 1110845
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
So the issue now is limited to the autophone smoketests. This is probably due to the ui expecting a buildername but that is not available for non buildbot jobs.
We can probably create a search string based on a combination of job name, platform and options and use it instead of the buildername
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 12

3 years ago
I have a patch almost ready in bug 1079923 which will populate the buildername for Autophone.
(Assignee)

Comment 13

3 years ago
bc: great!  Yeah, sorry about that.  I thought I'd fixed it.  My bad.  But reopening this is the right call.  Just attach the patch here in a PR when it's ready (or jfrench was going to perhaps look into this as well.)
Flags: needinfo?(cdawson)
That's fine :bc is working on it from his end. I've fixed 1110845 for the other job detail entry, and it's fine on stage.

Updated

3 years ago
Duplicate of this bug: 1085725

Updated

3 years ago
Summary: Job details: buildbotJobname persists between jobs → Job details: buildbotJobname persists when switching from a buildbot to non-buildbot job

Updated

3 years ago
No longer blocks: 1059400
(Assignee)

Comment 16

3 years ago
Un-assigning from myself.  I'm not going to get to this soon.
Assignee: cdawson → nobody
This is making for very confusing UX now that we're switching more jobs over to Taskcluster. Between the completely-incorrect string from another previously-selected job and the lack of ability to filter easily on that specific job, it's making Taskcluster sheriffing pretty painful.
Sounds like we should promote this to a P1, based on Ryan's comments.
Priority: P2 → P1
(Assignee)

Comment 19

3 years ago
I have a fix for this.  will open a PR shortly.
(Assignee)

Comment 20

3 years ago
Created attachment 8587756 [details] [review]
add signature value to jobs list
Attachment #8587756 - Flags: review?(mdoglio)
(Assignee)

Comment 21

3 years ago
Created attachment 8587759 [details] [review]
job value for task cluster jobs
Attachment #8587759 - Flags: review?(mdoglio)
(Assignee)

Updated

3 years ago
Assignee: nobody → cdawson
(Assignee)

Comment 22

3 years ago
mdoglio: I updated both PRs.  I reworked the second one to make it a little clearer.  This fixes the details ``job`` field for task cluster jobs so you can filter for either.  It also adds a separate link for filtering by ``signature``.  Conversation in IRC with RyanVM and Kwierso indicated that they would like both.  The strings are more "hack-able" which is used often in their workflow.
(Assignee)

Comment 23

3 years ago
mdoglio: I meant to say that I split the second one's commits up by functionality to make it clearer and easier to review.  :)
Attachment #8587756 - Flags: review?(mdoglio) → review+
Attachment #8587759 - Flags: review?(mdoglio) → review+

Comment 24

3 years ago
Commits pushed to master at https://github.com/mozilla/treeherder-ui

https://github.com/mozilla/treeherder-ui/commit/32f00c6d600b591e6711b6c8d4b9fbb7cd9d71f4
Bug 1067579 - Refactor thPlatformName and thJobSearchStr into services

This allows them to be shared by other classes

https://github.com/mozilla/treeherder-ui/commit/3297218eb2a68af4b4dfadb97d0c7bf7295a994a
Bug 1067579 - Add searchStr filtering support for non-buildbot jobs
(Assignee)

Comment 25

3 years ago
This is now fixed so that the filtering by the ``Job`` field works the same for Buildbot and Task Cluster jobs by field strings.  This is, then, hack-able where you can tweak what you're looking for.  However, due to the nature of multiple string compares, it can have false positives (just like before).  So this change also adds another ``Filter`` field that can be used for more precise filtering by a specific job type by SHA.

In addition, the ``Buildername`` has been moved to its own field in the job details area.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Depends on: 1155321

Comment 26

3 years ago
Commits pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/708d58b7f014a3beb14eaebc46ab052d972ab56a
Bug 1067579 - Refactor thPlatformName and thJobSearchStr into services

This allows them to be shared by other classes

https://github.com/mozilla/treeherder/commit/85d4575da0cf08abb118875667410f13c5258abf
Bug 1067579 - Add searchStr filtering support for non-buildbot jobs
You need to log in before you can comment on or make changes to this bug.