[Bluetooth][PTS][Bluedroid][2.1][KitKat] HFP - TC_AG_RSV_BV_01_I Failed

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: echang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8489826 [details]
TC_AG_RSV_BV_01_I.zip

### STR
Test case : TC_AG_RSV_BV_01_I started
	- SDP Service record for PTS: 'Handsfree HF' successfully registered
	- The IUT claims support for the following eSCO LMP packet types: EV3, 2-EV3, 
	- AT: SPP connect succeeded
	- AT: Service Level Connection established
	- AT: post SLC command sequence complete
	- AT: RING
	- AT: Received +CLIP: "0980512958",129
	- AT: Incoming call established
	- HCI: Audio Connection enabled
	- MTC FAIL: HF speaker volume incorrectly set to 9
	- HCI: Audio Connection disabled
	- AT: Call terminated
	- AT: Service Level Connection disabled
	- MTC: Test case ended
Final Verdict : Fail

### Version
1. flash v166
https://mozilla.app.box.com/files/0/f/2230155871
2. flash gecko, gaia from tinderbox
https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/tinderbox-builds/mozilla-aurora-flame-kk-eng/20140909171114/
(Reporter)

Updated

4 years ago
QA Whiteboard: [COM=Bluetooth]
This is very strange the error coming from:
	Message from PTS: MTC FAIL: HF speaker volume incorrectly set to 9

However,

	125	Slave	46	AT+VGS=9.	Current speaker gain: 9			21	 00:00:00.019000	2014/9/16 下午 01:52:21.340000	
	127	Master	46	..OK..			Success	19	 00:00:00.035000	2014/9/16 下午 01:52:21.375000	
	128	Slave	46	AT+VGM=9.	Current microphone gain: 9			21	 00:00:00.003000	2014/9/16 下午 01:52:21.378000	
	130	Master	46	..OK..			Success	19	 00:00:00.053000	2014/9/16 下午 01:52:21.431000	


This looks correct, and I don't think this can affect the result.
Message from PTS: MMI:  Set the speaker volume of the Implemenation Under Test (IUT) to a level that is greater to the deafault/nominal level, then click Ok.

I guess the problem is related to we did not send out volume up indication AT command to PTS.
(Reporter)

Comment 3

4 years ago
After a couple of attempts, 
1. Make sure the value set requested is in the note below.
2. Affected by bug 1061427 and bug 1061510, unable to send real volume data out, no matter what was shown on screen, it sent 9 to PTS suite, but a reboot can fix this.

Note:
Set volume greater then default, set it >= 12. 
Set to default, set it to 7, 8 or 9.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
QA Whiteboard: [COM=Bluetooth] → [COM=Bluetooth PTS]
You need to log in before you can comment on or make changes to this bug.