[Bluetooth][PTS][Bluedroid][2.1][KitKat] HFP - TC_AG_COD_BV_02_I Failed

VERIFIED FIXED

Status

Firefox OS
Bluetooth
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ericcc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8489838 [details]
TC_AG_COD_BV_02_I.zip

### STR
Test case : TC_AG_COD_BV_02_I started
	- SDP Service record for PTS: 'Handsfree HF' successfully registered
	- The IUT claims support for the following eSCO LMP packet types: EV3, 2-EV3, 
	- The IUT claims support for the following eSCO LMP packet types: EV3, 2-EV3, 
	- The IUT claims support for the following eSCO LMP packet types: EV3, 2-EV3, 
	- AT: SPP connect succeeded
	- AT: Service Level Connection established
	- AT: post SLC command sequence complete
	- MTC: IUT was able to connect to HF when CoD set to 0x200404
	- AT: Service Level Connection disabled
	- The IUT claims support for the following eSCO LMP packet types: EV3, 2-EV3, 
	- The IUT claims support for the following eSCO LMP packet types: EV3, 2-EV3, 
	- AT: SPP connect succeeded
	- AT: Service Level Connection established
	- AT: post SLC command sequence complete
	- MTC: IUT was able to connect to HF when CoD set to 0x202404
	- AT: Service Level Connection disabled
Final Verdict : None

### 
The 3rd time DUT sends SLC to PTS.
1. Device shown pairing under PTS-HFP in list.
2. Pairing request page not shown.

3. Tapping Searching for devices.
4. PTS-HFP shown in list but not able to tap UI, not responsive. 

5. Toggle BT - Unable to turn off BT, toggle moved to left, but list is still there. "Searching for devices" still can be tapped, and searching is ongoing, but items in list cannot be tapped.

### Version
1. flash v166
https://mozilla.app.box.com/files/0/f/2230155871
2. flash gecko, gaia from tinderbox
https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/tinderbox-builds/mozilla-aurora-flame-kk-eng/20140909171114/
(Reporter)

Updated

4 years ago
QA Whiteboard: [COM=Bluetooth]
Couldn't proceed the test since pair view is not shown most of the time.
(Not every time, but the reproduce rate is quite high.
 Mostly, the pair view won't show up when I try to pair with the remote device second time.)

By adding the log in the below function
https://github.com/mozilla-b2g/gaia/blob/master/apps/bluetooth/js/pair_manager.js#L53
I can see the correct pairing info reported by gecko, but logs in both req.onsuccess and req.onerror are not printed, and no pair view is shown.

Ian, any ideas from gaia point of view?

Note that, I can reproduce this on both flame(bluez) and flame-kk(bluedroid) using aurora code base.
Flags: needinfo?(iliu)
It seems the error stated in https://bugzilla.mozilla.org/show_bug.cgi?id=1061510 will happen before every get stuck.
Assignee: nobody → shuang
Clear needinfo since the root cause is found in comment2.
This can be passed after apply the patch in bug 1061510.
Depends on: 1061510
Flags: needinfo?(iliu)
Assignee: shuang → nobody

Updated

4 years ago
QA Whiteboard: [COM=Bluetooth] → [COM=Bluetooth PTS]
Fixed after Bug 1065999 is landed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 5

4 years ago
Verified on
Gaia-Rev        778ebac47554e1c4b7e9a952d73e850f58123914
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/aa98eb8873a2
Build-ID        20141005160206
Version         34.0a2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.