Remove system app navigation shim from bluetooth marionette webapi tests

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: qdot, Assigned: qdot)

Tracking

unspecified
2.1 S5 (26sep)
x86_64
Linux
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(b2g-v1.4 unaffected, b2g-v2.0 unaffected, b2g-v2.0M unaffected, b2g-v2.1 unaffected, b2g-v2.2 fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment, 1 obsolete attachment)

Now that bug 1058158 has landed, we should no longer need the explicit navigation to system app step in the bluetooth tests. It may actually be what's causing our perma-orange on Mnw from bug 1009157.
Looks like this may be causing the permaoranges on b2g-i.

10:19:40     INFO -  09-16 16:27:23.418 I/Gecko   (   44): 1410884843425	Marionette	DEBUG	Got request: setTestName, data: {"to":"0","sessionId":{"rotatable":true,"browserVersion":"35.0a1","takesScreenshot":true,"appBuildId":"20140916074856","XULappId":"{3c2e2abc-06d4-11e1-ac3b-374f68613e61}","secureSsl":false,"platform":"ANDROID","browserName":"B2G","version":"35.0a1","device":"qemu","b2g":true,"nativeEvents":false,"platformVersion":"35.0a1","takesElementScreenshot":true,"platformName":"ANDROID","handlesAlerts":false},"name":"setTestName","parameters":{"value":"test_navigate_to_default_url.py testNavigateToDefault.test_navigate_to_default_url"}}, id: {6d11850d-fbfd-4e6d-8c36-d336eb2e1c43}
10:19:40     INFO -  09-16 16:27:23.468 I/Gecko   (   44): 1410884843474	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {6d11850d-fbfd-4e6d-8c36-d336eb2e1c43}, {6d11850d-fbfd-4e6d-8c36-d336eb2e1c43}
10:19:40     INFO -  09-16 16:27:23.559 I/Gecko   (   44): 1410884843567	Marionette	DEBUG	Got request: execute, data: {"to":"0","sessionId":{"rotatable":true,"browserVersion":"35.0a1","takesScreenshot":true,"appBuildId":"20140916074856","XULappId":"{3c2e2abc-06d4-11e1-ac3b-374f68613e61}","secureSsl":false,"platform":"ANDROID","browserName":"B2G","version":"35.0a1","device":"qemu","b2g":true,"nativeEvents":false,"platformVersion":"35.0a1","takesElementScreenshot":true,"platformName":"ANDROID","handlesAlerts":false},"name":"executeScript","parameters":{"scriptTimeout":null,"specialPowers":false,"script":"log('TEST-START: /builds/slave/test/build/tests/marionette/tests/dom/bluetooth/tests/marionette/test_navigate_to_default_url.py:test_navigate_to_default_url')","newSandbox":true,"args":[],"filename":"marionette_test.py","line":543}}, id: {a81f24c2-da32-4c3a-9cdb-440baae7bfb8}
10:19:40     INFO -  09-16 16:27:23.689 I/Gecko   (   44): MARIONETTE LOG: INFO: TEST-START: /builds/slave/test/build/tests/marionette/tests/dom/bluetooth/tests/marionette/test_navigate_to_default_url.py:test_navigate_to_default_url
10:19:40     INFO -  09-16 16:27:23.739 I/Gecko   (   44): 1410884843740	Marionette	INFO	sendToClient: {"from":"0","value":null}, {a81f24c2-da32-4c3a-9cdb-440baae7bfb8}, {a81f24c2-da32-4c3a-9cdb-440baae7bfb8}
10:19:40     INFO -  09-16 16:27:23.809 I/Gecko   (   44): 1410884843812	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {35bd0087-c90a-4788-bbd0-ca9dc6d5a77d}, {35bd0087-c90a-4788-bbd0-ca9dc6d5a77d}
10:19:40     INFO -  09-16 16:27:36.529 I/GeckoDump(   44): LogShake: starting captureLogs listener
10:19:40     INFO -  09-16 16:27:45.298 I/Gecko   (   44): [Parent 44] WARNING: waitpid failed pid:174 errno:10: file ../../../gecko/ipc/chromium/src/base/process_util_posix.cc, line 261
10:19:40     INFO -  09-16 16:27:45.298 I/Gecko   (   44): IPDL protocol error: Handler for AsyncMessage returned error code
10:19:40     INFO -  09-16 16:27:45.308 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:45.308 I/Gecko   (   44): ###!!! [Parent][DispatchAsyncMessage] Error: (msgtype=0x2C00A2,name=PContent::Msg_AsyncMessage) Processing error: message was deserialized, but the handler returned false (indicating failure)
10:19:40     INFO -  09-16 16:27:45.308 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:45.348 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:45.348 I/Gecko   (   44): ###!!! [Parent][OnMaybeDequeueOne] Error: Channel error: cannot send/recv
10:19:40     INFO -  09-16 16:27:45.348 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:45.348 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:45.348 I/Gecko   (   44): ###!!! [Parent][OnMaybeDequeueOne] Error: Channel error: cannot send/recv
10:19:40     INFO -  09-16 16:27:45.348 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:45.358 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:45.358 I/Gecko   (   44): ###!!! [Parent][OnMaybeDequeueOne] Error: Channel error: cannot send/recv
10:19:40     INFO -  09-16 16:27:45.358 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:45.358 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:45.358 I/Gecko   (   44): ###!!! [Parent][OnMaybeDequeueOne] Error: Channel error: cannot send/recv
10:19:40     INFO -  09-16 16:27:45.358 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:45.358 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:45.358 I/Gecko   (   44): ###!!! [Parent][OnMaybeDequeueOne] Error: Channel error: cannot send/recv
10:19:40     INFO -  09-16 16:27:45.358 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:45.559 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:45.559 I/Gecko   (   44): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
10:19:40     INFO -  09-16 16:27:45.559 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:45.569 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:45.569 I/Gecko   (   44): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
10:19:40     INFO -  09-16 16:27:45.569 I/Gecko   (   44):
10:19:40  WARNING -  09-16 16:27:45.869 E/Homescreen(  310): [JavaScript Error: "IndexedDB UnknownErr: IDBDatabase.cpp:778"]
10:19:40  WARNING -  09-16 16:27:45.939 E/GeckoConsole(   44): [JavaScript Error: "TypeError: window.lockScreenNotificationBuilder is undefined" {file: "app://system.gaiamobile.org/js/lockscreen_window.js" line: 43}]
10:19:40     INFO -  09-16 16:27:46.328 I/Gecko   (   44): ############################### browserElementPanning.js loaded
10:19:40     INFO -  09-16 16:27:46.458 I/Gecko   (   44): ######################## BrowserElementChildPreload.js loaded
10:19:40     INFO -  09-16 16:27:47.168 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:47.168 I/Gecko   (   44): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
10:19:40     INFO -  09-16 16:27:47.168 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:47.589 I/Gecko   (   44): [Parent 44] WARNING: waitpid failed pid:310 errno:10: file ../../../gecko/ipc/chromium/src/base/process_util_posix.cc, line 261
10:19:40     INFO -  09-16 16:27:47.599 I/Gecko   (   44): [Parent 44] WARNING: waitpid failed pid:229 errno:10: file ../../../gecko/ipc/chromium/src/base/process_util_posix.cc, line 261
10:19:40     INFO -  09-16 16:27:47.698 I/Gecko   (   44): IPDL protocol error: Handler for AsyncMessage returned error code
10:19:40     INFO -  09-16 16:27:47.698 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:47.698 I/Gecko   (   44): ###!!! [Parent][DispatchAsyncMessage] Error: (msgtype=0x2C00A2,name=PContent::Msg_AsyncMessage) Processing error: message was deserialized, but the handler returned false (indicating failure)
10:19:40     INFO -  09-16 16:27:47.698 I/Gecko   (   44):
10:19:40     INFO -  09-16 16:27:47.839 E/GeckoConsole(   44): Content JS WARN at app://system.gaiamobile.org/js/homescreen_launcher.js:219 in hl_getHomescreen: HomescreenLauncher: not ready right now.
10:19:40     INFO -  09-16 16:27:47.849 E/GeckoConsole(   44): Content JS LOG at app://system.gaiamobile.org/js/wallpaper_manager.js:346 in debug: [WallpaperManager] started
Created attachment 8490212 [details] [diff] [review]
Patch 1 (v1) - Remove navigation to system app since we use test container now
Attachment #8490212 - Flags: review?(mdas)
Comment on attachment 8490212 [details] [diff] [review]
Patch 1 (v1) - Remove navigation to system app since we use test container now

This patch is blank, but assuming you mean this patch: https://hg.mozilla.org/try/rev/3c72a6d1e387, then yes, I r+ it
Attachment #8490212 - Flags: review?(mdas) → review+
https://hg.mozilla.org/integration/b2g-inbound/rev/b7379522f4e2

I assume that we're going to need this on Aurora as well once bug 1058158 lands and sticks there? If so, please set [checkin-needed-aurora] on the whiteboard so I find it :)
Assignee: nobody → kyle
Flags: in-testsuite-
blocking-b2g: --- → 2.2?
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → unaffected
status-b2g-v2.0M: --- → unaffected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Created attachment 8490400 [details] [diff] [review]
Patch 1 (v2) - Remove navigation to system app since we use test container now; r=mdas

Approval Request Comment
[Feature/regressing bug #]: Bug 1058158
[User impact if declined]: Mnw will fail due to system restarts while using test container 
[Describe test coverage new/current, TBPL]: This is a test
[Risks and why]: None
[String/UUID change made/needed]: None
Attachment #8490212 - Attachment is obsolete: true
Attachment #8490400 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/b7379522f4e2
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S5 (26sep)
Marking systemsfe and also NO_UPLIFT 'til we figure out what's up with bug 1058158 (and I'll deal with the uplift on that once we do)
Whiteboard: [systemsfe][NO_UPLIFT]
Comment on attachment 8490400 [details] [diff] [review]
Patch 1 (v2) - Remove navigation to system app since we use test container now; r=mdas

This causes a LOT of issues on aurora, and doesn't seem to be breaking Mnw like it used to. So removing request for aurora landing for right now.
Attachment #8490400 - Flags: approval-mozilla-aurora?
Marking unaffected on aurora since it's been building fine with no update.
status-b2g-v2.1: affected → unaffected
status-b2g-v2.2: affected → fixed
(In reply to Kyle Machulis [:kmachulis] [:qdot] (USE NEEDINFO?) from comment #11)
> Marking unaffected on aurora since it's been building fine with no update.

Can we remove the no_uplift?
blocking-b2g: 2.2? → ---
Flags: needinfo?(kyle)
Yup, done.
Flags: needinfo?(kyle)
Whiteboard: [systemsfe][NO_UPLIFT] → [systemsfe]
Duplicate of this bug: 1020732
You need to log in before you can comment on or make changes to this bug.