Closed Bug 1009157 Opened 5 years ago Closed 4 years ago

Intermittent test_dom_BluetoothManager_enabled.js | ScriptTimeoutException: ScriptTimeoutException: timed out

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox31 fixed, firefox32 fixed, firefox33 fixed, firefox-esr24 unaffected, b2g-v1.3 unaffected, b2g-v1.3T unaffected, b2g-v1.4 fixed, b2g-v2.0 fixed, b2g-v2.1 fixed)

RESOLVED WORKSFORME
2.0 S4 (20june)
Tracking Status
firefox31 --- fixed
firefox32 --- fixed
firefox33 --- fixed
firefox-esr24 --- unaffected
b2g-v1.3 --- unaffected
b2g-v1.3T --- unaffected
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: RyanVM, Assigned: jaliu)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #969109 +++

I strongly doubt this is really a new issue. More likely, it was lost in the noise of bug 948895. As such, I can't really say when this regressed, but only that it's happening.

https://tbpl.mozilla.org/php/getParsedLog.php?id=39497581&tree=Fx-Team

b2g_emulator_vm fx-team opt test marionette-webapi on 2014-05-12 09:45:03 PDT for push 99ea54c33bcf
slave: tst-linux64-spot-468

10:11:38     INFO -  TEST-START test_dom_BluetoothManager_enabled.js
10:17:43     INFO -  /builds/slave/test/build/tests/marionette/tests/dom/bluetooth/tests/marionette/test_dom_BluetoothManager_enabled.js, runTest (marionette_test.MarionetteJSTestCase) ... ERROR
10:17:43     INFO -  ======================================================================
10:17:43     INFO -  ERROR: None
10:17:43     INFO -  ----------------------------------------------------------------------
10:17:43     INFO -  Traceback (most recent call last):
10:17:43     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette_test.py", line 170, in run
10:17:43     INFO -      testMethod()
10:17:43     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette_test.py", line 497, in runTest
10:17:43     INFO -      filename=os.path.basename(self.jsFile))
10:17:43     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette.py", line 1057, in execute_js_script
10:17:43     INFO -      line=None)
10:17:43     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/decorators.py", line 35, in _
10:17:43     INFO -      return func(*args, **kwargs)
10:17:43     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette.py", line 614, in _send_message
10:17:43     INFO -      "Connection timed out", status=ErrorCodes.TIMEOUT)
10:17:43    ERROR -  TimeoutException: TimeoutException: Connection timed out
10:17:43     INFO -  Most recent errors/exceptions are:
10:17:43     INFO -  05-12 13:11:27.621 E/GeckoConsole(   44): [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,<html>test%20page</html>" line: 0}]
10:17:43     INFO -  05-12 13:11:30.851 E/GeckoConsole(   44): [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,<html>test%20page</html>" line: 0}]
10:17:43     INFO -  05-12 13:11:34.072 E/GeckoConsole(   44): [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,<html>test%20page</html>" line: 0}]
10:17:43     INFO -  05-12 13:11:37.202 E/GeckoConsole(   44): [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,<html>test%20page</html>" line: 0}]
10:17:43     INFO -  05-12 13:11:40.461 E/GeckoConsole(   44): [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,<html>test%20page</html>" line: 0}]
10:17:43    ERROR -  TEST-UNEXPECTED-FAIL | test_dom_BluetoothManager_enabled.js | TimeoutException: TimeoutException: Connection timed out
10:17:43     INFO -  ----------------------------------------------------------------------
10:17:43     INFO -  Ran 1 test in 363.705s
10:17:43  WARNING -  FAILED (errors=1)
That could be related to bug 1011110.
See Also: → 1011110
Assignee: nobody → jaliu
Attachment #8435561 - Flags: review?(echou) → review+
Summary: Intermittent test_dom_BluetoothManager_enabled.js | TimeoutException: TimeoutException: Connection timed out → Intermittent test_dom_BluetoothManager_enabled.js | ScriptTimeoutException: ScriptTimeoutException: timed out
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/6b8a3854ad75
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S4 (20june)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I checked the last five TBPL logs which TBPL Robot reported.

The test_dom_BluetoothManager_enabled.js exceeded timeout when it attempted to get the value of BT setting by calling mozSettings.createLock().get("bluetooth.enabled") at the beginning of test.

The root cause of those timeouts are that SettingsManager failed to create SettingsLock.

The warnings could be found on TBPL logs.
https://tbpl.mozilla.org/php/getParsedLog.php?id=42810088&full=1&branch=mozilla-inbound

> WARNING - GeckoConsole: [JavaScript Error: "IndexedDB UnknownErr: OpenDatabaseHelper.cpp:1891"]
> INFO - Gecko: Cannot open Settings DB. Trying to open an old version?
Depends on: 1032673
These six comments above which reported by TBPL Robot have the same symptom as comment 29 described.
The issue will be tracked by Bug 1032673.
(In reply to TBPL Robot from comment #57)
> RyanVM
> https://tbpl.mozilla.org/php/getParsedLog.php?id=45864924&tree=Mozilla-
> Inbound
> b2g_emulator_vm mozilla-inbound opt test marionette-webapi on 2014-08-13
> 09:49:59
> revision: 502f2efe3279
> slave: tst-linux64-spot-1264
> 
> TEST-UNEXPECTED-ERROR | test_dom_BluetoothManager_enabled.js |
> ScriptTimeoutException: ScriptTimeoutException: timed out
> Return code: 10

[JavaScript Error: "AbortError" {file: "app://system.gaiamobile.org/shared/js/async_storage.js" line: 99}]
[JavaScript Error: "NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIXPCComponents_Utils.cloneInto]" {file: "jar:file:///system/b2g/omni.ja!/components/SettingsManager.js" line: 49}]
... (multiple times)
IPDL protocol error: Handler for PIndexedDB returned error code
[JavaScript Error: "IndexedDB UnknownErr: OpenDatabaseHelper.cpp:1906"]
Cannot open Settings DB. Trying to open an old version?
[JavaScript Error: "NS_ERROR_FAILURE: Failure arg 0 [nsIDOMRequestService.fireError]" {file: "jar:file:///system/b2g/omni.ja!/components/SettingsManager.js" line: 155}]
This basically went perma-fail in the last couple days. Needs attention ASAP or I'll have to disable the test(s).
Flags: needinfo?(jaliu)