edge gesture swipe shows flash of black between static app image and actual live app loading

VERIFIED WORKSFORME

Status

Firefox OS
Gaia::System::Window Mgmt
VERIFIED WORKSFORME
3 years ago
3 years ago

People

(Reporter: asa, Unassigned)

Tracking

unspecified
2.2 S6 (20feb)
x86
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

3 years ago
Tested in today's nightly (shallow flashed JB build) on Flame.

When I use the edge gesture to swipe between apps, there's an ugly flash of black that happens between the static image of the app that's swiped in and the loading of the live app. That flash of black makes everything feel really janky. 

Steps: 
1. load up email and calendar apps
2. swipe between them

Results:
Flash of black between the loading of the static app image and the live app. 

Expected: 
A transition that doesn't have a flash of black. Ideally, a fade or other transition that feels less jarring.
This came up while verifying bug 939809, do we want to block on it?
blocking-b2g: --- → 2.2?

Updated

3 years ago
Whiteboard: [systemsfe]
(In reply to Sam Foster [:sfoster] from comment #1)
> This came up while verifying bug 939809, do we want to block on it?

Whats the UX input here?
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 3

3 years ago
This may be a dupe of bug 1113435, which is landing pretty soon, or possibly bug 1133518 or bug 1132741. Let's wait until those land and then re-test. (ftr, I think we should block on this, but it's quite likely already fixed)

Comment 4

3 years ago
This is not something we'd expect to see and may be a regression. We used to see this in 1.4 and 2.0 testing, if I'm not mistaken.
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 5

3 years ago
Chris, 1133518 is fixed, can you verify if this fixes the bug?
Flags: needinfo?(chrislord.net)

Comment 6

3 years ago
I don't see this with fixes for these bugs applied (using my local tree, I have fixes for all three bugs - I don't know if bug 1133518 specifically caused it, or either of the other two).
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(chrislord.net)
Resolution: --- → WORKSFORME
blocking-b2g: 2.2? → 2.2+

Updated

3 years ago
Target Milestone: --- → 2.2 S6 (20feb)
cannot reproduce this bug anymore
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.