Most of the applications (like Gallery, Settings or Email) in B2G display blank and can't be scrolled

VERIFIED FIXED in Firefox OS master

Status

()

Core
DOM
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: jlorenzo, Assigned: gsvelto)

Tracking

({qablocker, regression, smoketest})

38 Branch
2.2 S6 (20feb)
All
Gonk (Firefox OS)
qablocker, regression, smoketest
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
STR
1. Go to Settings, then Bluetooth.
2. Observe the white screen.

This prevents the smoke test[1] to pass.

Does repro on the current 3.0[2] but not on 2.2[3]. Does not repro on the build where bug 1132741 was spotted[4].

[Blocking Requested - why for this release]: Smoketest regression. Regression window wanted.

[1] https://moztrap.mozilla.org/manage/case/6071/
[2] Build ID               20150216010344
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e0cb32a0b1aa
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.050451
Firmware Date          Mon Feb 16 05:05:02 EST 2015
Bootloader             L1TC000118D0

[3] Build ID               20150216002503
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/62c80c92b39e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.040540
Firmware Date          Mon Feb 16 04:05:52 EST 2015
Bootloader             L1TC000118D0

[4] Build ID               20150212064620
Gaia Revision          2a2b008f9ae957fe19ad540d233d86b5c0b6829e
Gaia Date              2015-02-12 07:44:13
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/81f979b17fbd
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150212.102136
Firmware Date          Thu Feb 12 10:21:46 EST 2015
Bootloader             L1TC000118D0
(Reporter)

Comment 1

3 years ago
One thing I forgot to mention, if you go to the task manager you're able to see the bluetooth page again. If you tap where the buttons are supposed to be and then go back to the task manager, you can see the state of the buttons changed.
That's 100% what I have documented in bug 1132741 comment 21.
I could confirm the issue I mentioned in bug 1132741 comment 22 looks exactly like this.
(Reporter)

Comment 4

3 years ago
On mozilla-inbound:

Last working:
Build ID               20150212152257
Gaia Revision          2a2b008f9ae957fe19ad540d233d86b5c0b6829e
Gaia Date              2015-02-12 07:44:13
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/5186614bfe01
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150212.170722
Firmware Date          Thu Feb 12 17:07:33 EST 2015
Bootloader             L1TC000118D0

First broken:
Build ID               20150212154007
Gaia Revision          2a2b008f9ae957fe19ad540d233d86b5c0b6829e
Gaia Date              2015-02-12 07:44:13
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/ae4d683969e3
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150212.190628
Firmware Date          Thu Feb 12 19:06:39 EST 2015
Bootloader             L1TC000118D0

Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5186614bfe01&tochange=ae4d683969e3

Seems to be broken by bug 1075670. What do you think David?
Blocks: 1075670
Flags: needinfo?(davidp99)
Keywords: regressionwindow-wanted
Component: Graphics → DOM
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → All
See Also: → bug 1133588
This bug somehow blocks us development and testing.
(Reporter)

Comment 6

3 years ago
Per comment 5.
Keywords: qablocker
(Reporter)

Updated

3 years ago
Blocks: 1124095
(Reporter)

Comment 7

3 years ago
I tried to do the backout but I got a conflict and then a compile error. Hence, I checked that bug 1075670 was the actual cause of the issue:

I checked out gecko at 5186614bfe01 => Can't repro the bug
Then I checked it out at 17a3125a2f05 => Repro.

Bug 1075670 is the cause of the issue. David, could you back bug 1075670 out?
Whiteboard: [backout-needed]
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1133210
(Reporter)

Comment 9

3 years ago
Making the summary of the bug more general, per its dupe.
Summary: Settings -> Bluetooth shows as a blank page with just the title displayed → Most of the applications (like Gallery, Settings or Email) in B2G display blank and can't be scrolled

Updated

3 years ago
Duplicate of this bug: 1133056
I backed out bug 1075670 directly on m-c using gsvelto's patch.

https://hg.mozilla.org/mozilla-central/rev/4bb425001d8a
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [backout-needed]
Assignee: nobody → gsvelto
status-b2g-master: affected → fixed
(Reporter)

Comment 12

3 years ago
Not considering it as a blocker would make it disappear on http://mozilla-b2g.github.io/b2g-dashboard/
blocking-b2g: 3.0? → 3.0+
Flags: needinfo?(davidp99)
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1133210
This issue is verified fixed on the latest Nightly 3.0 Flame build.

Actual Results: Applications load as expected, no white screens are seen.

Environmental Variables:
Device: Flame 3.0 KK (319MB) (Full Flash)
BuildID: 20150219010228
Gaia: 620aecfde85a8b093247837c55de2708e22be1e1
Gecko: 360b5f211180
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
Hi Johan,

I'm looking into the issue here but I'm getting somewhat different results.  When you said that the Bluetooth page was blank, does that mean completely blank?  Or 'missing elements'.  Here's what I've seen:

Without the patches, you can go to Settings->Bluetooth and see the image in the "no-patch" image attachment.  It has all of the screen elements.  With the patches (manually applied to trunk), I get the image in the "patched" image attachment.  Clearly, its "missing" the "Paired Devices" and "Devices in the area" and "Searching for devices..." sections.  Looking over the source code (and reading the screen), I realize that is by design.  The patches in bug 1075670 actually fix a longstanding bug that was not updating the visibility of those elements but, when I "Turn Bluetooth on the view devices in the area", all of those elements reappear.  Indeed, they flash on screen for a fraction of a second before disappearing when I first navigate to the bluetooth page (this is clearly a bug).

The other apps in the title (Gallery and Email) also look fine to me but I'm not sure what I should be looking for.  I definitely don't see the issue in bug 1132741 -- I think its unrelated.  I am using a Flame-kk on a Flame device.
Flags: needinfo?(jlorenzo)
Created attachment 8566658 [details]
Bluetooth with no patches applied
Created attachment 8566659 [details]
Bluetooth with patches applied
Looks like you're using B2G desktop, which may not have the same results as on-device. On my current master build on a Flame device I see the "with patches applied" version of the screen, even though I don't have your patches.
Thanks.  I'll see if I can get the blank screen now.
Flags: needinfo?(jlorenzo)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Duplicate of this bug: 1133973
status-b2g-v2.5: --- → verified
Target Milestone: --- → 2.2 S6 (20feb)
status-b2g-v2.5: verified → ---
You need to log in before you can comment on or make changes to this bug.