Closed Bug 1068508 Opened 6 years ago Closed 6 years ago

NoScript stopped working as of the 2014-09-16 nightly

Categories

(WebExtensions :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: octoploid, Assigned: mao)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20140917043738

Steps to reproduce:

NoScript stopped working. The blocking list is always empty.
Component: Untriaged → Extension Compatibility
Same here, running on Windows 8.1.

And it is not only NoScript, but also AdBlock Plus, VimFX, PureURL... and most of the other addons I use. The few addons that work are Greasemonkey, HYYPS-Everywhere and WOT.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: e10s-noscript
I meant HTTPS-Everywhere, not HYYPS. Sorry.

Also, this began after updating to the 2014-09-14 build. Also seems to be referenced here: https://support.mozilla.org/en-US/questions/1020200
(In reply to Giorgio Maone from comment #2)
> 
> *** This bug has been marked as a duplicate of bug 1058542 ***

Giorgio, I do not have e10s enabled. Yet, NoScript does not work.
Yes. This is not a dup.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(In reply to Octoploid from comment #5)
> Yes. This is not a dup.

You're right, sorry for the haste.
It seems to have been caused by the JavaScript parser now spitting as some previously valid code.

I've fixed the reported issue in NoScript 2.6.8.42rc1, which I've just uploaded to AMO and made available from http://noscript.net/getit#devel 

Unfortunately I cannot guarantee the same cause won't break anything else. If it does, feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Well, Дарио says it also breaks other extensions.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
(In reply to Giorgio Maone from comment #6)
> (In reply to Octoploid from comment #5)
> > Yes. This is not a dup.
> 
> You're right, sorry for the haste.
> It seems to have been caused by the JavaScript parser now spitting as some
> previously valid code.

Can you elaborate on what exactly what went wrong, so that the JavaScript guys can take a look?
Summary: NoScript stopped working → Numerous extensions stopped working
What happened is that the following code:
<script>
var a = 1;
(function () {
let a = a;
alert(a);
})()
</script>
Used to run with no warning, even though the result was not what you may expect (it alerted "undefined").

No it breaks early with
"Exception: can't access let declaration `a' before initialization"

(which, IMHO, is much better, but will unearth lots of previously silent and often innocuous bugs).
same problem, since 35.0a1 (2014-09-16). no block list available (though it still blocks all js, just can't enable js execution).
Started with one of the Bug 1001090 checkins.
Which one I cannot tell because some of them doesn't even build,
so bisection is impossible.
Blocks: 1001090
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
(In reply to Дарио Ѓорѓевски from comment #1)
> Same here, running on Windows 8.1.
> 
> And it is not only NoScript, but also AdBlock Plus, VimFX, PureURL... and
> most of the other addons I use. The few addons that work are Greasemonkey,
> HYYPS-Everywhere and WOT.

It is expected that bug 1001090 unearth problems in addons, since the JS parser is now more strict about potentially risky uses of let.

These need fixing in the addons not in the JS engine, so this is an evangelism issue. As such, we need one Firefox::Extension Compatibility bug for each broken addon to track this most effectively, rather than multiple addons in one bug.

Since this bug as filed was just for NoScript (comment 0), this bug is now fixed per comment 6 - so closing this out. Please file new bugs blocking bug 1001090 for any addons broken in the 2014-09-16 nightly but working in 2014-09-15.
Assignee: nobody → g.maone
Status: NEW → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Summary: Numerous extensions stopped working → NoScript stopped working as of the 2014-09-16 nightly
(In reply to Ed Morley [:edmorley] from comment #12)
> These need fixing in the addons not in the JS engine, so this is an
> evangelism issue. As such, we need one Firefox::Extension Compatibility bug
> for each broken addon to track this most effectively, rather than multiple
> addons in one bug.

Presumably these bugs really belong in Tech Evang::Add-ons, then? (Not Firefox::Extension Compatibility)
Component: Extension Compatibility → Add-ons
Product: Firefox → Tech Evangelism
What happened is that I the addons I mentioned (AdBlock Plus, VimFX, ...) stopped working and I no longer even see their toolbar icons (even though NoScript had stopped working, I _did_ see its toolbar icon and could open up its menu).

Trying to re-install, for example, AdBlock Plus, gives me an "Adblock Plus cannot be installed because Nightly cannot modify the needed file" error.

Installing the same addon on a clean profile works as expected. Perhaps my profile was corrupted during an update; I do now know.
(In reply to Дарио Ѓорѓевски from comment #14)
> What happened is that I the addons I mentioned (AdBlock Plus, VimFX, ...)
> stopped working and I no longer even see their toolbar icons (even though
> NoScript had stopped working, I _did_ see its toolbar icon and could open up
> its menu).

That difference doesn't really mean much, for addons that were broken by bug 1001090. It could just means those add-ons have brokenness earlier on in their code than NoScript did. (See e.g. bug 1068790 for another add-on that doesn't manage to get its icon displayed anymore.)

> Installing the same addon on a clean profile works as expected. Perhaps my
> profile was corrupted during an update; I do now know.

Not sure what went wrong there, but that definitely sounds unrelated to this bug, then. (and that issue probably was not caused by bug 1068790)

In any case, per comment 12, please file different bugs for different Add-ons.  This bug is NoScript-specific, and it's now fixed (in the NoScript development version).
(In reply to Daniel Holbert [:dholbert] from comment #15)
> Not sure what went wrong there, but that definitely sounds unrelated to this
> bug, then. (and that issue probably was not caused by bug 1068790)

(sorry, wrong bug #; I meant to say "probably was not caused by bug 1001090")
(In reply to Daniel Holbert [:dholbert] from comment #13)
> Presumably these bugs really belong in Tech Evang::Add-ons, then? (Not
> Firefox::Extension Compatibility)

Ah indeed, I thought i was talking about the evang component, didn't realise about that one.
(In reply to Дарио Ѓорѓевски from comment #14)
> What happened is that I the addons I mentioned (AdBlock Plus, VimFX, ...)
> stopped working and I no longer even see their toolbar icons (even though
> NoScript had stopped working, I _did_ see its toolbar icon and could open up
> its menu).

This is also happened during my bisection and was definitely caused by bug 1001090.
What happened is that the browser started up with the default layout for a few commits (of 1001090)
and then switched back to my custom layout for other commits of this series.
Component: Add-ons → General
Product: Tech Evangelism → WebExtensions
You need to log in before you can comment on or make changes to this bug.