[Tracking] Desktop, mobile: update Wikipedia searchplugins to use HTTPS

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: flod, Assigned: flod)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(firefox32 wontfix, firefox33 wontfix, firefox34 wontfix, firefox35 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
We need to update URLs in Wikipedia searchplugins, on both mobile and desktop, to use HTTPS. See bug 758857 for more details.

1. Make sure the URL works with https and fix all 3 URLs.
2. Put a link to the changeset(s) in this bug. You can land this change on l10n-central and mozilla-aurora
(Assignee)

Comment 1

5 years ago
Posted file wikipedia_test.txt
Not seeing any error while checking current URL with https, so we should be good (but please test it anyway).
(Assignee)

Comment 2

5 years ago
Page to track status on Aurora
https://l10n.mozilla-community.org/~flod/p12n/bug1069123_wikipediassl_aurora/

Since we're touching Wikipedia's searchplugin, I'll whitelist also the change to add the extra images on Desktop (65x26, 130x52, en-US bug 1026298).
http://hg.mozilla.org/mozilla-central/rev/985fc62be7f3

Italian (it) fixed
http://hg.mozilla.org/releases/l10n/mozilla-aurora/it/rev/c8b8ef6bf096
http://hg.mozilla.org/l10n-central/it/rev/c8b8ef6bf096
Assignee: nobody → francesco.lodolo

Comment 7

5 years ago
(In reply to Francesco Lodolo [:flod] from comment #2)
> Since we're touching Wikipedia's searchplugin, I'll whitelist also the
> change to add the extra images on Desktop (65x26, 130x52, en-US bug 1026298).
> http://hg.mozilla.org/mozilla-central/rev/985fc62be7f3

Hm, so you're using the "Wikipedia" wordmark rather than a (square) icon. Note, there are about 150 languages which use a variant of the name; while the puzzle icon is "multilingual".

While we're at it: https://www.wiktionary.org/ has many other languages who may be considered for addition to the respective locales. :-)
flod - Do you have a list of the remaining locales that should provide updates for Firefox 34?
Flags: needinfo?(francesco.lodolo)
Should I uplift to beta for French?
(Assignee)

Comment 17

5 years ago
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #15)
> flod - Do you have a list of the remaining locales that should provide
> updates for Firefox 34?

Our target was Firefox 35 from the start, we don't do mass changes like this one on Beta.

Unfortunately I don't have time to work on this before November 10, so the situation is far from good.
https://l10n.mozilla-community.org/~flod/p12n/bug1069123_wikipediassl_aurora/

Most big locales are OK, all small ones are not.
Flags: needinfo?(francesco.lodolo)
(In reply to Francesco Lodolo [:flod] from comment #17)
> (In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #15)
> > flod - Do you have a list of the remaining locales that should provide
> > updates for Firefox 34?
> 
> Our target was Firefox 35 from the start, we don't do mass changes like this
> one on Beta.

Thank you for the correction. I have adjusted the tracking flags.

> Unfortunately I don't have time to work on this before November 10, so the
> situation is far from good.
> https://l10n.mozilla-community.org/~flod/p12n/bug1069123_wikipediassl_aurora/
> 
> Most big locales are OK, all small ones are not.

Understood.
(Assignee)

Comment 20

5 years ago
Note: I'm using this bug to push more changes to Wikipedia.

Desktop: remove searchform, add extra images, switch to SSL
Mobile: switch to SSL, add search activity section

For my own mental sanity I'm also trying to use the same structure of en-US (order of attributes, license header, etc.).

This to explain why you might see a landing even if you already fixed the SSL part.
(Assignee)

Updated

5 years ago
Depends on: 1094772
(Assignee)

Comment 28

5 years ago
Missed one for Tamil (wiktionary)
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ta/rev/207edcd758e8

Polish was fixed in bug 1094772, so we should be good.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1106608
You need to log in before you can comment on or make changes to this bug.