unable to close Image Manager window due to javascript errors

VERIFIED FIXED in mozilla0.9.6

Status

()

VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: bugzilla, Assigned: morse)

Tracking

Trunk
mozilla0.9.6
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
If I open Image Manager I cant close it again by pressing the OK button:

Warning: reference to undefined property
ipermissions[deletedImagePermissions[iperm_count]]
Source File: chrome://communicator/content/wallet/CookieViewer.js
Line: 538

Error: ipermissions[deletedImagePermissions[iperm_count]] has no properties
Source File: chrome://communicator/content/wallet/CookieViewer.js
Line: 538

build 2001102503
(Assignee)

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 106866 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
(Assignee)

Comment 3

18 years ago
Wait a minute.  This can't be a dup of 106886 because that bug has to do with 
password manager and this one has to do with image manager.  The js error 
reported here is for image/cookie manager only (same code) and cannot possible 
occur when running password manager.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Updated

18 years ago
Target Milestone: --- → mozilla0.9.6
(Assignee)

Comment 4

18 years ago
I am unable to reproduce.  Running with today's build on NT.  tever, can you 
reproduce this?

gemal, can you get to this error from a fresh profile?  If so, can you give a 
detailed description of exactly every step that you did to get to the error.
(Reporter)

Comment 5

18 years ago
i just reproduced this in 20011026:

1. right click on a image and say block images.
2. open image manager
3. delete the host you just added
4. click the Ok button and nuthing happens..
(Assignee)

Comment 6

18 years ago
OK, I'm able to reproduce it.  But the conditions for being able to do so are 
not as simple as gemal described.  I believe it is related to having at least 
two entries on the block list and you are attempting to delete the second one.  
In any case, here is a foolproof procedure for reproducing.

1. Start with a fresh profile (assures there is nothing in block-image list
2. Go to http://www.mozilla.org
3. Point to the lizard and do tasks->privacy->images->block
4. Go to http://www.switchboard.com
5. Point to first image on page and do tasks->privacy->images->block
6. Go to image manager (tasks->privacy->images->view
7. Click on the "remove all" button
8. Press OK
(Assignee)

Comment 7

18 years ago
Tracking this down was quite tedious because it appears to be caused by an 
obscure javascript bug.  See bug 107138 that I just filed on that bug.  However, 
now that I understand what is happening, I can easily put in some bulletproofing 
that works around the js bug.  Attaching patch.
(Assignee)

Comment 8

18 years ago
Created attachment 55396 [details] [diff] [review]
use parseInt to avoid the problem in bug 107138
(Assignee)

Comment 9

18 years ago
cc'ing jag and alecf for reviews
(Assignee)

Comment 10

18 years ago
The problem here is the same problem as in bug 106866 but in a different 
module.  The patches for each are similar.

Comment 11

18 years ago
I dont know if I see a dupe of this bug here, but the problem is similar:
Clicking 'OK' in the image manager just does nothing though I don't see an error
message like described.

This is Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5+) Gecko/20011026
(Assignee)

Comment 12

18 years ago
I'm sure it's a dup.  Especially if you tried to do a delete that included the 
second item in the list.

Comment 13

18 years ago
Deleting items is working, closing the manager (including save changes) does not.
This is not depending on whether I try to delete none, the second or any other item.

Is this reproducable at yours or do you need some more information?
(Assignee)

Comment 14

18 years ago
*** Bug 107351 has been marked as a duplicate of this bug. ***

Comment 15

18 years ago
Comment on attachment 55396 [details] [diff] [review]
use parseInt to avoid the problem in bug 107138

cool. This code will be faster too, because we don't have to keep accessing deletedCookies[cookieCount]
Attachment #55396 - Flags: superreview+
Comment on attachment 55396 [details] [diff] [review]
use parseInt to avoid the problem in bug 107138

r=jag
Attachment #55396 - Flags: review+
(Assignee)

Comment 17

18 years ago
fix checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 18

18 years ago
*** Bug 107747 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 19

17 years ago
v 20020222
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.