If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[PDF Viewer] Update pdf.js in Gaia

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: mancas, Assigned: mai)

Tracking

(Blocks: 1 bug)

unspecified
2.1 S9 (21Nov)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.0M fixed, b2g-v2.1 fixed, b2g-v2.2 fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
We need to update the pdf.js version in Gaia to include the changes made in bug 1054643
[Blocking Requested - why for this release]: Blocks a blocker.

Also sorely lacking in an owner...
blocking-b2g: --- → 2.0?

Comment 2

3 years ago
Triage group: Blocking 2.0+ since this blocks a 2.0 blocker
blocking-b2g: 2.0? → 2.0+

Comment 3

3 years ago
(In reply to howie [:howie] from comment #2)
> Triage group: Blocking 2.0+ since this blocks a 2.0 blocker

We have not had movement on this since you last commented on Oct 7th.  This bug is still unassigned.
(Assignee)

Updated

3 years ago
Assignee: nobody → marina.rodrigueziglesias
(Assignee)

Comment 4

3 years ago
Created attachment 8512526 [details] [review]
patch v1.0

Hi yuri,
Update pdf.js to version 1.0.931.
Tested manually and seems works fine.
Regards
Attachment #8512526 - Flags: review?(ydelendik)
Update of the core pdf.js library in the PR looks good. But I don't see anything related to bug 1054643 (or any viewer changes). If the intent only to update rendering functionality, then r+.
Flags: needinfo?(marina.rodriguez.iglesias)
(Assignee)

Comment 6

3 years ago
Hi Yury, 
sorry but when we talked by irc I understood that you only want to update the core funcionality (pdf.js and pdf.worker.js). I've updated the PR to the '1.0.954' version, updating the following files: 
   apps/pdfjs/content/build/pdf.js 
   apps/pdfjs/content/build/pdf.worker.js 
   apps/pdfjs/content/web/viewer.html 
   apps/pdfjs/content/web/viewer.js 

I've tested manually the patch with the browser (http://www.pdf995.com/samples/pdf.pdf) and it seems that it Works fine
Flags: needinfo?(marina.rodriguez.iglesias)

Updated

3 years ago
Attachment #8512526 - Flags: review?(ydelendik) → review+
(Assignee)

Comment 7

3 years ago
Master: f374ffac17f2a0e04ca85f50c216b22bb22cfa81
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Please request Gaia v2.0 and v2.1 approval on this when you get a chance.
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
Flags: needinfo?(marina.rodriguez.iglesias)
Target Milestone: --- → 2.1 S9 (21Nov)
(Assignee)

Comment 9

3 years ago
Comment on attachment 8512526 [details] [review]
patch v1.0

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): feature
[User impact] if declined: outdated version of pdf.js, the patch optimizes the performance and it fixes a few of minor bugs.
[Testing completed]: manually tested
[Risk to taking this patch] (and alternatives if risky): low risk
[String changes made]: No

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.
Flags: needinfo?(marina.rodriguez.iglesias)
Attachment #8512526 - Flags: approval-gaia-v2.1?(release-mgmt)
Attachment #8512526 - Flags: approval-gaia-v2.0?(release-mgmt)

Updated

3 years ago
Attachment #8512526 - Flags: approval-gaia-v2.1?(release-mgmt)
Attachment #8512526 - Flags: approval-gaia-v2.1+
Attachment #8512526 - Flags: approval-gaia-v2.0?(release-mgmt)
Attachment #8512526 - Flags: approval-gaia-v2.0+
Requesting QA to help do some exploratory pdf.js testing to ensure things aren't broken.
Keywords: verifyme
v2.1: https://github.com/mozilla-b2g/gaia/commit/3b815d4c88bf137f1a9a52b8a5373b94a012a7f3
v2.0: https://github.com/mozilla-b2g/gaia/commit/414f2ff5c7d000e151b970df3871f63082e4a300
status-b2g-v2.0: affected → fixed
status-b2g-v2.1: affected → fixed
Reverted for build bustage.

v2.1: https://github.com/mozilla-b2g/gaia/commit/38ff3c64464a326078c2e758f68fb060f9f05265
v2.0: https://github.com/mozilla-b2g/gaia/commit/1ede2666f1e6c1b3fd3b282011caf0cbc59544b0

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=36628&repo=mozilla-b2g34_v2_1
status-b2g-v2.0: fixed → affected
status-b2g-v2.1: fixed → affected
Flags: needinfo?(marina.rodriguez.iglesias)
Keywords: branch-patch-needed
(Assignee)

Comment 13

3 years ago
Created attachment 8524572 [details] [review]
patch for v2.1

Hi Ryan,
Updated the patch for 2.1, the following resources has been renamed.

Master:
"/shared/elements/gaia-theme/gaia-theme.css" 
"/shared/elements/gaia-icons/gaia-icons.css"
"/shared/elements/gaia-header/dist/gaia-header.js"

v2.1
"/shared/elements/gaia-theme/style.css"
"/shared/elements/gaia-icons/style.css"
"/shared/elements/gaia-header/dist/script.js"

Tested manually.

Yuri, I don't know if you want to review the patch again.

Best regards, 
Mai
Flags: needinfo?(marina.rodriguez.iglesias) → needinfo?(ydelendik)
(Assignee)

Comment 14

3 years ago
Created attachment 8524597 [details] [review]
patch for v2.0 branch

Hi,
I've updated the viewer.html to change the resources that they don't exist on v2.0 branch.
Regards
Attachment #8524597 - Flags: review?(ydelendik)

Comment 15

3 years ago
For the purpose of tracking blocking bugs lists (2.0 and 2.1), please reopen this bug.
Flags: needinfo?(b.mcb)
(In reply to Marina Rodríguez [:mai] from comment #13)
> Yuri, I don't know if you want to review the patch again.

I don't know gaia differences between 2.0, 2.1 and 2.2. It might take me a while to get up to speed. (You are welcome to pass review to somebody else, who knows the subject)
Flags: needinfo?(ydelendik)
(Reporter)

Comment 17

3 years ago
Reopening bug per comment 15
Status: RESOLVED → REOPENED
Flags: needinfo?(b.mcb)
Resolution: FIXED → ---
(Assignee)

Comment 18

3 years ago
Hi Wilson,
would you mind reviewing if it's correct the library replacements for 2.1 and 2.0 branches? (comment 13)

Regards
Flags: needinfo?(wilsonpage)
Yeah the paths in comment 13 look correct.
Flags: needinfo?(wilsonpage)
(In reply to Boaz Dodin from comment #15)
> For the purpose of tracking blocking bugs lists (2.0 and 2.1), please reopen
> this bug.

No, please don't. Bug status tracks landing on master (which this patch did). The status flags track uplifts (and we have numerous bug queries that depend on it which break if that assumption is violated).
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Keywords: branch-patch-needed
Resolution: --- → FIXED
Attachment #8524597 - Flags: review?(ydelendik)
v2.1: https://github.com/mozilla-b2g/gaia/commit/38e17b0219cbc50a4ad6f51101898f89e513a552
v2.0: https://github.com/mozilla-b2g/gaia/commit/856863962362030174bae4e03d59c3ebbc182473
status-b2g-v2.0: affected → fixed
status-b2g-v2.1: affected → fixed
status-b2g-v2.0M: --- → fixed

Comment 22

3 years ago
Hello, QA folks,

Please execute following test cases and exploratory testing to see if there is any regression.
Thanks.

- https://moztrap.mozilla.org/manage/cases/?pagenumber=1&pagesize=20&sortfield=created_on&sortdirection=desc&filter-name=pdf&filter-product=16&filter-productversion=177
Blocks: 1071449

Updated

2 years ago
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM

Comment 23

2 years ago
Hi, Norry,

Can you help assign an engineer to verify this bug?
Please file new bug if you find any issue.

Many thanks!
Flags: needinfo?(fan.luo)
According to comment 22, I run the test case on Flame 2.0 latest build. And I found wontfix bug 825318 according to TCID 6892, and other test cases results are pass. So this bug are verified successfully.

Device: Flame 2.0 build
Build ID               20150527160203
Gaia Revision          5552bf529d3d6775a968942e9afa6c1d4037362c
Gaia Date              2015-05-21 14:42:19
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/d295e80c5cdd
Gecko Version          32.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150527.192635
Firmware Date          Wed May 27 19:26:44 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.0: fixed → verified
Flags: needinfo?(fan.luo)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage+]
You need to log in before you can comment on or make changes to this bug.