[B2G][PDF Viewer]PDF Viewer title is shown as 'blob:...'

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::System
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: yury, Assigned: mancas)

Tracking

unspecified
2.1 S4 (12sep)
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.4 wontfix, b2g-v2.0 verified, b2g-v2.0M verified, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments, 2 obsolete attachments)

(Reporter)

Description

4 years ago
After bug 1009780, For PDF files without title specified, the `blob:...` is shown in the title bar. It will be nice to provide original filename for users as well.
QA Wanted for a screenshot.
Keywords: qawanted
Created attachment 8476303 [details]
2014-08-20-15-15-30.png

This is an irs form. When it's first opened, you can see the name Blob at the top, and then the title populates. However I'm pretty sure that last word in the title is also still blob.
Flags: needinfo?(jmitchell)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Keywords: qawanted
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Josh - Can you provide a blocking triage analysis?
Component: Gaia::PDF Viewer → Gaia::System
Flags: needinfo?(jmitchell)
Keywords: regression
QA-Wanted for Branch-Checks
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Keywords: qawanted
This bug repro's on: Flame 2.1, Flame 2.0, Flame 1.4, Open C 2.1

Actual Results: Blob shows up at the top of a .Pdf when opened.

Repro Rate: 5/5

Environmental Variables:
Device: Flame Master
BuildID: 20140823032956
Gaia: e424c85eda87a40c0fa64d6a779c3fa368bf770b
Gecko: daa84204a11a
Version: 34.0a1 (Master) 
Firmware Version: v123
------------------------------------------------
Environmental Variables:
Device: Flame 2.0
BuildID: 20140823033754
Gaia: 4c8b5ced1966079086d86dec3098ecf340881306
Gecko: b0545e46d08b
Version: 32.0 (2.0) 
Firmware Version: v123
------------------------------------------------
Environmental Variables:
Device: Flame 1.4
BuildID: 20140825062151
Gaia: cf9d74da6653efeb43d9653e81c61aa00e693a67
Gecko: cdcb73d0febc
Version: 30.0 (1.4) 
Firmware Version: v123
------------------------------------------------
Environmental Variables:
Device: Open_C Master
BuildID: 20140823032956
Gaia: e424c85eda87a40c0fa64d6a779c3fa368bf770b
Gecko: daa84204a11a
Version: 34.0a1 (Master) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted
Not a regression based on the branch checks, should fix but not nomming to block on
Flags: needinfo?(jmitchell)
Keywords: regression
Josh - I think this needs to be checked on older 1.4 builds, as I'm surprised this isn't a regression. Additionally, can you fix the QAnalyst-Triage flag here?
Flags: needinfo?(jmitchell)
(In reply to Jason Smith [:jsmith] from comment #7)
> Josh - I think this needs to be checked on older 1.4 builds, as I'm
> surprised this isn't a regression. Additionally, can you fix the
> QAnalyst-Triage flag here?

Jason,
   The earliest 1.4 build we have that produces this bug is the one below. Before that point, we got a message saying that there is not an app to open the .Pdf. And before that, the .pdf opened in the browser right as you tap the link. There was no issue seen at that point.

Environmental Variables:
Device: Flame 1.4
BuildID: 20140814084207
Gaia: 518c6afa28dc3b87e3a7360ee4b751885884d03d
Gecko: 49790dd7dc25
Version: 30.0 (1.4) 
Firmware Version: v123
Regression WITHIN the 1.4 branch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Keywords: regression
Josh - Can you provide a blocking analysis given knowledge of this now being a regression?
Flags: needinfo?(jmitchell)
[Blocking Requested - why for this release]:

based on this being a regression AND a bit of confusing UX I would block on this
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
QA Contact: croesch
QA Contact: jmercado
(Assignee)

Updated

4 years ago
Assignee: nobody → b.mcb
(Assignee)

Comment 12

4 years ago
Created attachment 8478976 [details] [review]
File name is displayed correctly
Attachment #8478976 - Flags: review?(21)
(Reporter)

Comment 13

4 years ago
Comment on attachment 8478976 [details] [review]
File name is displayed correctly

The update touches to much shared with other viewers code. Please submit the change to the upstream repo at https://github.com/mozilla/pdf.js
Attachment #8478976 - Flags: feedback-

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
Request to make sure this is resolved on 2.0 before sep 2 merge as that's the day we are shooting to resolve all 2.0+ bugs.
This issue seems to have been caused by bug 1009780.

B2g-inbound Regression Window

Last working 
Environmental Variables:
Device: Flame Master
BuildID: 20140607193134
Gaia: 5475755df9d5e16a221eb628b963172fc996f95f
Gecko: f64e4b6c3593
Version: 32.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


First Broken 
Environmental Variables:
Device: Flame Master
BuildID: 20140608001934
Gaia: 4099f6dc3ed6388507c4613b2d53183da21b106b
Gecko: a85db90b6e37
Version: 32.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Last working gaia / First broken gecko - Issue does NOT occur
Gaia: 5475755df9d5e16a221eb628b963172fc996f95f
Gecko: a85db90b6e37

First broken gaia / Last working gecko - Issue DOES occur
Gaia: 4099f6dc3ed6388507c4613b2d53183da21b106b
Gecko: f64e4b6c3593


Gaia Pushlog:  https://github.com/mozilla-b2g/gaia/compare/5475755df9d5e16a221eb628b963172fc996f95f...4099f6dc3ed6388507c4613b2d53183da21b106b
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Broken by bug 1009780 ? Aus - I'm not sure if you are needed here or not - there is already an 'assigned to' and a patch in the works so NI you just in case.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(aus)

Comment 17

4 years ago
Looks like everything is under control here. :) I don't have anything to add.
Flags: needinfo?(aus)
Comment on attachment 8478976 [details] [review]
File name is displayed correctly

Manuel, can you do a PR against pdf.js github repository as suggested by Yury ?
https://github.com/mozilla/pdf.js/

We used to update the pdf app by taking the whole repo there and pushing it into Gaia a few times a year. Adding those changes directly into Gaia means they will likely be overwritten as some points.
Attachment #8478976 - Flags: review?(21)
(Assignee)

Comment 19

4 years ago
Created attachment 8482214 [details] [review]
PR in pdf.js repo

Take a look at the commit. Thanks!
Attachment #8478976 - Attachment is obsolete: true
Attachment #8482214 - Flags: review?(21)
Comment on attachment 8482214 [details] [review]
PR in pdf.js repo

I just want to be sure. Does the patch has landed on the upstream repo already ?
(Assignee)

Comment 21

4 years ago
Created attachment 8484033 [details] [review]
PR in pdf.js repo
Attachment #8482214 - Attachment is obsolete: true
Attachment #8482214 - Flags: review?(21)
Attachment #8484033 - Flags: review?(21)
Comment on attachment 8484033 [details] [review]
PR in pdf.js repo

Defering to Yury for this repo now :)

Thanks.
Attachment #8484033 - Flags: review?(21) → review?(ydelendik)
(Assignee)

Comment 23

4 years ago
Hey Yury!

I've taken care of the comments you did in github. Please check it when you want. Thanks
Flags: needinfo?(ydelendik)
(Assignee)

Updated

4 years ago
Whiteboard: [ETA:09/15]
Whiteboard: [ETA:09/15] → [ETA:09/15][systemsfe]
Target Milestone: --- → 2.1 S4 (12sep)
(Reporter)

Comment 24

4 years ago
Comment on attachment 8484033 [details] [review]
PR in pdf.js repo

r+ with the commit message changed
Attachment #8484033 - Flags: review?(ydelendik) → review+
Flags: needinfo?(ydelendik)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
(Assignee)

Comment 25

4 years ago
master: https://github.com/mozilla/pdf.js/commit/74d02c3406d1278cb52153cce6c6bdcc15f6cdf4
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 26

4 years ago
Was it sync'ed with b2g master?
Flags: needinfo?(b.mcb)
(Assignee)

Comment 27

4 years ago
Not yet, how can I do that?
Flags: needinfo?(b.mcb) → needinfo?(ydelendik)
Presumably you need to file an "Update pdf.js in Gaia to version..." bug and mark it as blocking this bug.
status-b2g-v2.2: --- → affected
(Assignee)

Updated

4 years ago
Depends on: 1069157
status-b2g-v1.4: affected → wontfix
status-b2g-v2.2: affected → fixed
Flags: needinfo?(ydelendik)
Whiteboard: [ETA:09/15][systemsfe] → [systemsfe]
While attempting to verify issue discovered that titles in PDF viewer still appear incorrect. For example, a PDF with the file name "sample.pdf" has the title "4bba655f-ac13-48e5-a7..." displayed. "Blob" does not appear anywhere in the PDF titles tested.

Unsure as to whether this is part of this bug, or whether a new bug should be written.

Video of above: http://youtu.be/qfKNjPLuwuE

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141113040205
Gaia: be8b0151d2f9a4c41fc63952128e0b723cd1161d
Gecko: ab137ddd3746
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(ktucker)
status-b2g-v2.0: affected → fixed
status-b2g-v2.0M: --- → fixed
status-b2g-v2.1: affected → fixed
Created attachment 8554485 [details]
Verify video

This problem is verified pass on latest build of Woodduck2.0 and Flame2.0/2.1, due to Bug 1119172, the problem cannot be verified on Flame2.2.
STR:
1.Launch Browser.
2.Link to a webpage with pdf file on it (such as: http://apps.irs.gov/app/picklist/list/formsInstructions.html)
3.Search and select the PDF File to download it.
4.After download completes, tap to open it.
** The name of pdf file is displayed correctly
See attachment: Verify_video.MP4
Reproduce rate 0/10

Woodduck v2.0 build:
Gaia-Rev        8561b6203888dcf10a0d4a75e81b0d0dd3618875
Gecko-Rev       8596d18e9b5f8ea4fadd952694e2739124a636f9
Build-ID        20150126050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1422219945
FW-Date         Mon Jan 26 05:06:10 CST 2015

Flame v2.0 build:
Gaia-Rev        2989f2b2bd12fcc0e9c017d2db766e76a55873b8
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/ffb9925dd084
Build-ID        20150125000204
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150125.033105
FW-Date         Sun Jan 25 03:31:16 EST 2015
Bootloader      L1TC000118D0

Flame v2.1 build:
Gaia-Rev        54d92cc0755e5102223276ab23063b5eee74b514
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/522d6c980917
Build-ID        20150125001312
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150125.035903
FW-Date         Sun Jan 25 03:59:13 EST 2015
Bootloader      L1TC000118D0

Flame v2.2 build:
Gaia-Rev        0518f4581a0925c0b703d730ef289ab15cbd1216
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c6aa604a7967
Build-ID        20150125002503
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150125.035924
FW-Date         Sun Jan 25 03:59:36 EST 2015
Bootloader      L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage+][lead-review+][MGSEI-Triage+]
status-b2g-v2.0: fixed → verified
status-b2g-v2.0M: fixed → verified
status-b2g-v2.1: fixed → verified
Keywords: regression
Created attachment 8611621 [details]
Verify_Pass_Flame2.2.MP4

This Problem is verified pass on latest build of Flame 2.2 by STR in comment 30.
Actual result: The "blob:..." doesn't shown in the PDF Viewer title bar. the original filename is normally displayed.
See attachment: Verify_Pass_Flame2.2.MP4
Rate: 0/10

Device: Flame 2.2 (Pass)
Build ID               20150527002504
Gaia Revision          8084264c4d1e28bc33220bc7443c7425bb76dbcc
Gaia Date              2015-05-27 03:47:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/19fcc06fb7ab
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150527.040521
Firmware Date          Wed May 27 04:05:32 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.