White screen flickers observed during Suspend/resume of video playback.

RESOLVED DUPLICATE of bug 1072013

Status

()

Core
Layout
--
major
RESOLVED DUPLICATE of bug 1072013
4 years ago
4 years ago

People

(Reporter: Pooja, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [caf priority: p2][CR 726551])

(Reporter)

Description

4 years ago
STR:

1. Open Video app
2. Play a video
3. Suspend device using proper button and resume it back

Actual behavior:
  As soon as app opened we see a white screen flicker

Expected Behavior:
 Switching back to video app should be smooth
(Reporter)

Comment 1

4 years ago
[Blocking Requested - why for this release]:
Blocks: 1025317
blocking-b2g: --- → 2.1?
(Reporter)

Comment 2

4 years ago
Device and build Details:
Device msm8x26 QRD KK branch

Gaia : 944e5b4582c4efa1b67cd33245dbb8f6aa25d09f
Gecko: a50444fdaa68fefefc3ecc08d97530e13a4742ab
OS Version: 2.1.0
Platform Version : 34.0a2
Build ID: 20140915184008
QA Wanted to test on Flame KK 2.1
Keywords: qawanted
QA Contact: aalldredge
I am attempting to reproduce this issue and I have a few questions.
When you say "Suspend device using proper button and resume it back" in step 3 do you mean to lock the device using the top button and then unlock it? Or to close the video app and relaunch it?
I have only seen a white screen appear when I lock the device but in your actual behaviour  it says that you should see it when the app is opened. Did you see the white screen when locking the device or returning to the video app?
Flags: needinfo?(poojas)

Updated

4 years ago
Whiteboard: [CR 726551] → [caf priority: p2][CR 726551]
(Reporter)

Comment 5

4 years ago
(In reply to Adam Alldredge [:AdamA] from comment #4)

> When you say "Suspend device using proper button and resume it back" in step
> 3 do you mean to lock the device using the top button and then unlock it? Or
> to close the video app and relaunch it?

Thanks for pointing mistake. Its "Power button". you got it right. Lock and unlock device using Power button

> I have only seen a white screen appear when I lock the device but in your
> actual behaviour  it says that you should see it when the app is opened. Did
> you see the white screen when locking the device or returning to the video
> app?

I see flicker when i unlock device.
As Video app was opened when we locked the device.
SO when we unlock it, firstly it shows a white flicker and then the video app (which was opened in background).

Kindly let me know If still steps are not clear. If so  i will upload a video for same
Flags: needinfo?(poojas)
Pooja and Adam,

What devices are you seeing the white flicker on, and how much memory do they have? Does the bug occur on devices that have more memory?

Adam: does the same bug occur in 2.0?

The video app has code to release the video hardware when it is hidden and to re-acquire it when it becomes visible again. But the same code should be running when we lock and unlock the phone as when we go to the homescreen and return to the app. So if they bug is only happening in one of those cases, I'm guessing that it is not directly caused by the Video app.

So I'd expect that this might have something to do with the fact that when we lock the phone it actually sleeps and has to do more work when waking up.  Or, if this bug is related to low-memory, then maybe locking the phone uses more memory because it has to launch the lockscreen app or something.

A video would be great, but probably not necessary if this is easy to reproduce on a Flame.

If the root cause is hardware or memory related, then I doubt we can do much about this as a Gaia bug other than try to add a CSS transition or something to try to hide or disguise the flicker.

Or possibly there is a gecko issue here that the media or graphics teams could help us with.
I was able to reproduce this issue 2.1 KK Flame. With the lock screen turned off white screen appears when unlocking the phone 9/10 times. With the lock screen turned on the white screen will appear when locking the phone 1/5 times.

Environmental Variables:
Device: Flame 2.1
BuildID: 20140919105218
Gaia: d558bd001edee9defa017bd67551d43878077932
Gecko: 0d23cb46b0f3
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

(In reply to  David Flanagan [:djf] from comment #6)

I am seeing the white screen appear on Flame devices in 512mb, 319mb, and 273mb. I was unable to reproduce this issue at all in Flame 2.0.

Environmental Variables:
Device: Flame 2.0
BuildID: 20140919041249
Gaia: 31434a3949556171f3565ca47ac2b44e810e95e6
Gecko: fb1589259e4f
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0.

This issue is very easy to reproduce with lock screen turned off, but if you would like a video let me know.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
Flags: needinfo?(jmitchell)
Flags: needinfo?(dflanagan)
Keywords: qawanted
I'm a little uncertain this merits blocking on
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Keywords: regression
I don't see the bug on my JB flame running gaia master.  If this is a KK vs JB bug, then it is not a Gaia issue. Milan: is there someone on your team who could investigate this?
Flags: needinfo?(dflanagan) → needinfo?(milan)
Let's get the video, just so that we all know what this looks like and can discuss blocking status.  Also, David hasn't been able to reproduce it on JB, not sure anybody else tried, and QA is now only testing on KK, and I'm not sure how much of a useful information it would be knowing whether it's a problem on JB as well?
Hema, how should we sort this out?
Flags: needinfo?(milan) → needinfo?(hkoka)

Comment 11

4 years ago
Based on comment 7 it looks like this is easily reproducible on 2.1 KK Flame build when lockscreen is turned off and with varied memory configs. And this is not an issue with 2.0 (v180 base image KK) or JB with master based on previous comments from QA and David. So perhaps this is 2.1 specific and not related to KK/JB differences.

Adam says he can provide a video (NI'ing him)

Milan, Once Adam attaches the video, could Sotaro or someone from your team help investigate if it is gecko/graphics issue?
Flags: needinfo?(milan)
Flags: needinfo?(hkoka)
Flags: needinfo?(aalldredge)

Updated

4 years ago
blocking-b2g: 2.1? → 2.1+
Video uploaded at location: http://youtu.be/ZWFpt1WA6ls

Environmental Variables for uploaded video:
Device: Flame 2.1
BuildID: 20140922091042
Gaia: 2c5f245929d40ee7b0227ef39e47a0220171d17b
Gecko: 093f0bc90451
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

This is issue is also occurring on 2.2 Flame Master.

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140922040649
Gaia: 3802009e1ab6c3ddfc3eb15522e3140a96b33336
Gecko: 5e704397529b
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
status-b2g-v2.2: --- → affected
Flags: needinfo?(aalldredge) → needinfo?(hkoka)
(In reply to Hema Koka [:hema] from comment #11)
> ...
> Milan, Once Adam attaches the video, could Sotaro or someone from your team
> help investigate if it is gecko/graphics issue?

Graphics guilty until proven otherwise. Sure, we can take a look, but I don't know how quickly Sotaro can get to this.
Assignee: nobody → sotaro.ikeda.g
Flags: needinfo?(milan)
Let's get a regression window for this.
Keywords: regressionwindow-wanted
We have another bug 1071437 similar to this bug reported for videos played in gallery app. Gaia code handling video player in gallery (shared/js/media/video_player.js) and video app (apps/video/js/video.js) is different. This appears to be an underlying gecko/graphics issue seen in apps playing videos.

Error seen in logs for Gallery and Video app: 

09-23 08:32:06.320 V/GonkBufferQueue( 4409): cancelBuffer: slot=0
09-23 08:32:06.320 V/GonkBufferQueue( 4409): dequeueBuffer: w=1280 h=720 fmt=0x7fa30c04 usage=0x42002100
09-23 08:32:06.320 V/GonkBufferQueue( 4409): dequeueBuffer: returning slot=0 buf=0xaeefc600 flags=0
09-23 08:32:06.330 D/charger_monitor(  502): AICL: start
09-23 08:32:06.340 E/OMX-VDEC-1080P(  284): Error: Insufficient size allocated for extra-data
(In reply to Punam Dahiya from comment #15)
> 
> 09-23 08:32:06.320 V/GonkBufferQueue( 4409): cancelBuffer: slot=0
> 09-23 08:32:06.320 V/GonkBufferQueue( 4409): dequeueBuffer: w=1280 h=720
> fmt=0x7fa30c04 usage=0x42002100
> 09-23 08:32:06.320 V/GonkBufferQueue( 4409): dequeueBuffer: returning slot=0
> buf=0xaeefc600 flags=0
> 09-23 08:32:06.330 D/charger_monitor(  502): AICL: start
> 09-23 08:32:06.340 E/OMX-VDEC-1080P(  284): Error: Insufficient size
> allocated for extra-data

The above log is not related to this bug.
I do not think this is a problem of graphics. It seems that display becomes ON before application rendering is completed. Therefore this could be a problem of layout or display on/off control.
I saw the while flash by the following STR. From it, I suspect it is a layout regression.
- [1] Store some videos in SD card.
- [2] Start video app and wait thumbnail generations complete.
- [3] Kill the video app.
- [4] Start video app again.

Continue [3]-[4] until the white flash appear on the screen.
From the symptom, it seems that white color is drawn instead of background color by layout.
Assignee: sotaro.ikeda.g → nobody
Component: Gaia::Video → Layout
Product: Firefox OS → Core
B2G-Inbound regression window.

Last working:
Device: Flame 2.1
BuildID: 20140829113200
Gaia: 4419091ae760328a52606920e335331a16fcb448
Gecko: 3748d4065959
Version: 34.0a1 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken:
Device: Flame 2.1
BuildID: 20140829120201
Gaia: db6ed35ac354a3eeb5a4bd3c8339bca28f8eb7e6
Gecko: e75d48b3dc6d
Version: 34.0a1 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Last working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 4419091ae760328a52606920e335331a16fcb448
Gecko: e75d48b3dc6d

First Broken Gaia Last working Gecko: Issue DOES reproduce
Gaia: db6ed35ac354a3eeb5a4bd3c8339bca28f8eb7e6
Gecko: 3748d4065959

Pushlog:
https://github.com/mozilla-b2g/gaia/compare/4419091ae760328a52606920e335331a16fcb448...db6ed35ac354a3eeb5a4bd3c8339bca28f8eb7e6

Caused by Bug 1054105
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
(In reply to Sotaro Ikeda [:sotaro] from comment #19)
> From the symptom, it seems that white color is drawn instead of background
> color by layout.

This seems caused by bug 1054105 - "- background-color: #0E1214;"

I would normally NI the patch author to investigate but you seem to already be investigating.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(sotaro.ikeda.g)

Updated

4 years ago
Flags: needinfo?(hkoka) → needinfo?(hub)
Flags: needinfo?(sotaro.ikeda.g)
Looking into it.

Updated

4 years ago
Flags: needinfo?(hub)
Can't reproduce on KK / master.

Will try on 2.1...
Dupe.

Yes the problem is caused by bug 1054105. bug 1072013 has a patch.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1072013

Updated

4 years ago
No longer blocks: 1025317
You need to log in before you can comment on or make changes to this bug.