Usage first time use: pages are not exclusively visible.

RESOLVED FIXED

Status

Firefox OS
Gaia::Cost Control
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: yzen, Assigned: eeejay)

Tracking

(Blocks: 1 bug, {access})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [b2ga11y p=1][NaBfT])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Steps to reproduce (with screen reader):
* Open Usage app (for the first time)
* Focus the screen reader on the next button on the first page.
* Double tap to activate
** Expected the page transitions to the next one
* Swipe back
** Expected: from the topmost element on the current screen the screen reader focus should jump into a status bar (since there's nothing else there)
** Observed: screen reader focus jumps on the controls from the previous page that are underneath the current one.

All first time use pages should be exclusively visible with the current one being the only one visible/accessible to the screen reader.
(Reporter)

Updated

4 years ago
Blocks: 1069414
(Assignee)

Comment 1

3 years ago
Created attachment 8512094 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25550
Attachment #8512094 - Flags: review?(21)
Whiteboard: [b2ga11y p=1] → [b2ga11y p=1][NaBfT]
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1069414
(Assignee)

Comment 3

3 years ago
Comment on attachment 8512094 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25550

Changing reviewer since it looks like 21 is gone for a while.
Attachment #8512094 - Flags: review?(21) → review?(salva)
(Assignee)

Updated

3 years ago
Assignee: nobody → eitan
Status: NEW → ASSIGNED
Comment on attachment 8512094 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25550

Nice catch. Thank you.
Attachment #8512094 - Flags: review?(salva) → review+
(Assignee)

Comment 5

3 years ago
https://github.com/mozilla-b2g/gaia/commit/4ff75ab9fd44440545dcb80789260176dc91e37d
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.