Buttons of "B I U" on composer toolbar do not change when clicked on...

VERIFIED DUPLICATE of bug 101982

Status

SeaMonkey
Composer
--
critical
VERIFIED DUPLICATE of bug 101982
17 years ago
14 years ago

People

(Reporter: Patty Mac, Assigned: Charles Manske)

Tracking

({regression})

Trunk
mozilla0.9.7
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE [QAHP])

(Reporter)

Description

17 years ago
Seen on all platforms (trunk build: 2001-10-26-06-trunk).

1. Launch the above build.
2. Open composer.
3. Click on composer toolbar like " B I U".
Notice the buttons don't press when clicked on. It occurs in both modern and 
classic themes. Therefore, it's a bug in composer only.
(Reporter)

Updated

17 years ago
Component: Sidebar → Compositor

Comment 1

17 years ago
--> charley
Assignee: sgehani → cmanske
Component: Compositor → Editor: Composer
(Assignee)

Comment 2

17 years ago
What do you mean by "don't press"? they don't look different when you click down?

Comment 3

17 years ago
confirming that this happens in both modern and classic..

Charley, the buttons don't change when clicked on...

Comment 4

17 years ago
I am seeing this on Win 2k using today's trunk build (2001102603).  I am also 
seeing the same problem with the other buttons on the toolbar (i.e. lists and 
text justification). By "don't press" I think she means that the buttons don't 
stay depressed, so there is no indication that the attribute is being applied.
(Reporter)

Comment 5

17 years ago
change the summary to be more appropriate.
Summary: Buttons of "B I U" on composer toolbar do not press when clicked → Buttons of "B I U" on composer toolbar do not change when clicked on...

Comment 6

17 years ago
dup of bug 106733?
(Assignee)

Comment 7

17 years ago
I'm rebuilding with yesterday's changes, but my build recent as of last night
doesn't show this and I think my fix to bug 106733 fixes this.
Status: NEW → ASSIGNED
Whiteboard: EDITORBASE
Target Milestone: --- → mozilla0.9.6
(Assignee)

Comment 8

17 years ago
Today's build is finished and does not show this problem, so it's the same cause
 as bug 107633

*** This bug has been marked as a duplicate of 106733 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 9

17 years ago
Umm, last comment should say: bug 106733

Comment 10

17 years ago
verified.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 11

17 years ago
Oops, this really wasn't a dup. Showing attributes / command state system is 
really falling apart!
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Updated

17 years ago
Whiteboard: EDITORBASE → EDITORBASE [QAHP]
(Assignee)

Comment 12

17 years ago
What is going on! Toolbar command updating is falling apart.
Anyone changing code in this area? Joe?
Status: REOPENED → ASSIGNED

Comment 13

17 years ago
I looked into this.  First I checked the state gathering code in HTMLEditor lib.
 I stepped through it; it is working.  Then I checked the command state
maintainence code in Composer lib.  I stepped through it; it is working.  This
is a drawing problem or a xul problem.
(Assignee)

Comment 14

17 years ago
Jfrancis: Thanks for helping.
Hewitt: Know of any changes recently that might have upset toolbar button code?
Severity: normal → critical
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.6 → mozilla0.9.7
(Assignee)

Comment 15

17 years ago
Next round.

Updated

17 years ago
Keywords: regression
(Assignee)

Comment 16

17 years ago
Bug 101982 has better explanation of underlying problem with "observes" nodes.

*** This bug has been marked as a duplicate of 101982 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 17

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.