Recipient autocomplete: "wrong" matches, i.e. unexpected prioritization/order of results

RESOLVED DUPLICATE of bug 970456

Status

Thunderbird
Address Book
P1
normal
RESOLVED DUPLICATE of bug 970456
4 years ago
4 years ago

People

(Reporter: slight, Unassigned)

Tracking

31 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140917194002

Steps to reproduce:

typing a letter, e.g. "L" for "Louis Miller" ...


Actual results:

... the autocomplete shows the result "Udo Miller" 
 (typing "Lo", the autocomplete shows "Max Oister")


Expected results:

the address "Louis Miller" = l.miller@ ... should match as first result
(Reporter)

Updated

4 years ago
Depends on: 970456, 1068570
Priority: -- → P1

Comment 1

4 years ago
You didn't write the address, so I don't know why Max Oister match in the first place, but I assume "lo" is somewhere in the address then.

But for the rest, this is dupe of bug 970456.
slight, thanks for reporting. We have already fixed this issue of unexpected result sorting, and we are trying to release the fix asap (currently fixed only on non-release versions of TB). It's not easy to get the sorting right, sorry 4 the inconvenience!

In the meantime, try using other cool search strategies...
e.g. typing "lo mi" might suffice to return "Louis Miller" as a unique match...
Also try setting value in Nickname field of contact properties, e.g. "lm#". Then, just typing "lm#" should also reliably return that contact only.
Pls report back if these tips are helpful :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 970456
No longer depends on: 1068570, 970456
See Also: → bug 1068570
Summary: adress book autocomplete: wrong matches → Recipient autocomplete: "wrong" matches, i.e. unexpected prioritization/order of results
You need to log in before you can comment on or make changes to this bug.