Solaris: XOR selection highlight not working

VERIFIED FIXED

Status

()

Core
Event Handling
P2
major
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: sujay, Assigned: Chris McAfee)

Tracking

({pp})

Trunk
Sun
BSDI
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
using 7/28 build on linux build

1) launch apprunner and editor
2) using mouse, highlight some text.

The text doesn't get highlighted giving visible indication that it is
selected....this is a regression...

linux only.

Updated

19 years ago
Assignee: buster → akkana
Severity: normal → major
Priority: P3 → P2
Summary: [PP]selection highlight not working → [PP]selection highlight not working

Comment 1

19 years ago
akkana, can you do two things please:
1) verify that this is still a bug on linux
2) if so, set a break in nsTextEditorFocusListener::Focus(nsIDOMEvent*
aEvent)and validate that it gets called as a result of the mouse click in the
editor content area.  If it does not, please reassign this bug to either joki or
whoever is platform champion for events on linux.  If the method does get
called, but selection is not visible, please reassign to me.  Thanks.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 2

19 years ago
I don't see this on my linux build from today (8/2).  I can drag the mouse in
the editor window (without doing anything else first) and the highlighting shows
up, in both html and plaintext editors.

Marking worksforme -- Sujay, would you try with today's build and if you still
see it, I'll come over and watch what you're doing.
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 3

19 years ago
re-opening bug..apparently its a Solaris issue...

Updated

19 years ago
Hardware: Other → Sun
Resolution: WORKSFORME → ---

Comment 4

19 years ago
Setting platform to Sun. Clearing WorksForMe resolution since this bug has been
reopened.

Updated

19 years ago
Assignee: akkana → ramiro
Status: REOPENED → NEW
Summary: [PP]selection highlight not working → [PP] Solaris: XOR selection highlight not working

Comment 5

19 years ago
Chris, Ramiro, who's our Sun contact for Sun-specific gfx bugs?  Apparently the
gfx XOR mode isn't working when displaying to a Solaris display, and I'm not
sure who should own this bug.

Updated

19 years ago
Assignee: ramiro → mcafee

Comment 6

19 years ago
Reassigning to mcafee, cause i dont have a sun box to test.
(Assignee)

Updated

19 years ago
Target Milestone: M1
(Assignee)

Updated

19 years ago
Target Milestone: M1 → M12
(Assignee)

Updated

19 years ago
Component: Editor → Event Handling
Depends on: 13916
OS: Linux → BSDI
(Assignee)

Updated

19 years ago
Depends on: 13160
No longer depends on: 13916
(Assignee)

Comment 7

18 years ago
Yes, I see this on solaris now.

Updated

18 years ago
Target Milestone: M12 → M13

Comment 8

18 years ago
Not really critical for dogfood.  Move to M13.

Updated

18 years ago
Target Milestone: M13 → M14

Comment 9

18 years ago
How hard is this gonna be to fix?

Comment 10

18 years ago
It appears that Mozilla doesn't support highlighting on 8 bit displays. I have
the same problem on some of the Linux boxes here.

Build ID: 2000021508 Linux

Updated

18 years ago
Keywords: pp
(Assignee)

Comment 11

18 years ago
m15
Target Milestone: M14 → M15

Updated

18 years ago
Summary: [PP] Solaris: XOR selection highlight not working → Solaris: XOR selection highlight not working

Comment 12

18 years ago
Move to M16 for now ...
Target Milestone: M15 → M16

Comment 13

18 years ago
I think this may have been fixed becuase the Linux boxes here which were showing
this 8-bit problem can highlight fine now...
Build id: 2000050208 Linux

Updated

18 years ago
Target Milestone: M16 → M18

Comment 14

18 years ago
Move to M21 target milestone.
Target Milestone: M18 → M21
(Assignee)

Comment 15

18 years ago
pavlov says he's mostly fixed this w/ mjudge.

A small problem remains, but he (pavlov) has a bug

assigned to him about that.



This is workingforme tonight, linux displaying to solaris 2.6/8bit.

Status: NEW → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 16

18 years ago
verified in 6/12 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.