Closed Bug 1069908 Opened 7 years ago Closed 7 years ago

Better handling of failures in the log parser

Categories

(Tree Management :: Treeherder, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mdoglio, Assigned: mdoglio)

References

Details

To better handle failures in the log parser, we should either 
1- increase the number of automatic retries (currently set to 3) and set an increasing delay between each retry 
or 
2- let the user manually retry it.
Blocks: 1068534
No longer blocks: 1068534
Duplicate of this bug: 1068534
Since this contributed to bug 1068534, making this a blocker.
Priority: -- → P2
Assignee: nobody → mdoglio
I'll implement the first solution as it doesn't require manual intervention and it will probably solve 99% of the cases if not all of them.
Status: NEW → ASSIGNED
Priority: P2 → P1
attachment 8493713 [details] [review] on bug 1063923 fixes this bug as well
Commits pushed to master at https://github.com/mozilla/treeherder-service

https://github.com/mozilla/treeherder-service/commit/84a0d2c0f25c163eb807a249b45d78bc3e256213
Bug 1069908,1063923 - increase number of automatic log parser retries

and properly change log parsing status to failed when needed

https://github.com/mozilla/treeherder-service/commit/fb7aeb1aced6ccd7d391170afdf7c9e2fe6dcedd
Merge pull request #226 from mozilla/bug-1069908-increase-log-parser-retries

Bug 1069908,1063923 - increase number of automatic log parser retries
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.