[e10s] Right click menu not showing up for links in Zimbra email messages

RESOLVED FIXED in Firefox 36

Status

()

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: directxman12, Assigned: enndeakin)

Tracking

35 Branch
Firefox 36
x86_64
Linux
Points:
3
Dependency tree / graph

Firefox Tracking Flags

(e10sm4+)

Details

Attachments

(2 attachments)

Reporter

Description

5 years ago
Normally, right-clicking on a link in a email message in the Zimbra webmail client shows the normal browser link right-click context menu.  However, right-clicking on links in Zimbra in an e10s tab does nothing.

I experience this behavior both in two different versions of Zimbra (one of which is the Comcast xfinity webmail client).

Functionality returns to normal if I open Zimbra in a non-e10s window instead.

I'm on Firefox Nightly 35.0a1 (2014-09-19)
Also seeing this on the Xfinity Zimbrea client
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → enndeakin
Assignee

Comment 2

5 years ago
Posted file Testcase
This is because the page is calling stopPropagation. Here is a testcase.
Assignee

Comment 3

5 years ago
This should use a system event listener instead.
Attachment #8506083 - Flags: review?(mconley)
Assignee

Updated

5 years ago
Points: --- → 3
Comment on attachment 8506083 [details] [diff] [review]
stopcontextmenu

Review of attachment 8506083 [details] [diff] [review]:
-----------------------------------------------------------------

TIL about nsIEventListenerService. Thanks Enn!
Attachment #8506083 - Flags: review?(mconley) → review+
This failure was actually from bug 1084367, as far as I can tell from retriggers.
Assignee

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/b81fb178319b
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
QA Whiteboard: [good first verify][testcase available][verify in NIghtly only]
You need to log in before you can comment on or make changes to this bug.