Closed Bug 1060070 (e10s-contextmenu) Opened 5 years ago Closed 5 years ago

[meta] e10s - busted context menus

Categories

(Firefox :: Menus, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
e10s - ---

People

(Reporter: mconley, Unassigned)

References

Details

(Keywords: meta)

Meta bug for a variety of context menu issues that have come up recently.
tracking-e10s: --- → +
Depends on: 1058787
Depends on: 1058788
Depends on: 1058883
Depends on: 1058712
Depends on: 1058717
Depends on: 1058539
Depends on: 1058708
Many of these bugs will be because commands aren't being updated properly, likely because they're using the child process UpdateCommands rather than the parent. I filed 1060529 on this issue.
Depends on: 1063787
Move old M2's low-priority bugs to M6 milestone.
Depends on: 1068736
Alias: e10s-contextmenu
I think 1058787, 1058883, 1058539, and 1068736 and possibly others may be caused by the spellchecking error, bug 1071771, of which a workaround is now checked in. I can reproduce some of them before that patch, and not after, and the remainder I cannot reproduce at all.
(In reply to Neil Deakin from comment #3)
> I think 1058787, 1058883, 1058539, and 1068736 and possibly others may be
> caused by the spellchecking error, bug 1071771, of which a workaround is now
> checked in. I can reproduce some of them before that patch, and not after,
> and the remainder I cannot reproduce at all.

Can we close bug 1071771? Its currently marked leave-open.
We can, but we should then file another bug about fixing it properly.
Depends on: 1097208
Depends on: 1099072
Flags: firefox-backlog+
No dependencies, so closing.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.