[Contacts] [ICE] Deleting ICE Contact 1 makes ICE Contact 2 to promote to position 1

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Jose Manuel Cantera, Assigned: Jose Manuel Cantera)

Tracking

unspecified
2.1 S5 (26sep)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
STR:

Set ICE Contact 1 and ICE Contact 2

Remove ICE Contact 2.

Go to Settings / ICE Contacts. ICE Contact 2 now appears in position 1
(Assignee)

Comment 1

3 years ago
Carrie,

I think this is not the intended behaviour. I mean, ICE Contact 2 should remain in position 2 and not "promote" to position 1.

Please confirm

thanks
Flags: needinfo?(cawang)
Hi Jose, 

Yes, the expected behavior is remaining ICE 2 in position 2. Looks like it's a bug here. Thanks!
Flags: needinfo?(cawang)
(Assignee)

Comment 3

3 years ago
Created attachment 8493675 [details]
24330.html
Attachment #8493675 - Flags: review?(francisco)
(Assignee)

Updated

3 years ago
Target Milestone: --- → 2.1 S5 (26sep)
QA Whiteboard: [ICE]
Comment on attachment 8493675 [details]
24330.html

Let's keep the code based on promises, instead of callbacks passing. That will increase readability and will prevent us for having to check for callback existence and type.

Apart from that, the code for manipulating the data state is perfect.
Attachment #8493675 - Flags: review?(francisco) → review-
(Assignee)

Updated

3 years ago
Attachment #8493675 - Flags: review- → review?(francisco)
Comment on attachment 8493675 [details]
24330.html

Great patch here!
Attachment #8493675 - Flags: review?(francisco) → review+
(Assignee)

Comment 6

3 years ago
landed in master:

https://github.com/mozilla-b2g/gaia/commit/84c9fcb8c846203ede478c05886ef9fff9384f79
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Blocks: 1071632
Comment on attachment 8493675 [details]
24330.html

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: it is confusing when you set a contact as two and it is converted to first ICE contact
[Testing completed]: added unit test and manually by developer
[Risk to taking this patch] (and alternatives if risky): close to null
[String changes made]: no
Attachment #8493675 - Flags: approval-gaia-v2.1?
Tested and working
Flame
Eng
Gecko-a310d15
Gaia-931d547

Pending 2.1
Attachment #8493675 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Needs rebasing for v2.1 uplift.
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
Flags: needinfo?(jmcf)
Keywords: branch-patch-needed
(Assignee)

Comment 10

3 years ago
landed in v2.1

https://github.com/mozilla-b2g/gaia/commit/997e37faa5433c8ab8e4e5a33f518890d0900682
Flags: needinfo?(jmcf)
(Assignee)

Updated

3 years ago
Keywords: verifyme
status-b2g-v2.1: affected → fixed
Keywords: branch-patch-needed
Tested and working
2.1
Flame
User
Platform versin: 34.0a2
Build ID: 20141002015226
Git commit: c1cc61e3

Updated

3 years ago
Status: RESOLVED → VERIFIED
No longer blocks: 1071632

Comment 12

3 years ago
Issue is verified fixed on flame 2.2 and flame 2.1

When removing the second ICE contact, that contact does not move up to ICE contact 1.

Flame 2.2
Environmental Variables:
Device: Flame 2.2
Build ID: 20141125040209
Gaia: 824a61cccec4c69be9a86ad5cb629a1f61fa142f
Gecko: acde07cb4e4d
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.1

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141125001201
Gaia: 1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
Gecko: db893274d9a6
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [ICE] → [ICE] [QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [ICE] [QAnalyst-Triage?] → [ICE] [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.