[Contacts] [ICE] ICE Group is not properly refreshed after removing all phone numbers of an ICE Contact

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Jose Manuel Cantera, Assigned: crdlc)

Tracking

(Depends on: 1 bug)

unspecified
2.1 S5 (26sep)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
STR: 

Set ICE Contact 1 and ICE Contact 2. 

Go to the Contact List. Open the ICE Contacts Group. Edit one of the ICE contacts.
Remove all telephone numbers of the edited contact. A popup informs the user that the contact will be unset as ICE Contact. Once the popup is dismissed, the user returns to the ICE Group List.

Actual:

In the ICE Group list are appearing two contacts.

Expected:

Only one contact should appear, as the other has stopped being an ICE Contact. 

User impact is relatively high as it sees inconsistent information on screen.
Is this bug happening in 2.1 branch?
Flags: needinfo?(jmcf)
QA Whiteboard: [ICE]
(Reporter)

Comment 2

3 years ago
(In reply to Maria Angeles Oteo (:oteo) from comment #1)
> Is this bug happening in 2.1 branch?

yes, indeed
Flags: needinfo?(jmcf)
(Reporter)

Updated

3 years ago
Assignee: jmcf → crdlc
status-b2g-v2.1: --- → affected
[Blocking Requested - why for this release]: As Jose Manuel said, this is a bug with a high user impact. Furthermore, this is a basic use case covered by the specs (attachment 8459474 [details], page 15).
blocking-b2g: --- → 2.1?
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1061420
(Assignee)

Comment 5

3 years ago
This issue is reproducible once landed bug 1061420. That bug removed the ICE contact but the ICE list was not refreshed properly the first time

(In reply to Wesley Huang [:wesley_huang] from comment #4)
> 
> *** This bug has been marked as a duplicate of bug 1061420 ***
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 6

3 years ago
Created attachment 8495072 [details]
Github pull request
Attachment #8495072 - Flags: review?(jmcf)
(Reporter)

Comment 7

3 years ago
Comment on attachment 8495072 [details]
Github pull request

very nice work

thanks!
Attachment #8495072 - Flags: review?(jmcf) → review+
(Assignee)

Comment 8

3 years ago
Merged in master:

https://github.com/mozilla-b2g/gaia/commit/7d56bbb04476e464786538b91ac1db82b02222e3
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

3 years ago
Comment on attachment 8495072 [details]
Github pull request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: https://bugzilla.mozilla.org/show_bug.cgi?id=1071632#c3
[Testing completed]: by peer and added a new integration test
[Risk to taking this patch] (and alternatives if risky): close to null
[String changes made]: No
Attachment #8495072 - Flags: approval-gaia-v2.1?

Updated

3 years ago
blocking-b2g: 2.1? → 2.1+

Updated

3 years ago
Attachment #8495072 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Tested and working
2.2
Flame
User 
Gecko-f24dab7
Gaia-ec272b4

Pengin 2.1
Needs rebasing for v2.1 uplift.
status-b2g-v2.2: --- → fixed
Flags: needinfo?(crdlc)
Keywords: branch-patch-needed
(Assignee)

Comment 12

3 years ago
It depends on bug 1069974, maybe we should ask for uplifting this one
Depends on: 1069974
Flags: needinfo?(crdlc)
v2.1: https://github.com/mozilla-b2g/gaia/commit/b327c640fea887770d011a127e349838b3b44724
status-b2g-v2.1: affected → fixed
Keywords: branch-patch-needed
Tested and working
2.1
Flame
User
Platform versin: 34.0a2
Build ID: 20141002015226
Git commit: c1cc61e3
Status: RESOLVED → VERIFIED
This issue is verified fixed for the latest 2.2 Flame build:

Environmental Variables:
------------------------
Device: Flame 2.2 Master
BuildID: 20141012040203
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

When the user deletes all numbers of an ICE contact a menu is brought to the user's attention that all numbers have been removed and the contact is no longer an ICE contact.

-

This issue is NOT verified fixed for the latest 2.1 Flame build:

Environmental Variables:
------------------------
Device: Flame 2.1
BuildID: 20141012001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180

When the user deletes all numbers of an ICE contact that contact will still remain set as an ICE contact.
status-b2g-v2.1: fixed → affected
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
Whiteboard: [failed-verification]
Depends on: 1081696
No longer depends on: 1069974
QA Whiteboard: [ICE] → [ICE][failed-verification] [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Whiteboard: [failed-verification]
Flags: needinfo?(crdlc)
(Assignee)

Comment 16

3 years ago
Per comment 14 this is a regression for some uplift thought because of Loli verified this when was uplifted
Flags: needinfo?(crdlc)
(Assignee)

Comment 17

3 years ago
This is working fine for me. This patch fixed the ICE contact list (nothing related to dialogs). When you remove all phones for an ICE contact and go back to ICE contact list this edited contact won't be displayed in the list. On the other hand if you only have one ICE contact and you remove all phones for this and got back, you see the contact detail instead of the ICE contacts because of being empty.

At least I cannot see the dialog informing the user that the contact will be unset as ICE Contact. This is another issue different than this bug

Jose, double check?

commit 379ea4c9dd6d3f8ca2f79ce59c15f6afe6e557c3
Flags: needinfo?(jmcf)
(Assignee)

Comment 18

3 years ago
I didn't remember (thanks to Jose Manuel) that the dialog (which informs the user that the contact will be unset as ICE Contact) is not available in 2.1 because of string freeze (new strings couldn't be uplifted so this dialog is not living in v2.1)
Flags: needinfo?(jmcf)
Roland, does the issue occur in 2.1 because of the lack of warning pop up? Or does it occur because the contacts are not properly remove as ICE?
In the first case, the thing is tracked in bug 1062595, so we can marked our bug as verified. In the second case, can you explain what happens?

Thank you!
Flags: needinfo?(rkunkel)
(In reply to Johan Lorenzo [:jlorenzo] from comment #19)
> Roland, does the issue occur in 2.1 because of the lack of warning pop up?
> Or does it occur because the contacts are not properly remove as ICE?
> In the first case, the thing is tracked in bug 1062595, so we can marked our
> bug as verified. In the second case, can you explain what happens?
> 
> Thank you!

I wrote a new bug concerning this issue: bug 1081696

When all numbers are removed from a ICE contact, that contact should no longer remain set as an ICE contact. In 2.1 when all numbers have been removed, the contact stays set as an ICE contact.

What happens: There is no menu presented to the user and the contact that should no longer be an ICE contact remains as such. After you delete all numbers for the contact, the contact is saved and the user is returned to their contacts list. There they can see that the contact with no number is still assigned as an ICE contact.

I am still able to reproduce this issue in today’s 2.1 Flame build:

Environmental Variables:
----------------------------------------
Device: Flame 2.1
BuildID: 20141015001201
Gaia: 379ea4c9dd6d3f8ca2f79ce59c15f6afe6e557c3
Gecko: 4853208cb48a
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(rkunkel)
What's the plan here?
Flags: needinfo?(crdlc)
(Reporter)

Comment 22

3 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #21)
> What's the plan here?

I'm gonna check this thoroughly and the new bug open by our QA colleagues. Once I have all the info will update

thanks!
(Reporter)

Updated

3 years ago
Flags: needinfo?(crdlc)
(Reporter)

Comment 23

3 years ago
Ryan,

This bug can be considered as fixed on v2.1. The popup does not appear but that's another bug. The bug concerning the behavior described in the title has been fixed.

Updating the flag properly

thanks
status-b2g-v2.1: affected → fixed
Issue still occurs on Flame 2.1

Actual Results: As per comment 23, the popup does not appear, but the contact without phone number appears in ICE Contacts list even after exiting and restarting Contacts app. After updating contact in ICE list to remove phone number the contact still appears in ICE Contacts list.

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141110001201
Gaia: 0ec1925fc37b7c71d129ae44e42516a0cfb013c4
Gecko: 97487a2d1ee6
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [ICE][failed-verification] [QAnalyst-Triage+] → [ICE][failed-verification] [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [ICE][failed-verification] [QAnalyst-Triage?] → [ICE][failed-verification] [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 25

3 years ago
This issue has been verified successfully on Flame 2.1.

Step:
1. Open Address book and tap gettings icon.
2. Set ICE Contact 1 and ICE Contact 2. 
3. Go to the Contact List and tap the ICE Contacts Group.
4. Edit one of the ICE contacts.
5. Remove all telephone numbers of edited contact.
6. Tap Update button and come back to contact detail page.
7. Tap < button come back to ICE Contacts grop.

** There is only one contact appeared.

See attachment: Verify_video.MP4
Reproducing rate: 0/5
Flame2.1 build:
Gaia-Rev        afdfa629be209dd53a1b7b6d6c95eab7077ffcd9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/dc3018cbdbe6
Build-ID        20141123001201
Version         34.0
Flags: needinfo?(jocheng)

Updated

3 years ago
status-b2g-v2.1: fixed → verified

Comment 26

3 years ago
Created attachment 8527469 [details]
Verify_video.3gp

Updated

3 years ago
Flags: needinfo?(jocheng) → needinfo?(hlu)
(In reply to Paladin from comment #25)
> This issue has been verified successfully on Flame 2.1.
> 
> Step:
> 1. Open Address book and tap gettings icon.
> 2. Set ICE Contact 1 and ICE Contact 2. 
> 3. Go to the Contact List and tap the ICE Contacts Group.
> 4. Edit one of the ICE contacts.
> 5. Remove all telephone numbers of edited contact.

  Hi Paladin,
     After check your video, I found you click "delete" icon to remove it. But it should be "Remove all telephone numbers". I think they are NOT same behavior. 
     I try to follow the steps on comment 0, and this issue still could be reproduced. Please follow the steps on comment 0 to check it again. Thank you.

> 6. Tap Update button and come back to contact detail page.
> 7. Tap < button come back to ICE Contacts grop.
> 
> ** There is only one contact appeared.
>
Flags: needinfo?(hlu) → needinfo?(jihao)
status-b2g-v2.1: verified → affected

Comment 28

3 years ago
Created attachment 8528738 [details]
Verify_video_update.3gp

(In reply to Hubert Lu[:hlu] <hlu@mozilla.com> from comment #27)
> (In reply to Paladin from comment #25)
>   Hi Paladin,
>      After check your video, I found you click "delete" icon to remove it.
> But it should be "Remove all telephone numbers". I think they are NOT same
> behavior. 
>      I try to follow the steps on comment 0, and this issue still could be
> reproduced. Please follow the steps on comment 0 to check it again. Thank
> you.

Hi Hubert,
  They are NOT same behavior and this bug has been verified to fail on Flame 2.1.
Steps:
1. Open Address book and tap gettings icon.
2. Set ICE Contact 1 and ICE Contact 2. 
3. Go to the Contact List and tap the ICE Contacts Group.
4. Edit one of the ICE contacts.
5. REMOVE all telephone numbers of edited contact.
6. Tap Update button and come back to contact detail page.
7. Tap < button come back to ICE Contacts grop.
**In the ICE Group list are appearing two contacts.

See attachment: Verify_video_update.3gp and logcat_flame_1854.txt
Reproducing rate: 5/5
Flame2.1 build:
Gaia-Rev        1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/db893274d9a6
Build-ID        20141125001201
Version         34.0
Flags: needinfo?(jihao)

Comment 29

3 years ago
Created attachment 8528743 [details]
logcat_flame_1854.txt
(Reporter)

Comment 30

3 years ago
(In reply to Paladin from comment #28)
> Created attachment 8528738 [details]
> Verify_video_update.3gp
> 
> (In reply to Hubert Lu[:hlu] <hlu@mozilla.com> from comment #27)
> > (In reply to Paladin from comment #25)
> >   Hi Paladin,
> >      After check your video, I found you click "delete" icon to remove it.
> > But it should be "Remove all telephone numbers". I think they are NOT same
> > behavior. 
> >      I try to follow the steps on comment 0, and this issue still could be
> > reproduced. Please follow the steps on comment 0 to check it again. Thank
> > you.
> 
> Hi Hubert,
>   They are NOT same behavior and this bug has been verified to fail on Flame
> 2.1.

but in comment #25 you've verified it successfully :) 

> Steps:
> 1. Open Address book and tap gettings icon.
> 2. Set ICE Contact 1 and ICE Contact 2. 
> 3. Go to the Contact List and tap the ICE Contacts Group.
> 4. Edit one of the ICE contacts.
> 5. REMOVE all telephone numbers of edited contact.
> 6. Tap Update button and come back to contact detail page.
> 7. Tap < button come back to ICE Contacts grop.
> **In the ICE Group list are appearing two contacts.
> 
> See attachment: Verify_video_update.3gp and logcat_flame_1854.txt
> Reproducing rate: 5/5
> Flame2.1 build:
> Gaia-Rev        1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
> Gecko-Rev      
> https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/db893274d9a6
> Build-ID        20141125001201
> Version         34.0

Comment 31

3 years ago
(In reply to Jose Manuel Cantera from comment #30)
> but in comment #25 you've verified it successfully :) 
In comment #25,Step 5:
   When we tap "X" button rather than the delete key in keyboard to remove the phone numbers, this issue does not exist any more.
In comment #28,step 5:
   If  we tap delete key to remove all phone numbers,this issue still exists.
Where do we stand here?
Flags: needinfo?(crdlc)
(Assignee)

Comment 33

3 years ago
Forwarding to Jose
Flags: needinfo?(crdlc) → needinfo?(jmcf)
(Reporter)

Comment 34

3 years ago
I cannot reproduce the bug anymore.
Flags: needinfo?(jmcf)
Depends on: 1113127
I verified this bug on both today's master and 2.1. Like said in comment 27, we have 2 different behaviors. If you delete (by tapping the red button) the phone number, the contact is properly removed from the ICE list. If you clear (by tapping the grey button) the string of the phone number, the contact remains. I filed bug 1113127 to track the fix of the second case.
status-b2g-v2.1: affected → verified
You need to log in before you can comment on or make changes to this bug.