Closed Bug 1070045 Opened 5 years ago Closed 5 years ago

Use of ES6 syntax breaks component showcase

Categories

(Hello (Loop) :: Client, defect)

defect
Not set
Points:
1

Tracking

(firefox34 fixed, firefox35 fixed)

RESOLVED FIXED
Iteration:
36.1
Tracking Status
firefox34 --- fixed
firefox35 --- fixed

People

(Reporter: andreio, Assigned: pkerr)

References

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20140915204924

Steps to reproduce:

In latest fx-team open the ui-showcase.


Actual results:

The page is broken because required files are not included & they use ES6 syntax which requires <script type="application/javascript;version=1.7"> [0] to support "let, const" etc. 

[0] https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Statements/let


Expected results:

Loop components should show up
Blocks: 1020449
As discussed at standup today, we want a regression tests for this so that if the ui-showcase completely fails to load, the automated tests flag it.

It probably wants to be something very much like <https://github.com/mozilla/gecko-dev/blob/master/browser/components/loop/test/shared/frontend_tester.py>.  Perhaps that code could be refactored/overridden (i.e. check_page and get_failure details) to be slightly more generic.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch WIP 1 (obsolete) — Splinter Review
I'm not actively working on this since I'm not very familiar with this code but this at lets more than a white page appear. There are still errors in the console.
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Iteration: --- → 35.2
Points: --- → 1
Flags: qe-verify-
Flags: firefox-backlog+
I just took it all the way...
Attachment #8493463 - Attachment is obsolete: true
Attachment #8493642 - Flags: review?(nperriault)
Comment on attachment 8493642 [details] [diff] [review]
Patch v1: shim contacts React classes when ES6 is not available in the browser used

Review of attachment 8493642 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8493642 - Flags: review?(nperriault) → review+
Thanks for the super-fast review!

Pushed to fx-team as https://hg.mozilla.org/integration/fx-team/rev/121504802da7
Flags: needinfo?(mmucci)
Added to IT 35.2
Flags: needinfo?(mmucci)
Adding leave-open, as this still needs the regression test described in comment 1.
Keywords: leave-open
Assignee: mdeboer → pkerr
Taking up regression testing issue that was left open.
Iteration: 35.2 → ---
Comment on attachment 8493642 [details] [diff] [review]
Patch v1: shim contacts React classes when ES6 is not available in the browser used

Approval Request Comment
Uplift request for patches staged and tested on Fig
Attachment #8493642 - Flags: approval-mozilla-aurora?
Comment on attachment 8493642 [details] [diff] [review]
Patch v1: shim contacts React classes when ES6 is not available in the browser used

I worked with Randell and Maire on uplifting a large number of Loop bugs at once. All of the bugs have been staged on Fig and tested by QE before uplift to Aurora. As well, all of the bugs are isolated to the Loop client. Randell handled the uplift with my approval. I am adding approval to the bug after the fact for bookkeeping.
Attachment #8493642 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: in-testsuite?
Keywords: leave-open
Opened bug 1088006 for the regression test.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Iteration: --- → 36.1
Tests were added in bug 1088006.
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.