Closed Bug 1088006 Opened 5 years ago Closed 5 years ago

Regression Test for "Use of ES6 syntax breaks component showcase"

Categories

(Hello (Loop) :: Client, defect, P2)

defect
Points:
1

Tracking

(firefox39 fixed)

RESOLVED FIXED
mozilla39
Iteration:
39.2 - 23 Mar
Tracking Status
firefox39 --- fixed
Blocking Flags:
backlog tech-debt

People

(Reporter: mreavy, Assigned: standard8)

References

Details

(Whiteboard: [tech-debt])

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1070045 +++

We want to add a regression test for Bug 1070045
https://bugzilla.mozilla.org/show_bug.cgi?id=1070045#c7
backlog: --- → Fx36?
backlog: Fx36? → Fx37?
Whiteboard: [tech-debt]
backlog: Fx37? → Fx38?
We've wanted this or something along these lines for a while, and I've got a partial patch in progress somewhere, so taking.
Assignee: nobody → standard8
backlog: Fx38? → tech-debt
Priority: -- → P2
Having just hit this again, Dan talked me into finishing this patch off.

Here it is. We use the same structure as our unit tests so that we can use the Marionette harness. I've tested the failure modes by backing out the various parts of https://hg.mozilla.org/integration/fx-team/rev/c4d7c9f94f61 and checking the error output.

It works for me locally, but I'll push it to try before
Attachment #8576197 - Flags: review?(dmose)
Comment on attachment 8576197 [details] [diff] [review]
Hook up Loop's ui-showcase to unit tests so that we don't keep on breaking it, and so that it can possibly catch use of es6 errors.

Review of attachment 8576197 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, r=dmose
Attachment #8576197 - Flags: review?(dmose) → review+
https://hg.mozilla.org/integration/fx-team/rev/901d9d1beec0
Iteration: --- → 39.2 - 23 Mar
Target Milestone: --- → mozilla39
Rank: 3
Flags: firefox-backlog+
https://hg.mozilla.org/mozilla-central/rev/901d9d1beec0
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.