RSS version history only goes to page 1

VERIFIED FIXED in 2014-10

Status

addons.mozilla.org Graveyard
Public Pages
P4
normal
VERIFIED FIXED
4 years ago
2 years ago

People

(Reporter: infinity0, Assigned: infinity0)

Tracking

unspecified
2014-10

Details

(Assignee)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 Iceweasel/31.1.0
Build ID: 20140903072827

Steps to reproduce:

Currently, I can get an RSS feed of the Version History of an addon at (e.g.):

https://addons.mozilla.org/en-US/firefox/addon/saved-password-editor/versions/format:rss

However, this only goes to page 1. I cannot get page 2 of the Version History in RSS format.


Actual results:

I tried the following URLs:

https://addons.mozilla.org/en-US/firefox/addon/saved-password-editor/versions/format:rss?page=2

But this only gives me page 1.

I also tried some variants:

https://addons.mozilla.org/en-US/firefox/addon/saved-password-editor/versions/format:rss?page=2
https://addons.mozilla.org/en-US/firefox/addon/saved-password-editor/versions/?page=2&format:rss
https://addons.mozilla.org/en-US/firefox/addon/saved-password-editor/versions/?page=2&format=rss
https://addons.mozilla.org/en-US/firefox/addon/saved-password-editor/versions/?page=2format:rss

The first URL just gave me page 1, and the other URLs just gave me the HTML page. The last one seems obviously wrong, but is mentioned in the source code of the HTML page:

https://addons.mozilla.org/en-US/firefox/addon/saved-password-editor/versions/?page=2


Expected results:

There should be some way of getting page 2 of Version History in RSS format.
(Assignee)

Comment 1

4 years ago
This is preventing us from fixing https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=762310, where we automatically include the version history into the package. We'd like to continue using RSS, as the format is cleaner and less likely to change.
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 3

4 years ago
Hello, I would be happy to write a patch but I don't know where the source code is. Is the AMO website source code even published anywhere? Please give me some tips.
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(clouserw)
Resolution: WONTFIX → ---
The source code is at https://github.com/mozilla/olympia along with the links to documentation.  Interested folks hang out in #amo on irc.mozilla.org but there are no active developers.  Feel free to reopen if you get a pull request. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(clouserw)
Resolution: --- → WONTFIX
(Assignee)

Comment 5

4 years ago
Pull request sent: https://github.com/mozilla/olympia/pull/301
Assignee: nobody → infinity0
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WONTFIX → ---
Target Milestone: --- → 2014-10
Priority: -- → P4
Fixed in https://github.com/mozilla/olympia/commit/badaa3488e57ef0773315ab8f2913a5eef528216
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → FIXED

Comment 7

3 years ago
Verified as fixed in FF33(Win7) in addons-dev.allizom.org
The second page of the rss can pe accessed using "format:rss?page=2"
Postfix screencast: http://screencast.com/t/DCJ01kgBJu6H
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.