History: titles in RTL are invisible when they can't fit the screen

VERIFIED FIXED

Status

()

Firefox for Android
Awesomescreen
P1
normal
VERIFIED FIXED
3 years ago
4 months ago

People

(Reporter: dror3go, Unassigned)

Tracking

(Blocks: 1 bug, {rtl, testcase})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8492912 [details]
Example of the bug

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140917194002

Steps to reproduce:

When viewing the browser's history, the titles of long pages with RTL text are hidden if they are wider than the browser's width.
I suspect that this may be a bug in FadedTextView when the layout direction is RTL
Thanks for filing, that looks bad. +CC Lucas
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
OS: Windows 7 → Android
Hardware: x86_64 → ARM
tracking-fennec: ? → ---
Blocks: 702845
Keywords: rtl
Hardware: ARM → All
Version: Firefox 32 → unspecified
This only occurs if the title begins RTL, and doesn't affect the tab tray or the URL bar.
Test page:

http://people.mozilla.org/~rnewman/rtl/title.html

Updated

3 years ago
Keywords: testcase
Priority: -- → P1

Updated

9 months ago
QA Contact: ioana.chiorean

Comment 5

6 months ago
Seems to be fixed in latest Nightly builds.
There still a minor issue related to this, see bug 935388 comment 8.

Closing as RESOLVED FIXED.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Hi all,

Tested on latest Nightly (Arabic) and the results are here:
Phone:
- LG G4 (Android 5.1) - https://i.imgur.com/yKu00bZ.png
Tablet:
- Asus ZenPad 8 (Android 6.0.1) - https://i.imgur.com/Pg0KzGQ.png

We will test again after bug 1321635 and bug 1321633 are fixed.

Comment 7

4 months ago
Created attachment 8827919 [details]
Long RTL title name

Using the test page I can see this was fixe d and the pending bugs were also fixed. 
(In reply to Richard Newman [:rnewman] from comment #4)
> http://people.mozilla.org/~rnewman/rtl/title.html

Tested on Fennec 53.0a1 2017-01-17

Updated

4 months ago
Status: RESOLVED → VERIFIED
Blocks: 1319302
You need to log in before you can comment on or make changes to this bug.