Please deploy Loop-Client 0.6.1 code to production

VERIFIED FIXED

Status

Cloud Services
Operations: Deployment Requests
P1
major
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: standard8, Assigned: bobm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa+])

(Reporter)

Description

3 years ago
We'd like to deploy the loop-client 0.6.0 release to production.

https://github.com/mozilla/loop-client/releases/tag/0.6.0

This can be done after 0.6.0 is on staging and verified. Preferably we'd like to deploy Tuesday/Wednesday if possible.

There are configuration and process changes required for release:

- Removed:
-- LOOP_PENDING_CALL_TIMEOUT / loop.config.pendingCallTimeout
- Added:
-- LOOP_FEEDBACK_API_URL / loop.config.feedbackApiUrl
-- LOOP_FEEDBACK_PRODUCT_NAME / loop.config.feedbackProductName

For production, these can be created in config.js by "make config":

loop.config.feedbackApiUrl for staging should be "https://input.mozilla.org/api/v1/feedback"
loop.config.feedbackProductName should be "Loop"

See README.md for more info about how to update this: https://github.com/mozilla/loop-client/blob/9a6301de54ada806d599b06d9d285166876d1dfd/README.md#configuration


Process changes:

We need to pull in the terms of service and include these in on staging, this is scripted, and can be generated by running "make install".

The ToS are generated as static pages and should show up under:

https://call.mozilla.com/legal/terms/
:rpapa will handle this one as well...
Whiteboard: [qa+]
(Reporter)

Comment 2

3 years ago
Bumping to 0.6.1 per the staging bug.
Summary: Please deploy Loop-Client 0.6.0 code to production → Please deploy Loop-Client 0.6.1 code to production
(Reporter)

Comment 3

3 years ago
(In reply to Mark Banner (:standard8) from comment #0)
> loop.config.feedbackApiUrl for staging should be
> "https://input.mozilla.org/api/v1/feedback"

Correction, this is the correct url for *production* not staging.
VERIFIED HOST RUNNING FOLLOWING CODE:

puppet-config-loop 20140924112304-1 x86_64 15370
loop-client-svcops 0.6.1-1 x86_64 11469095

/data/loop-client/content/VERSION.txt:
0.6.1
48f57f403e52f74858fa2783bd7f470e43d2752b Wed, 24 Sep 2014 13:06:25 +0100

FILES ON STAGE

/opt:
aws  openresty  stackdriver   ec2  rh

/data:
hekad  loop-client

/etc:
heka.d

/etc/puppet/yaml/app:
loop_client.dev.yaml
loop_client.prod.yaml
loop_client.stage.yaml
loop_client.yaml
loop_server.dev.yaml
loop_server.prod.yaml
loop_server.stage.yaml
loop_server.yaml

LOGS:
/var/log/circus.log
/var/log/hekad
/media/ephemeral0/nginx/logs 

HEKA
/data/hekad
/etc/heka.d

PROCESSES
stackdriver, nginx, python, circus, heka 

QUICK CHECKS

https://call.stage.mozaws.net/VERSION.txt:
0.6.1
48f57f403e52f74858fa2783bd7f470e43d2752b Wed, 24 Sep 2014 13:06:25 +0100

curl -I https://call.stage.mozaws.net:
HTTP/1.1 200 OK
Accept-Ranges: bytes
Content-length: 2523
Content-Type: text/html
Date: Wed, 24 Sep 2014 15:25:05 GMT
ETag: "5422b811-9db"
Last-Modified: Wed, 24 Sep 2014 12:24:49 GMT
Vary: Accept-Encoding
Connection: keep-alive

https://call.stage.mozaws.net/config.js:
var loop = loop || {};
loop.config = {serverUrl: 'https://loop.stage.mozaws.net'};

https://call.stage.mozaws.net/:
Welcome to the WebRTC! web client.

https://loop.stage.mozaws.net/:
{"name":"mozilla-loop-server","description":"The Mozilla Loop (WebRTC App) server","version":"0.12.2","homepage":"https://github.com/mozilla-services/loop-server/","endpoint":"https://loop.stage.mozaws.net","fakeTokBox":false,"fxaOAuth":true,"i18n":{"defaultLang":"en-US","lang":"en-US"}}
config.js file should be https://call.stage.mozaws.net/config.js

And returns:

var loop = loop || {};

loop.config = {
  serverUrl: 'https://loop.stage.mozaws.net',
  feedbackApiUrl: 'https://input.allizom.org/api/v1/feedback',
  feedbackProductName: 'Loop'
};

Also https://call.stage.mozaws.net/VERSION.txt

0.6.1
48f57f403e52f74858fa2783bd7f470e43d2752b Wed, 24 Sep 2014 13:06:25 +0100
Comment #4 meant for stage deploy bug, please disregard
:deanw or :bobm please add the actual behind the scenes deployment of this...
(copy/paste from IRC as needed)

Once the Stage bug is marked Verified, then we can move forward and get the DNS pointing to the new stack.
:rpapa can verify from there officially.
Assignee: nobody → bobm
Status: NEW → ASSIGNED
QA Contact: rpappalardo
Also, QA will need help verifying /data/loop-client/content/config.js and the yaml files in Production.
We need to make sure they contain different values than Stage (values appropriate for Production).
(Assignee)

Comment 9

3 years ago
(In reply to James Bonacci [:jbonacci] from comment #7)
> :deanw or :bobm please add the actual behind the scenes deployment of this...
> (copy/paste from IRC as needed)

Stage bug has been marked verified.  :deanw has already built this new stack.  I have directed call.mozilla.com over to it.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
File and quick checks look OK, but ran into this issue when testing client on nightly:
https://bugzilla.mozilla.org/show_bug.cgi?id=1072685

Is anyone else seeing this?
OK, so we hold here until we figure out whether or not bug 1072685 is caused by this deploy.
I saw Nightly issues earlier in the day, so it comes down to when was the DNS switched to the new stack.

And, I am pretty sure I saw no errors while using Aurora.

If this turns out to be a 0.12.2 issue, we will need to roll back pretty quickly.


Anybody on the client team that can triage on this on Aurora and Nightly?
Severity: normal → major
Priority: -- → P1
Depends on: 1072685
No longer depends on: 1072685
My error above. I meant to state the loop-client release of 0.6.1, not the server release of 0.12.2.
Silly me...

Quick testing by me and the client team shows that Loop appears to work well with this release.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.